• ¬°Welcome to the WhatPulse Forums!
Hello There, Guest! Login Register


Poll: Do you have this issue?
You do not have permission to vote in this poll.
Yes
50.00%
2 50.00%
No
50.00%
2 50.00%
Total 4 vote(s) 100%
* You voted for this item. [Show Results]

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Title: High CPU Usage - On wake-up
Threaded Mode
#1
Hi,

I would like to bring to attention if this was not already brought to your attention recently, I found this problem from 2012 and 2013.

When my laptop is put to sleep, next time I wake up the laptop, Whatpulse will start using 20-50% CPU. I tried leaving this to settle down, but after 3-4hrs it was still the same. A simple, open task manager and kill process will fix the issue as the watchdog will reopen whatpulse.

But this is annoying to say the least.

From performed tests, it does not matter if it's on battery power or not, it will do this 99% of the times I put my laptop to sleep and wake it back up.

To minimize posts such as "I get this too", please vote on the poll I have created so the devs will see that this is a problem for most users ( I assume it is, cause this happens on 3 machines)

Thanks,
 
Reply
#2
I couldn't replicate this issue. I tested it on 3 different computers and got the following results:

0.1-0.4% usage after resuming from sleep mode on my laptop (Intel i7-8750H)
0.1-0.3% usage after resuming my desktop (AMD Ryzen 7 1700)
0.4-5.2% usage after resuming my other desktop (Intel i3-7100)
 
Reply
#3
(05-20-2019, 07:55 AM)Inquizitor Wrote: I couldn't replicate this issue. I tested it on 3 different computers and got the following results:

0.1-0.4% usage after resuming from sleep mode on my laptop (Intel i7-8750H)
0.1-0.3% usage after resuming my desktop (AMD Ryzen 7 1700)
0.4-5.2% usage after resuming my other desktop (Intel i3-7100)

Will post screenshots as soon as I have some free time to do so.
 
Reply
#4
Sorry for the long delay, here is a screenshot of it happening
https://gyazo.com/f2f1c20a566a485194ea2b40db089543
https://gyazo.com/d54e228c7847921fb05f828a19986aa3

this has been going like this for over 20mins now, and just restarted whatpulse to "fix" it
 
Reply
#5
A little update, I am noticing that when this issue occurs, I always find an update error window from whatpulse, even after closing this window, the high cpu remains.
 
Reply
#6
Very professional, no answer in 2 months time, and yet I am facing this issue every single time I close my laptop and open it again. Whatpulse always starts taking up too much of my CPU.

Yes,this is a free service, but I think there is a limit of how much anyone could take. I'm removing this from all my machines and won't recommend it for anyone.
 
Reply
#7
Bug is still happening on daily basis on my laptop MSI 7REX.

Just noticed it happens more often when I have the Icybox connected to the laptop.
 
Reply
#8
They don't seem to be responding anywhere
 
Reply
#9
yeah while the issue is still present, every time I open my laptop and the OS wakes up I have to kill whatpulse, it will auto restart, but it's annoying. seriously considering fo uninstalling the app, even though I have years of data on it Sad
 
Reply
#10
I have a similar issue. I think it is related with (virtual) network cards appearing/disappearing as I can reproduce it under linux by building docker containers. That usually makes whatpulse hang, start using a lot of CPU and tons of RAM until I kill it and then the system takes up to an hour to slowly get the RAM back and run normal. Seen it with resuming from standby too but pretty seldom - and I'm not doing that too often though, I usually switch them off, NVMe-SSD boots up fast enough and I had it a few times that the notebook switched itself on inside the bag and almost died from the heat...
 
Reply
  


Possibly Related Threads…
Thread Author Replies Views Last Post
  No Download counting on high speeds iOChris 14 8,416 01-14-2022, 06:53 PM
Last Post: TehMoff
  WhatPulse slow loading, massive HDD usage Redirect Left 0 167 01-11-2022, 03:34 AM
Last Post: Redirect Left
  bandwidth usage not being tracked khalby786 0 657 10-20-2021, 09:47 AM
Last Post: khalby786
Bug WIndows High CPU Usage necenzurat 15 15,273 01-17-2021, 12:08 PM
Last Post: smitmartijn
Exclamation Constant 6 GB+ Ram Usage on MacOS teslasagan 6 3,493 09-06-2020, 08:52 PM
Last Post: teslasagan
  Heatmap On = High CPU Usage Dark_wizzie 3 4,492 03-19-2017, 07:28 AM
Last Post: Dark_wizzie
  CPU usage spikes on OS X eithel 8 7,627 06-19-2016, 01:56 PM
Last Post: smitmartijn
  Still no High DPI support ajfoegen 1 3,138 09-29-2015, 08:05 AM
Last Post: Megachip
  2.6.1 uses high amount of 'energy' on OS X haroenv 3 4,656 09-23-2015, 06:21 PM
Last Post: wootah
  [SOLVED] Linux 2.4.1 critical CPU usage+temp when no network connection vonunov 1 3,928 03-13-2015, 08:41 AM
Last Post: smitmartijn

Forum Jump:


Browsing: 1 Guest(s)