WhatPulse Forums » Support » Client software v » [CLOSED] Network traffic not recorded on Ubuntu 16.04 LTS Welcome back, Guest.


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[CLOSED] Network traffic not recorded on Ubuntu 16.04 LTS
07-08-2016, 06:02 AM, (This post was last modified: 10-22-2016, 06:34 PM by smitmartijn.)
#1
[CLOSED] Network traffic not recorded on Ubuntu 16.04 LTS
Hello!

I'm running Ubuntu 16.04 LTS on my workstation together with the latest version of WhatPulse (2.7.1).
Keys, Clicks and Uptime is recorded and pulsed correctly, but I am not able to get it to record Download and Upload without running it as root.

I have run: setcap cap_net_raw,cap_net_admin=eip ./whatpulse (even as root), but still, it doesn't seem to have the correct permissions to record data.

Error I'm getting is:
DEBUG Couldn't open device "eno1" : eno1: You don't have permission to capture on that device (socket: Operation not permitted)

Workaround would be to run it as root, but then the GUI isn't shown.
Reply
07-08-2016, 09:35 PM,
#2
RE: Network traffic not recorded on Ubuntu 16.04 LTS
Hi,

Could you try a slightly different syntax? I'm seeing this one related to 16.04:

setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' /path/to/whatpulse

Otherwise it might be an idea to run it with setuid:

chown root /path/to/whatpulse
chmod u+s /path/to/whatpulse
Reply
08-05-2016, 08:05 AM, (This post was last modified: 08-05-2016, 08:08 AM by GnaXi.)
#3
RE: Network traffic not recorded on Ubuntu 16.04 LTS
Sorry about the late reply! When I try the suggested command, I get:

Failed to set capabilities on file `/whatpulse' (Invalid argument)
The value of the capability argument is not permitted for a file. Or the file is not a regular (non-symlink) file

I also tried changing owner of whatpulse to root as suggested.
Reply
09-09-2016, 12:25 PM,
#4
RE: Network traffic not recorded on Ubuntu 16.04 LTS
Any idea to what else I could try?
Reply
09-15-2016, 03:33 AM,
#5
RE: Network traffic not recorded on Ubuntu 16.04 LTS
Not for permanent, but try running it as root, see if that resolves the error and if it's running properly.

If it does, then it's still an issue of permissions. Maybe you've got selinux or something similar set up? If you've done the setcap stuff, I'm afraid I don't have much else for you..
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  WhatPulse on Ubuntu not recording network metrics [solved] Code-E 2 366 11-03-2021, 10:29 PM
Last Post: Code-E
  Ubuntu issues with network stats XploD 1 416 10-20-2021, 08:21 AM
Last Post: XploD
  Whatpulse 3.2 on Ubuntu 21.04 Lieutenant_Dan 3 1,241 09-10-2021, 11:30 AM
Last Post: kitliasteele
  Modifiers key on Ubuntu Erwane 1 766 06-09-2021, 04:38 AM
Last Post: AdrianLaurean
  Network stats displayed / counted wrong MrElliwood 0 1,027 01-30-2021, 10:10 PM
Last Post: MrElliwood
  Error: "Network access is disabled." Jourei 5 2,232 01-20-2021, 07:01 AM
Last Post: penguin2233
Question 3.0 not tracking network stats on macOS numbermaniac 0 1,006 01-02-2021, 11:36 AM
Last Post: numbermaniac
  3.0 Mac Network Not Tracking mewturn 3 1,549 12-30-2020, 05:57 AM
Last Post: mewturn
  Cannot start WhatPulse using Ubuntu 19.10 Adrriii 8 6,553 11-05-2020, 02:23 PM
Last Post: Juje
  Portable Mode Network Recording ItsRiftzy 1 1,687 09-04-2020, 03:25 PM
Last Post: smitmartijn

Forum Jump:


Users browsing this thread: 1 Guest(s)