• ¬°Welcome to the WhatPulse Forums!
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Title: [CLOSED] docker and whatpulse
Threaded Mode
#1
So I have had this problem for a while now..

It seems whatpulse gets completely confused when I start to build docker images/containers.

Whatpulse will crash, I will try and kill it but it just goes to a zombie process.

I have looked and it seems to hogging the crap out of ksoftirqd. So it seems to be interrupt requests.

Has anyone else had this?

prime example of this is as I write this post.

1.7 GiB + 2.1 GiB = 3.7 GiB whatpulse

PID USER PR NI VIRT RES %CPU %MEM TIME+ S COMMAND
3 root 20 0 0.0m 0.0m 44.0 0.0 1:33.39 S ksoftirqd/0
16986 ben 9 -11 611.8m 11.7m 18.7 0.1 0:13.96 S pulseaudio
14 root 20 0 0.0m 0.0m 14.7 0.0 0:34.19 S ksoftirqd/1

here is a strace of whatpulse

https://gist.github.com/81d1fdde737d608f6e72
 
Reply
#2
Hi,

The only thing I can think of is that the client does not like the docker0 virtual interface. Could you try to turn off network stats and see if that fixes it?
 
Reply
#3
I tried to ignore the docker adapter, but still caused the same problem and had to restart.

Now gone to settings and disabled network stats fully.

Is it possible to get this fixed Sad It seems quite a major bug!
 
Reply
#4
nope, evening ignoring causes problems

627.6 MiB + 1.9 GiB = 2.5 GiB whatpulse
 
Reply
#5
I don't think ignoring would fix it as I assume the docker0 interface would create virtual interfaces for each container. Those virtual interfaces are probably the ones that the client can't handle.

Could you confirm disabling the network counter completely stops the client from crashing when you run docker?

If so, you might want to leave it disabled when you work with it for now. I've put it on the todo, it might be an easy fix, it might not be.
 
Reply
#6
I have disabled network counter but it still causes whatpulse to have huge memory problems + locks up my system.

For now I am not running whatpulse when doing docker work (which currently is most days Sad )
 
Reply
#7
okay disabling network stats does seem to make a difference, I had to do a reboot.

I had same problem on my laptop too, so had to disable stats on that as well
 
Reply
#8
Great, thanks for the feedback. I'll put that in the help center for the time being.
 
Reply
#9
when do you think you'll get a fix for this??

This is a real major bug for me, as I want to track my whatpulse stuff still...

It keeps messing up my machine. If it disable/enable network, you *have* to reboot, otherwise it just causes crazy irq requests and sucks all your memory Sad
 
Reply
#10
Not sure, the todo list is pretty long with more stuff with a higher priority then this one, as you are maybe 1 of 5 users who use this on their local machine. Not that you get anything from this answer, but I can't give a proper one.
 
Reply
  


Possibly Related Threads…
Thread Author Replies Views Last Post
  WhatPulse slow loading, massive HDD usage Redirect Left 0 125 01-11-2022, 03:34 AM
Last Post: Redirect Left
  Whatpulse restarting several times cavveman 2 187 01-10-2022, 05:28 PM
Last Post: cavveman
  I can't use new versions "WhatPulse". Fluttermina 9 589 01-09-2022, 02:31 PM
Last Post: Fluttermina
  Whatpulse is not tracking anything on linux Xabec 2 684 11-29-2021, 09:08 AM
Last Post: Xabec
  Whatpulse client backup: Access is denied. Galaxied 1 690 11-28-2021, 10:31 AM
Last Post: smitmartijn
  WhatPulse on Ubuntu not recording network metrics [solved] Code-E 2 718 11-03-2021, 10:29 PM
Last Post: Code-E
  WhatPulse randomly stop tracking keyboard strokes anandinasu 0 573 09-29-2021, 03:37 AM
Last Post: anandinasu
  Whatpulse 3.2 on Ubuntu 21.04 Lieutenant_Dan 3 1,676 09-10-2021, 11:30 AM
Last Post: kitliasteele
  [SOLVED] WhatPulse Refuses to Start automatically. iisacc 11 14,355 08-23-2021, 09:45 PM
Last Post: Tealdragon204
  Whatpulse doesn't track internet up/down correctly on gigibit internet Deuss 2 987 08-19-2021, 08:32 PM
Last Post: lvh1

Forum Jump:


Browsing: 2 Guest(s)