• ¡Welcome to the WhatPulse Forums!
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Title: [SOLVED] Linux 2.4.1 critical CPU usage+temp when no network connection
Threaded Mode
#1
https://www.youtube.com/watch?v=ZN42VAoX_vA

I'm a bit late upgrading to 2.5, where this issue isn't reproduced. It seems this version has been out for some months now, but I'm posting this in case someone runs into the same problem and didn't think to upgrade, or in case some conditions in 2.5 can cause the same behavior. I don't see anything about this in the new version blog posts, so maybe there's still some chance it could cause a problem.

When WhatPulse 2.4.1 is configured to collect network stats and there is no network connection, it immediately pegs a CPU core and causes the temperature to climb to critical levels. In the video, my uptime is 9 minutes because I didn't notice and the temp climbed until my laptop powered off.

I start WhatPulse a couple of times with a connection to show normal behavior. Then I down the network interface and start WhatPulse again to show the problem. You can see CPU % and temp (which climbed to 80C before I killed WP) at the bottom of the screen, and more resource monitoring at the top.
 
Reply
#2
Good to see that it's not reproducible in 2.5. There have not been able direct changes to the Linux networking no, but it was compiled on a newer version of Linux, so that might have been related to this being fixed in 2.5.

Thanks for the info!
 
Reply
  


Possibly Related Threads…
Thread Author Replies Views Last Post
  Whatpulse is not tracking anything on linux Xabec 2 204 11-29-2021, 09:08 AM
Last Post: Xabec
  WhatPulse on Ubuntu not recording network metrics [solved] Code-E 2 290 11-03-2021, 10:29 PM
Last Post: Code-E
  bandwidth usage not being tracked khalby786 0 177 10-20-2021, 09:47 AM
Last Post: khalby786
  Ubuntu issues with network stats XploD 1 351 10-20-2021, 08:21 AM
Last Post: XploD
  [SOLVED] WhatPulse Refuses to Start automatically. iisacc 11 13,149 08-23-2021, 09:45 PM
Last Post: Tealdragon204
  WhatPulse error on Linux (Elementary-OS 6) Suxhe 0 599 06-13-2021, 10:56 PM
Last Post: Suxhe
  Network stats displayed / counted wrong MrElliwood 0 955 01-30-2021, 10:10 PM
Last Post: MrElliwood
  Snap fails on Manjaro Linux madhead 6 2,327 01-22-2021, 04:40 PM
Last Post: madhead
  3.0 for Linux Bzzz 5 2,140 01-22-2021, 03:43 PM
Last Post: flotwig
  Error: "Network access is disabled." Jourei 5 2,113 01-20-2021, 07:01 AM
Last Post: penguin2233

Forum Jump:


Browsing: 1 Guest(s)