Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] WhatPulse Refuses to Start automatically.
Solution in Last Post!

Hello all,

I've been struggling with WhatPulse for a few months now, not so much for how it works or what it does..
My issue is that I can not get WhatPulse to start on boot.
I've tried enable/disable of UAC, enable/disable run as administrator.
Uninstalls, reinstalls, upgrades to the lastes version (2.2.1 at time of writing), however it just refuses to load on boot.

I'm running Windows 8, never had this issue with previous versions of windows, but since doing a clean slate install with windows 8 it's never played ball.

I even purchased the premium package in hopes it was perhaps just a premium option now, but still no juice.

If anyone can knock this one on the head I'd be grateful.
Have you tried using the Windows 8 startup manager itself? (

Perhaps the client is kept from editing the registry settings that are needed for the startup by your antivirus or other security program.
Yes sir, I have investigated the startup, it's in the start-up section in the manager, and enabled.

Could you tell me precisely what the registry should have to enable startup? I can go thru and double check/manually correct thru the reg if needed.

A little more info:
Windows 8 (x86 os on x64 arch)
AVG antivirus.
Never had/have any permissions issues with anything else I run.
Location: HKEY_CURRENT_USER\\Software\\Microsoft\\Windows\\CurrentVersion\\Run\

There should be a key there called 'whatpulse' with the path to the whatpulse.exe as value.

If it does exist, please check the app.log file inside the data directory to see whether Windows actually tries to start the client..if it tries to start the client, the app.log should have an error message saying why it can't start it.
Seems like whatpulse will start when "Desktop" starts first time. So if you only use Metro apps and never launched the Desktop, whatpulse possible will not start.

Will this match your Problem?
Okay, I've checked the reg key, it exists and points to the correct place.
Also, in regards to the "Desktop", I've also thought it may be that, but tested it previously, starting desktop and leaving it to sit.. doesn't start.

here's the latest in my app.log, it doesn't try to start at all without a manual start. So this log only existed after I manually started whatpulse.

Quote:16-10-2013 17:23:48.905 INFO "Starting WhatPulse 2.2.1..."
16-10-2013 17:23:49.115 DEBUG Installed CrashRpt!
16-10-2013 17:23:49.985 DEBUG Database file: "C:/Users/iisacc/AppData/Local/WhatPulse/whatpulse.db"
16-10-2013 17:23:50.260 DEBUG Database check: "ok"
16-10-2013 17:23:50.261 DEBUG Opened database in: 288 ms
16-10-2013 17:23:50.272 DEBUG Running WhatPulse as Administrator! :-)
16-10-2013 17:23:50.272 DEBUG Encrypted file: "C:/Users/iisacc/AppData/Local/WhatPulse/whatpulse.wpw"
16-10-2013 17:23:52.698 DEBUG Opening GeoIP database: "C:/Users/iisacc/AppData/Local/WhatPulse/GeoIP.dat"
16-10-2013 17:23:53.060 DEBUG WhatPulse 2.2.1 has started
16-10-2013 17:23:55.042 DEBUG Starting timers and collector..
16-10-2013 17:23:55.042 DEBUG enableInputHook: true
16-10-2013 17:23:55.042 DEBUG Starting PcapNetworkTrafficMonitor..
16-10-2013 17:23:55.042 DEBUG LowLevelHookHandler starting
16-10-2013 17:23:55.043 DEBUG Enabling lowlevel input hooks
16-10-2013 17:23:55.075 DEBUG Found new interface: 12 "{8BABFAAD-D60A-4C68-B8FB-99DA1B51B1D7}" "BC:AE:C5:2D:03:C4" "Qualcomm Atheros AR8131 PCI-E Gigabit"
16-10-2013 17:23:55.075 DEBUG PcapNetworkTrafficMonitor: Starting interface 12
16-10-2013 17:23:55.131 DEBUG pcap thread started on interface "\Device\NPF_{8BABFAAD-D60A-4C68-B8FB-99DA1B51B1D7}"

I just added an exception in my antivirus for the .exe, reboooted and still no go, so that rules out the AV software.
No idea why your Windows won't start the app then...I suggest looking for a solution globally , as there are quite a few posts regarding to programs not starting on Windows 8&7, as I've just seen:
I've tried a couple of these fixes, still no joy.
I did however manage to capture this error from the final step of install.
Final step being closing the installer and starting whatpulse (checkbox inside installer.)

link to online ccopy if you cannot see attachment -

Attached Files
.png   setupfail.png (Size: 8.77 KB / Downloads: 539)
Okay, I've finally fixed the issue. Thanks to all who helped out to get this one done.
As suspected it wasn't a WhatPulse issue, but a Windows 8 permissions error.

It's a well hidden option buried deep within windows settings.
I fixed it using this method.
In control panel, goto "local security policy" > "local policies" > "security options" and [u]disable[/u] "User Account Control: run all administrators in admin approval mode"

Upon shutdown and reboot, finally WP starts automatically once Desktop is loaded.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Cannot log in on Whatpulse client riddl3r 0 102 Today, 06:10 AM
Last Post: riddl3r
  WhatPulse slow loading, massive HDD usage Redirect Left 0 180 01-11-2022, 03:34 AM
Last Post: Redirect Left
  Whatpulse restarting several times cavveman 2 240 01-10-2022, 05:28 PM
Last Post: cavveman
  I can't use new versions "WhatPulse". Fluttermina 9 707 01-09-2022, 02:31 PM
Last Post: Fluttermina
  Whatpulse is not tracking anything on linux Xabec 2 763 11-29-2021, 09:08 AM
Last Post: Xabec
  Whatpulse client backup: Access is denied. Galaxied 1 777 11-28-2021, 10:31 AM
Last Post: smitmartijn
  WhatPulse on Ubuntu not recording network metrics [solved] Code-E 2 781 11-03-2021, 10:29 PM
Last Post: Code-E
  WhatPulse randomly stop tracking keyboard strokes anandinasu 0 614 09-29-2021, 03:37 AM
Last Post: anandinasu
  Whatpulse 3.2 on Ubuntu 21.04 Lieutenant_Dan 3 1,740 09-10-2021, 11:30 AM
Last Post: kitliasteele
  Whatpulse doesn't track internet up/down correctly on gigibit internet Deuss 2 1,050 08-19-2021, 08:32 PM
Last Post: lvh1

Forum Jump:

Users browsing this thread: 1 Guest(s)