WhatPulse Forums » Support » Client software v » 3.0 heat map issues Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
3.0 heat map issues
12-29-2020, 12:49 AM (This post was last modified: 12-29-2020 11:26 AM by smitmartijn.)
Post: #1
Bug 3.0 heat map issues
Just upgraded to Whatpulse 3.0 and it's reset my stats. because this happens so darn often with Whatpulse I have backups but they don't seem compatible with 3.0.

If you're going to force a wipe on our client stats then at least make it so all heatmap data (such as the keyboard heatmap) is pulsed online. that way we can still view the heatmaps online.

it's the main damn reason I use this application, to view the keyboard heatmap, but it breaks or resets so often and always without warning so you go and check it and it's been reset but you don't know how long, so you have to make sure to have several backups.
Find all posts by this user
Quote this message in a reply
12-29-2020, 04:11 AM
Post: #2
RE:
(12-29-2020 12:49 AM)Hakisak Wrote:  Just upgraded to Whatpulse 3.0 and it's reset my stats. because this happens so darn often with Whatpulse I have backups but they don't seem compatible with 3.0.

If you're going to force a wipe on our client stats then at least make it so all heatmap data (such as the keyboard heatmap) is pulsed online. that way we can still view the heatmaps online.

it's the main damn reason I use this application, to view the keyboard heatmap, but it breaks or resets so often and always without warning so you go and check it and it's been reset but you don't know how long, so you have to make sure to have several backups.

That's a bummer, heatmaps are the main other thing I pay attention to other than key count. Do you know if keys were reset too? I like to pulse after reaching a certain amount, usually a big even number.
Find all posts by this user
Quote this message in a reply
12-29-2020, 04:51 AM (This post was last modified: 12-29-2020 04:52 AM by Hakisak.)
Post: #3
RE:
(12-29-2020 04:11 AM)Radeax Wrote:  That's a bummer, heatmaps are the main other thing I pay attention to other than key count. Do you know if keys were reset too? I like to pulse after reaching a certain amount, usually a big even number.

It all reset for me (yes; total (and unpulsed) keys, clicks, up-l down-l). it's all still on the website obviously but actual heatmaps are all client side unfortunately.

my old database file was 200+ megabytes and everytime I go and replace my current database it just doesn't work (you could always use backups with the old client).

Edit: so don't update if you want your heatmaps. I might go back to the old client and use my backup if they don't fix this asap.
Find all posts by this user
Quote this message in a reply
12-29-2020, 11:25 AM
Post: #4
RE: 3.0 Heat map issues
Hi,

Sorry that happened to you - but there's nothing in the client preventing you from using the database of an older client. Nothing changed in the structure, just the way of accessing it. I'm seeing tons of people update without problems, so it isn't a structural issue.

What happened when you first started 3.0? And what happens when you use your old database and start the client?
Visit this user's website Find all posts by this user
Quote this message in a reply
12-30-2020, 08:06 AM
Post: #5
RE: 3.0 Heat map issues
(12-29-2020 11:25 AM)smitmartijn Wrote:  Hi,

Sorry that happened to you - but there's nothing in the client preventing you from using the database of an older client. Nothing changed in the structure, just the way of accessing it. I'm seeing tons of people update without problems, so it isn't a structural issue.

What happened when you first started 3.0? And what happens when you use your old database and start the client?

Ok, I doublechecked and I think I know what's going on.
it seems my Second PC is fine (everything moved across).
My main PC is the one with the troubles.

I use freefilesync to backup stuff onto other drives. but just now I used winrar to zip the folder before I stuff around with it, an error comes up saying the files are in use.
When I exit whatpulse it zip's like it should.

so I think what happened was the old database I was trying to use is corrupt (as freefilesync would copy the files even with whatpulse running).
^keep in mind the database file is still 274mb.
I also moved my working database from my second PC and it works on my main PC so that confirms it.

That still doesn't explain why it got reset when I updated to 3.0.

I'll have to find a way to close whatpulse, back it up, then open whatpulse again (I think I can do it with task scheduler).

to answer your questions:
when I first started 3.0 I'm pretty sure it started in tray like normal, I then maximized it and it shows all stats reset (still logged in and it recognizes the PC).

When I use the old database it just resets to 0 every time, I can even watch the 275mb database file turn to a few mb as I start it.
Find all posts by this user
Quote this message in a reply
01-02-2021, 06:33 AM
Post: #6
RE: 3.0 heat map issues
I just updated; confirming that I didn't lose any data (heat map, keys, etc.)
Find all posts by this user
Quote this message in a reply
01-06-2021, 12:06 PM
Post: #7
RE: 3.0 heat map issues
Yeah, so if another program takes the database and does something with it (i.e. locks it to zip it), there's a chance that the client won't like that and the database becomes corrupted. This is true for all applications that use a relational database.

Don't backup the database when the client is running, as that also doesn't guarantee a proper backup.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  OSX client issues since latest update mehcore 2 2,990 05-15-2015 06:57 PM
Last Post: mehcore
Bug OS X v2.5 Wifi Latency Issues BlitzBolt 3 3,954 12-13-2014 08:32 PM
Last Post: smitmartijn
  Issues with renaming computer smudgerox 1 2,741 09-30-2014 05:22 PM
Last Post: smitmartijn
  Gnome 3 and system tray issues Wieschie 0 2,876 06-17-2014 08:07 PM
Last Post: Supernova190
  Heat Map in v2.4 Changes When Window is Resized SirNothing 1 2,562 05-25-2014 01:57 PM
Last Post: smitmartijn
  Heat map is not showing Enter button in Debian Testing(Jessie) and version 2.3 [GoT]Jewest 1 4,370 02-20-2014 10:18 PM
Last Post: cartman2000
  Few Issues Uploading Application Info London_Ash 5 6,778 01-03-2014 10:20 AM
Last Post: SearchBuzz
  Network Issues (PC) abpop 0 3,283 11-23-2013 10:20 PM
Last Post: abpop
  Updating Issues OCNRyahn 4 6,913 09-17-2013 05:17 PM
Last Post: Megachip
  Proxy Issues Noobster 10 17,106 03-19-2013 02:14 AM
Last Post: Bloopy

Forum Jump:


User(s) browsing this thread: 1 Guest(s)