WhatPulse Forums » Support » Client software v » “Cannot open shared object file” pops up when installing WhatPulse Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
“Cannot open shared object file” pops up when installing WhatPulse
04-22-2020, 06:08 PM (This post was last modified: 04-22-2020 06:10 PM by Gaurav Mall.)
Post: #1
“Cannot open shared object file” pops up when installing WhatPulse
So, I just installed Ubuntu yesterday, together with my main Windows just so I could use it for development. Because of all the keys, I would be typing I thought why not install Whatpulse to keep track of them? But turns out it is a tedious task. So, basically, I followed this guide: Whatpulse (installation guide Ubuntu 14.04), because there isn't anything that is newer.

NOTE: I do use the generic version from the installs.

So, basically this is what I did (after extracting the .gz file of course):

sudo ./setup-input-permissions.sh
sudo apt-get install libqtcore4
sudo apt-get install libqtscript4-core
sudo apt-get install libqt5sql5
sudo apt-get install libpcap-dev
sudo setcap cap_net_raw,cap_net_admin=eip ./whatpulse

And then I tried

./whatpulse

But it gave me this error:

./whatpulse: error while loading shared libraries: libQt5Sql.so.5: cannot open shared object file: No such file or directory

What does it mean? After a bit of searching I found that by reinstalling and doing this the problem might be resolved:

sudo strip --remove-section=.note.ABI-tag /usr/lib/x86_64-linux-gnu/libQt5Core.so.5

But it still gives the same error. By the way, I didn't install the libqtwebkit4 library because it isn't listed at the official site.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Bug Whatpulse keeps me logging off shadowrune 1 417 09-13-2020 10:08 AM
Last Post: shadowrune
  WhatPulse hangs and crashes on Windows startup td95 0 206 08-17-2020 07:20 AM
Last Post: td95
  Cannot start WhatPulse using Ubuntu 19.10 Adrriii 7 1,988 03-31-2020 09:39 PM
Last Post: Lieutenant_Dan
  Cannot start Whatpulse successfully on Manjaro 18.1.4 (Arch Linux) anijatsu 2 1,261 01-12-2020 04:06 PM
Last Post: Adrriii
  Whatpulse could not find OpenSSL Adrriii 0 747 12-03-2019 12:52 AM
Last Post: Adrriii
  Having trouble running whatpulse on Neon Linux BlackWidow 1 925 12-03-2019 12:02 AM
Last Post: Adrriii
  Whatpulse crash [GoT]Jewest 3 1,506 10-28-2019 01:18 PM
Last Post: [GoT]Jewest
  Updating from jessie to buster breaks whatpulse [GoT]Jewest 2 1,150 10-28-2019 01:17 PM
Last Post: [GoT]Jewest
  Server error: Missing input! with whatpulse 2.8.4 on Win10 Franck.Dernoncourt 3 1,740 09-24-2019 10:56 PM
Last Post: kolah
  Whatpulse isn't running after upgrading Ubuntu 1geeky 0 898 08-06-2019 05:46 AM
Last Post: 1geeky

Forum Jump:


User(s) browsing this thread: 1 Guest(s)