WhatPulse Forums » Support » Client software v » CPU usage spikes on OS X Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CPU usage spikes on OS X
03-11-2016, 09:00 PM (This post was last modified: 03-11-2016 09:01 PM by eithel.)
Post: #1
CPU usage spikes on OS X
WhatPulse is spiking 99% CPU usage every 15 seconds.

http://i.imgur.com/k3vB5Xl.png

If you need any logs, let me know.

Client: WhatPulse 2.7

OS X 10.11.3 (15D21)
Model Name: MacBook Air
Model Identifier: MacBookAir7,2
Processor Name: Intel Core i7
Processor Speed: 2.2 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Memory: 8 GB
Find all posts by this user
Quote this message in a reply
04-04-2016, 05:10 AM
Post: #2
RE: CPU usage spikes on OS X
I have the same issue.

Every 15 seconds CPU usage for Whatpulse spikes.

Model Name: MacBook Pro
Model Identifier: MacBookPro11,1
Processor Name: Intel Core i7
Processor Speed: 3 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Memory: 16 GB
Boot ROM Version: MBP111.0138.B17
SMC Version (system): 2.16f68

Systemversion: OS X 10.11.4 (15E65)
Kernel-Version: Darwin 15.4.0

Whatpulse Version: 2.7


I had this issue already with Whatpulse 2.6.3 and also with OSX 10.11.3. So it should not be related to the only latest versions of these softwares.

I would be really glad about some help, as this is draining the battery faster than it should be.

Any help is highly appreciated.


Attached File(s)
.png  whatpulse.png (Size: 158.03 KB / Downloads: 120)
Find all posts by this user
Quote this message in a reply
04-15-2016, 04:08 AM
Post: #3
RE: CPU usage spikes on OS X
*push*...
Find all posts by this user
Quote this message in a reply
05-03-2016, 09:05 AM
Post: #4
RE: CPU usage spikes on OS X
Any response from a dev possible?
Find all posts by this user
Quote this message in a reply
05-21-2016, 09:09 PM
Post: #5
RE: CPU usage spikes on OS X
I find this lack of response disturbing.

Stopped using the Mac client. Got 1.5h more of battery life.
Find all posts by this user
Quote this message in a reply
05-23-2016, 02:03 PM
Post: #6
RE: CPU usage spikes on OS X
Hi,

Sorry about the lack of response, something about this thread being buried in my view. I need a better system with these things. Undecided

How I respect your decision to stop using it, I would like to ask a few questions, if you recall:

- Did you have the network measurements enabled and have you ever tried to disable it?
- Did you have the geek window open when this happened, or did it happen with it closed?

Thanks
Visit this user's website Find all posts by this user
Quote this message in a reply
05-23-2016, 04:30 PM
Post: #7
RE: CPU usage spikes on OS X
Thanks for your reply.

1) The network measurement is enabled. Also every sub-option for that (except for the first one, as no premium user)
But it makes no difference, if any measurement (input, network, uptime) is enabled or disabled. The cpu usage spikes continue.
One interesting thing I just noticed while watching Activity Monitor: shortly before the Whatpulse process spikes up, the kernel_task does. It goes like: normal cpu usage -> kernel_task up to 10-20% usage -> kernel_task low again, but Whatpulse 35-50% usage -> normal cpu usage.
And this repeats and repeats. If I close the WhatPulse client, there are also no more cpu usage spikes for kernel_task. So it is somehow connected.


2) The geek window is not opened when this happened. It also makes no difference if the main window is open or not (and WhatPulse just running in the background).
Find all posts by this user
Quote this message in a reply
06-17-2016, 07:39 PM
Post: #8
RE: CPU usage spikes on OS X
Response?
Find all posts by this user
Quote this message in a reply
06-19-2016, 01:56 PM
Post: #9
RE: CPU usage spikes on OS X
We're looking into reproducing it and checking whether there's something to optimise, as it's proving rather hard to reproduce. It's most likely a combination of applications/hardware/av that's causing it, but I haven't found the combo.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  High CPU Usage - On wake-up ClayC 5 375 07-27-2019 02:01 PM
Last Post: ClayC
  Heatmap On = High CPU Usage Dark_wizzie 3 823 03-19-2017 07:28 AM
Last Post: Dark_wizzie
Bug WIndows High CPU Usage necenzurat 9 4,601 03-26-2015 11:37 AM
Last Post: True
  [SOLVED] Linux 2.4.1 critical CPU usage+temp when no network connection vonunov 1 1,594 03-13-2015 08:41 AM
Last Post: smitmartijn
  WhatPulse Only Recording LAN Usage brian724080 11 3,743 12-10-2014 10:21 AM
Last Post: smitmartijn
  [SOLVED]700mb memory usage Freezy3 3 3,824 09-14-2014 10:48 AM
Last Post: rebootyourmind
  Whatpulse does not track application network usage Taboo 5 5,133 08-02-2014 08:52 AM
Last Post: smitmartijn
  [SOLVED] Missmatch application usage between webpage and client Megachip 3 3,497 09-29-2013 03:11 PM
Last Post: smitmartijn
  Memory usage? kiwie 0 4,231 03-28-2013 02:11 AM
Last Post: kiwie
  2.0.4 doesn't capture network usage on Linux. RaymondTracer 5 8,027 03-13-2013 02:07 PM
Last Post: nimd4

Forum Jump:


User(s) browsing this thread: 1 Guest(s)