WhatPulse Forums » Support » Client software v » [CLOSED] WhatPulse not starting - Ubuntu 12.04 on Chromebook Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[CLOSED] WhatPulse not starting - Ubuntu 12.04 on Chromebook
05-15-2015, 11:37 PM (This post was last modified: 05-20-2015 05:48 PM by smitmartijn.)
Post: #1
[CLOSED] WhatPulse not starting - Ubuntu 12.04 on Chromebook
Hi,

I've installed Ubuntu 12.04 on my Chromebook via Crouton and I've been trying to get Whatpulse installed on it for several days now.
I've installed all the packages on the help page, and many other QT packages in an attempt to get it to work, but it won't even start.

It's set to execute and everything.

I'm not sure what the issue is, unless it has to do with the fact that the Ubuntu install is on a Chromebook.

Any help would be appreciated!

Thanks!
Find all posts by this user
Quote this message in a reply
05-16-2015, 10:43 AM
Post: #2
RE: WhatPulse not starting - Ubuntu 12.04 on Chromebook
What is the error the client gives? Run it via commandline to see. If it's a Segmentation error and you're using 2.6, update to 2.6.1.
Visit this user's website Find all posts by this user
Quote this message in a reply
05-16-2015, 07:42 PM
Post: #3
RE: WhatPulse not starting - Ubuntu 12.04 on Chromebook
It gives no error at all. It doesn't even start up when I click the executable. It also does nothing when I try to run it from terminal with ./whatpulse

But now that 2.6.1 is out I'll download that and try it.
Find all posts by this user
Quote this message in a reply
05-16-2015, 08:19 PM
Post: #4
RE: WhatPulse not starting - Ubuntu 12.04 on Chromebook
Does nothing is not really an option...running it from terminal should always give some message, whether from the client or from the os. I suggest capturing the terminal session when you're running it and see what it says.
Visit this user's website Find all posts by this user
Quote this message in a reply
05-19-2015, 12:42 AM (This post was last modified: 05-19-2015 12:49 AM by Code-E.)
Post: #5
RE: WhatPulse not starting - Ubuntu 12.04 on Chromebook
(05-16-2015 08:19 PM)smitmartijn Wrote:  Does nothing is not really an option...running it from terminal should always give some message, whether from the client or from the os. I suggest capturing the terminal session when you're running it and see what it says.

You're completely right. I think the fact I was using an installed terminal rather than the one that came with the install on the chromebook was doing something weird.

When I type
Code:
./whatpulse
in the terminal I get
Code:
bash: ./whatpulse: cannot execute binary file

But when I double click the binary file, nothing still happens.

EDIT: Tried installing the new version 2.6.1 and still get the same things happening
Find all posts by this user
Quote this message in a reply
05-19-2015, 06:21 AM
Post: #6
RE: WhatPulse not starting - Ubuntu 12.04 on Chromebook
Well there you go, WhatPulse is simply not compatible with a Chromebook. Probably because it has a different processor architecture.
Visit this user's website Find all posts by this user
Quote this message in a reply
05-19-2015, 05:58 PM
Post: #7
RE: WhatPulse not starting - Ubuntu 12.04 on Chromebook
(05-19-2015 06:21 AM)smitmartijn Wrote:  Well there you go, WhatPulse is simply not compatible with a Chromebook. Probably because it has a different processor architecture.

I didn't realize that's what it meant. I've been scouring the internet looking for packages that could give that error or packages related to whatpulse.

This chromebook does have a different processor achitecture, its ARM.

Thanks for the help.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Whatpulse could not find OpenSSL Adrriii 0 28 12-03-2019 12:52 AM
Last Post: Adrriii
  Having trouble running whatpulse on Neon Linux BlackWidow 1 65 12-03-2019 12:02 AM
Last Post: Adrriii
  Cannot start WhatPulse using Ubuntu 19.10 Adrriii 1 127 11-01-2019 02:37 PM
Last Post: Adrriii
  Whatpulse crash [GoT]Jewest 3 243 10-28-2019 01:18 PM
Last Post: [GoT]Jewest
  Updating from jessie to buster breaks whatpulse [GoT]Jewest 2 233 10-28-2019 01:17 PM
Last Post: [GoT]Jewest
  Server error: Missing input! with whatpulse 2.8.4 on Win10 Franck.Dernoncourt 3 578 09-24-2019 10:56 PM
Last Post: kolah
  Whatpulse isn't running after upgrading Ubuntu 1geeky 0 258 08-06-2019 05:46 AM
Last Post: 1geeky
  WhatPulse 64bit install on Lubuntu 19.04 SiKTheGreatOne 0 420 06-30-2019 02:49 AM
Last Post: SiKTheGreatOne
  Ubuntu 16.04 and Libqt5 VanackSabbadium 0 471 06-09-2019 02:24 PM
Last Post: VanackSabbadium
  WhatPulse not opening on Manjaro Linux (Arch distro) tboxley 4 808 05-26-2019 11:30 AM
Last Post: FamilienVater

Forum Jump:


User(s) browsing this thread: 1 Guest(s)