WhatPulse Forums » Support » Client software v » WhatPulse bandwidth monitor causing crashes from memory allocation Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WhatPulse bandwidth monitor causing crashes from memory allocation
04-12-2015, 03:28 AM
Post: #1
WhatPulse bandwidth monitor causing crashes from memory allocation
Hi!

Every once in a while my WhatPulse client allocates an extreme amount of memory over the period of a minute, usually causing my computer to become unresponsive and freeze. It usually happens whenever I plug in my laptop to ethernet or use Docker, http://docker.com, which creates/uses a virtual network interface. I presume its something to do with the network part of WhatPulse based on the logs.

My computer is Xubuntu 14.04 x64, WhatPulse 2.5, with libpcap0.8. I run WhatPulse as root.

When running WhatPulse in a terminal window, stdout scrolls by fast as my RAM quickly fills up. The following from stdout is quickly repeated when the program is allocating memory:

11-04-2015 22:53:37.583 DEBUG PF-Ring thread stopped
11-04-2015 22:53:37.599 DEBUG Stopping PfRingNetworkTrafficMonitor..
11-04-2015 22:53:37.599 DEBUG PF-Ring thread started
11-04-2015 22:53:37.599 DEBUG Starting PfRingNetworkTrafficMonitor..
11-04-2015 22:53:37.599 DEBUG PF-Ring thread stopped
11-04-2015 22:53:37.619 DEBUG Stopping PfRingNetworkTrafficMonitor..
11-04-2015 22:53:37.619 DEBUG PF-Ring thread started
11-04-2015 22:53:37.619 DEBUG Starting PfRingNetworkTrafficMonitor..
11-04-2015 22:53:37.620 DEBUG PF-Ring thread stopped
11-04-2015 22:53:37.635 DEBUG Stopping PfRingNetworkTrafficMonitor..
11-04-2015 22:53:37.635 DEBUG Starting PfRingNetworkTrafficMonitor..
11-04-2015 22:53:37.635 DEBUG PF-Ring thread started
11-04-2015 22:53:37.637 DEBUG PF-Ring thread stopped
11-04-2015 22:53:37.647 DEBUG Stopping PfRingNetworkTrafficMonitor..
11-04-2015 22:53:37.647 DEBUG PF-Ring thread started
11-04-2015 22:53:37.647 DEBUG Starting PfRingNetworkTrafficMonitor..
11-04-2015 22:53:37.648 DEBUG PF-Ring thread stopped


Additionally, this is the log from app.log:


02-04-2015 20:59:17.413 INFO "Starting WhatPulse 2.5..."
02-04-2015 20:59:17.418 DEBUG "/root/.local/share/data//WhatPulse" does not exist, starting fresh!
02-04-2015 20:59:17.418 DEBUG Database file: "/root/.local/share/data/WhatPulse/whatpulse.db"
02-04-2015 20:59:17.419 DEBUG Database check: "ok"
02-04-2015 20:59:17.419 DEBUG Opened database in: 1 ms
02-04-2015 20:59:17.426 DEBUG First time database use detected, setting version to: 4
02-04-2015 20:59:32.516 INFO "Starting WhatPulse 2.5..."
02-04-2015 20:59:32.522 DEBUG Database file: "/root/.local/share/data/WhatPulse/whatpulse.db"
02-04-2015 20:59:32.523 DEBUG Database check: "ok"
02-04-2015 20:59:32.524 DEBUG Opened database in: 2 ms
02-04-2015 20:59:39.624 DEBUG Encrypted file: "/root/.local/share/data/WhatPulse/whatpulse.wpw"
02-04-2015 20:59:39.624 DEBUG Unable to open savefile
02-04-2015 20:59:39.624 WARN Failed to load ' "/root/.local/share/data/WhatPulse/whatpulse.wpw" ' - trying backup file
02-04-2015 20:59:39.625 DEBUG Unable to open savefile
02-04-2015 20:59:39.671 DEBUG Loaded application aliases
02-04-2015 20:59:39.847 DEBUG Started download of GeoIP Database..
02-04-2015 20:59:39.852 DEBUG WhatPulse 2.5 has started
02-04-2015 20:59:39.938 WARN Unable to find videocard in our database with vendor "8086" , device "0126" and subsys "17AA21E2"
02-04-2015 20:59:40.143 DEBUG Starting timers and collector..
02-04-2015 20:59:40.144 DEBUG Creating device listener for "/dev/input/event0"
02-04-2015 20:59:40.145 DEBUG Creating device listener for "/dev/input/event1"
02-04-2015 20:59:40.145 DEBUG Creating device listener for "/dev/input/event10"
02-04-2015 20:59:40.145 DEBUG Creating device listener for "/dev/input/event2"
02-04-2015 20:59:40.145 DEBUG Creating device listener for "/dev/input/event3"
02-04-2015 20:59:40.145 DEBUG Creating device listener for "/dev/input/event4"
02-04-2015 20:59:40.146 DEBUG Creating device listener for "/dev/input/event5"
02-04-2015 20:59:40.146 DEBUG Creating device listener for "/dev/input/event6"
02-04-2015 20:59:40.146 DEBUG Creating device listener for "/dev/input/event7"
02-04-2015 20:59:40.146 DEBUG Creating device listener for "/dev/input/event8"
02-04-2015 20:59:40.146 WARN QThread::start: Thread creation error: Resource temporarily unavailable
02-04-2015 20:59:40.146 DEBUG Creating device listener for "/dev/input/event9"
02-04-2015 20:59:40.146 WARN QThread::start: Thread creation error: Resource temporarily unavailable
02-04-2015 20:59:40.146 WARN QThread::start: Thread creation error: Resource temporarily unavailable
02-04-2015 20:59:40.147 DEBUG Starting PfRingNetworkTrafficMonitor..
02-04-2015 20:59:59.663 INFO "Starting WhatPulse 2.5..."
02-04-2015 20:59:59.669 DEBUG Database file: "/root/.local/share/data/WhatPulse/whatpulse.db"
02-04-2015 20:59:59.670 DEBUG Database check: "ok"
02-04-2015 20:59:59.670 DEBUG Opened database in: 1 ms
02-04-2015 21:00:01.482 DEBUG Encrypted file: "/root/.local/share/data/WhatPulse/whatpulse.wpw"
02-04-2015 21:00:01.482 DEBUG Unable to open savefile
02-04-2015 21:00:01.482 WARN Failed to load ' "/root/.local/share/data/WhatPulse/whatpulse.wpw" ' - trying backup file
02-04-2015 21:00:01.482 DEBUG Unable to open savefile
02-04-2015 21:00:01.528 DEBUG Loaded application aliases
02-04-2015 21:00:01.696 DEBUG Started download of GeoIP Database..
02-04-2015 21:00:01.711 DEBUG WhatPulse 2.5 has started
02-04-2015 21:00:01.784 WARN Unable to find videocard in our database with vendor "8086" , device "0126" and subsys "17AA21E2"
02-04-2015 21:00:01.990 DEBUG Starting timers and collector..
02-04-2015 21:00:01.991 DEBUG Creating device listener for "/dev/input/event0"
02-04-2015 21:00:01.991 DEBUG Creating device listener for "/dev/input/event1"
02-04-2015 21:00:01.991 DEBUG Creating device listener for "/dev/input/event10"
02-04-2015 21:00:01.991 DEBUG Creating device listener for "/dev/input/event2"
02-04-2015 21:00:01.992 DEBUG Creating device listener for "/dev/input/event3"
02-04-2015 21:00:01.992 DEBUG Creating device listener for "/dev/input/event4"
02-04-2015 21:00:01.992 DEBUG Creating device listener for "/dev/input/event5"
02-04-2015 21:00:01.992 DEBUG Creating device listener for "/dev/input/event6"
02-04-2015 21:00:01.993 DEBUG Creating device listener for "/dev/input/event7"
02-04-2015 21:00:01.993 DEBUG Creating device listener for "/dev/input/event8"
02-04-2015 21:00:01.993 DEBUG Creating device listener for "/dev/input/event9"
02-04-2015 21:00:01.993 DEBUG Starting PfRingNetworkTrafficMonitor..
02-04-2015 21:00:02.011 DEBUG PF-Ring thread started
02-04-2015 21:00:02.513 WARN Failed to open: "/sys/class/net/virbr0/device/vendor" or "/sys/class/net/virbr0/device/device"
02-04-2015 21:00:02.517 WARN Failed to open: "/sys/class/net/docker0/device/vendor" or "/sys/class/net/docker0/device/device"
02-04-2015 21:00:15.587 DEBUG Writing downloaded GeoIP Database into: "/root/.local/share/data/WhatPulse/GeoIP.dat"
02-04-2015 21:00:15.590 DEBUG Opening GeoIP database: "/root/.local/share/data/WhatPulse/GeoIP.dat"
02-04-2015 21:00:15.591 DEBUG Finished downloading GeoIP database!


Thanks for your help!
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Multi-monitor help dscotthep 1 213 08-08-2019 04:52 PM
Last Post: dscotthep
  Whatpulse isn't running after upgrading Ubuntu 1geeky 0 44 08-06-2019 05:46 AM
Last Post: 1geeky
  Server error: Missing input! with whatpulse 2.8.4 on Win10 Franck.Dernoncourt 2 289 07-28-2019 08:11 PM
Last Post: Franck.Dernoncourt
  WhatPulse 64bit install on Lubuntu 19.04 SiKTheGreatOne 0 159 06-30-2019 02:49 AM
Last Post: SiKTheGreatOne
  WhatPulse not opening on Manjaro Linux (Arch distro) tboxley 4 489 05-26-2019 11:30 AM
Last Post: FamilienVater
  Whatpulse won't start, Unable to install crashRpt! Bai.Bing 0 195 05-24-2019 01:02 PM
Last Post: Bai.Bing
  Whatpulse is not recognizing internet traffic Lodisen 8 674 05-22-2019 05:35 PM
Last Post: Trapton
Exclamation giving pcap permissions breaks whatpulse ajencks1 0 294 04-18-2019 01:08 AM
Last Post: ajencks1
  Mac client causing latency every ~10 seconds bryandh 10 1,830 03-09-2017 04:50 PM
Last Post: DJLunacy
  [Edited] Whatpulse does not work with libssl-dev 1.1.0 jhepburn 4 3,078 03-07-2017 11:11 PM
Last Post: swissboney3

Forum Jump:


User(s) browsing this thread: 1 Guest(s)