WhatPulse Forums » Support » Client software v » OS X WP Client Hanging Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OS X WP Client Hanging
04-09-2015, 06:40 PM
Post: #1
OS X WP Client Hanging
Hi guys,

I have had an ongoing issue where several seconds after starting up, thed WP client will hang.

I am defining "hang" here as the system bar icon becomes unresponsive: clicks yield nothing, and no pips appear on key/mouse action. The icon is also sometimes greyed out. I suspect it is not recording keystrokes or mouse activity during this time as my counts have been lower than previous.

Killing the whatpulse process and restarting it, it will function for several seconds, then stop. Rebooting my mac seems to resolve the issue, until it begins reoccurring.

I've attached the output of dtruss on the running whatpulse process during a "hung" state. It's obviously doing something.

Additionally, the uname string for my OS X install is: "Darwin [hostname] 14.1.0 Darwin Kernel Version 14.1.0: Thu Feb 26 19:26:47 PST 2015; root:xnu-2782.10.73~1/RELEASE_X86_64 x86_64"

Let me know if you need any more info.


Attached File(s)
.gz  wp_dtruss.tar.gz (Size: 20 KB / Downloads: 59)
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Mac client causing latency every ~10 seconds bryandh 10 2,615 03-09-2017 04:50 PM
Last Post: DJLunacy
Information [CLOSED] Mouse distance counter in Windows client. TigraPolosatiy 1 774 02-27-2017 05:30 PM
Last Post: smitmartijn
  Client crash on launch (v2.7.1) Sovex66 13 2,605 02-27-2017 09:31 AM
Last Post: Dosphal
Bug Client doing an insane amount of writing to disk Formina_Sage 4 1,196 11-04-2016 04:47 PM
Last Post: smitmartijn
  [SOLVED] Client crashes on startup v. 2.7 Win10x64 Lttngblt 11 2,893 10-08-2016 06:43 PM
Last Post: smitmartijn
  [CLOSED] Client Crash macOS Sierra SeeEmAge 3 1,322 09-15-2016 03:42 AM
Last Post: smitmartijn
Bug [FIXED] Premium on site does not match premium on client fractalsauce 3 1,151 06-26-2016 06:10 PM
Last Post: smitmartijn
  [CLOSED] Mac client, network traffic reading but not pulsing dacheat 1 994 05-23-2016 02:11 PM
Last Post: smitmartijn
  Logitech G19-app. The whatpulse client API is not responding. BootVluchteling 5 1,857 04-01-2016 07:37 PM
Last Post: smitmartijn
  [SOLVED] Client freezes and crashes on first startup Creator13 1 1,016 03-06-2016 12:43 PM
Last Post: smitmartijn

Forum Jump:


User(s) browsing this thread: 1 Guest(s)