WhatPulse Forums » Support » Client software v » [SOLVED] Linux 2.4.1 critical CPU usage+temp when no network connection Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Linux 2.4.1 critical CPU usage+temp when no network connection
03-04-2015, 09:08 AM (This post was last modified: 03-13-2015 08:41 AM by smitmartijn.)
Post: #1
[SOLVED] Linux 2.4.1 critical CPU usage+temp when no network connection
https://www.youtube.com/watch?v=ZN42VAoX_vA

I'm a bit late upgrading to 2.5, where this issue isn't reproduced. It seems this version has been out for some months now, but I'm posting this in case someone runs into the same problem and didn't think to upgrade, or in case some conditions in 2.5 can cause the same behavior. I don't see anything about this in the new version blog posts, so maybe there's still some chance it could cause a problem.

When WhatPulse 2.4.1 is configured to collect network stats and there is no network connection, it immediately pegs a CPU core and causes the temperature to climb to critical levels. In the video, my uptime is 9 minutes because I didn't notice and the temp climbed until my laptop powered off.

I start WhatPulse a couple of times with a connection to show normal behavior. Then I down the network interface and start WhatPulse again to show the problem. You can see CPU % and temp (which climbed to 80C before I killed WP) at the bottom of the screen, and more resource monitoring at the top.
Find all posts by this user
Quote this message in a reply
03-13-2015, 08:41 AM
Post: #2
RE: Linux 2.4.1 critical CPU usage+temp when no network connection
Good to see that it's not reproducible in 2.5. There have not been able direct changes to the Linux networking no, but it was compiled on a newer version of Linux, so that might have been related to this being fixed in 2.5.

Thanks for the info!
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Network stats displayed / counted wrong MrElliwood 0 128 01-30-2021 10:10 PM
Last Post: MrElliwood
  Snap fails on Manjaro Linux madhead 6 535 01-22-2021 04:40 PM
Last Post: madhead
  3.0 for Linux Bzzz 5 497 01-22-2021 03:43 PM
Last Post: flotwig
  Error: "Network access is disabled." Jourei 5 376 01-20-2021 07:01 AM
Last Post: penguin2233
Bug WIndows High CPU Usage necenzurat 15 9,555 01-17-2021 12:08 PM
Last Post: smitmartijn
Question 3.0 not tracking network stats on macOS numbermaniac 0 208 01-02-2021 11:36 AM
Last Post: numbermaniac
  3.0 Mac Network Not Tracking mewturn 3 343 12-30-2020 05:57 AM
Last Post: mewturn
  Cannot start Whatpulse successfully on Manjaro 18.1.4 (Arch Linux) anijatsu 3 2,186 10-25-2020 01:36 PM
Last Post: smitmartijn
  Support for Linux dropped ? Adrriii 23 5,012 10-25-2020 01:35 PM
Last Post: smitmartijn
Exclamation Constant 6 GB+ Ram Usage on MacOS teslasagan 6 1,046 09-06-2020 08:52 PM
Last Post: teslasagan

Forum Jump:


User(s) browsing this thread: 1 Guest(s)