WhatPulse Forums » Support » Client software v » [linux|windows] Floating point exception Welcome back, Guest.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[linux|windows] Floating point exception
10-10-2014, 08:59 AM (This post was last modified: 10-29-2014 01:31 PM by FamilienVater.)
Post: #1
[linux|windows] Floating point exception

With the current linux client (2.4.1) I get a "Floating point exception" when starting the client. The only thing that helps is throwing all the local data away and starting from scratch.
This happened even when using the backup database and then resetting the token. In this case the program crashed immediately after the token reset and could not be started again.
This is happening every other program start (occured three times to me until now - had the computer running the whole week), but I haven't really tried to reproduce this more often...

10-10-2014 10:40:42.609  INFO "Starting WhatPulse 2.4.1..."
10-10-2014 10:40:42.618 DEBUG Database file:  "/home/****/.local/share/data/WhatPulse/whatpulse.db"
10-10-2014 10:40:42.628 DEBUG Database check:  "ok"
10-10-2014 10:40:42.628 DEBUG Opened database in:  10 ms
10-10-2014 10:40:42.633 DEBUG Found proper permissions for network monitoring
10-10-2014 10:40:42.633 DEBUG Encrypted file:  "/home/****/.local/share/data/WhatPulse/whatpulse.wpw"
10-10-2014 10:40:42.650 DEBUG Loaded application aliases
10-10-2014 10:40:42.816 DEBUG Opening GeoIP database:  "/home/****/.local/share/data/WhatPulse/GeoIP.dat"
./whatpulse.sh: line 8:  3087 Floating point exception(core dumped) /home/****/Apps/whatpulse

OS is xubuntu 14.04
I've disabled per application and per country stats
Find all posts by this user
Quote this message in a reply
10-29-2014, 01:30 PM
Post: #2
RE: [linux] Floating point exception
I've now reproduced this problem a few times, even with windows.

There are two distinct moments this CAN happen:
* Reboots / Shutting down the system. It seems that if the whatpulse program is closed by the operating system when the machine shuts down (or reboots), it might be caught in the wrong moment and writes a corrupt database to disk.
** Shutting down Whatpulse manually when shutting down the computer seems to help with this case in most cases
* Auto-Pulsing - I've seen this happen at least five times now, twice on windows, three times on linux. It crashes immediately after an automatic pulse and then never recovers.
Find all posts by this user
Quote this message in a reply
11-08-2014, 10:13 AM
Post: #3
RE: [linux|windows] Floating point exception
Since this problem still exists for me and happens quite often, I've found out, it happens randomly on pulsing. It doesn't matter if it's manual or automatic. The client immediately crashes and won't recover until you delete the database files and start with a new configuration.

I've disabled all "per application statistics" and "per country statistics"

Windows Version is Win7 64bit in two cases.
Linux is xubuntu 14.10 in 3 cases and Debian 7 with XFCE in one case.

Am I the only one?
Find all posts by this user
Quote this message in a reply
11-08-2014, 10:27 AM
Post: #4
RE: [linux|windows] Floating point exception
(11-08-2014 10:13 AM)FamilienVater Wrote:  Am I the only one?

Pretty much, you're the only one who has reported this.. Try removing the file: /home/****/.local/share/data/WhatPulse/GeoIP.dat and downloading a manual copy from here: http://geolite.maxmind.com/download/geoi...oIP.dat.gz

That's the only thing that I can think of that could cause this. Otherwise something is blocking the client from writing a proper data file or receiving proper data from the website.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [SOLVED] Can't run the Linux version [Driver not loaded Driver not loaded] radioz 2 1,066 06-20-2019 11:54 AM
Last Post: radioz
  WhatPulse not opening on Manjaro Linux (Arch distro) tboxley 4 778 05-26-2019 11:30 AM
Last Post: FamilienVater
Information [CLOSED] Mouse distance counter in Windows client. TigraPolosatiy 1 747 02-27-2017 05:30 PM
Last Post: smitmartijn
Bug [CLOSED] What pulse stuck , is what pulse not support for windows 10 ? karahan29 1 943 11-05-2016 10:34 PM
Last Post: smitmartijn
  Connected to VPN Windows not counting anymore iOChris 1 879 10-27-2016 12:57 AM
Last Post: Ruben_Koster
  [CLOSED] Does whatpulse linux support Qt5 satshow 1 1,240 06-26-2016 06:19 PM
Last Post: smitmartijn
  Uptime not tracking correctly (windows 10) RuneRifle 0 852 05-05-2016 11:04 PM
Last Post: RuneRifle
  [CLOSED] Installing on ARM Based Linux London_Ash 3 3,871 05-01-2016 11:42 PM
Last Post: Wopian
  Help for Linux version angelo.gallesio 0 659 04-27-2016 11:26 AM
Last Post: angelo.gallesio
  [Linux] Inaccurate download numbers Frogging101 7 1,891 04-13-2016 06:55 PM
Last Post: LukeLR

Forum Jump:

User(s) browsing this thread: 1 Guest(s)