WhatPulse Forums » Support » Client software v » [SOLVED] Cleanup Required During Every Launch Welcome back, Guest.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Cleanup Required During Every Launch
10-01-2014, 03:10 PM (This post was last modified: 10-11-2014 01:33 PM by smitmartijn.)
Post: #1
[SOLVED] Cleanup Required During Every Launch
I'm running 2.4.1 on Win7 x64 as a non-admin. Whenever WhatPulse is launched, either automatically at boot time or manually I get the same message I got after upgrading from 2.2:
"Cleanup Required - I have detected a required cleanup after your update of just now. For the sake of cleanliness, I will run the cleanup program (whatpulse-after-update.exe) before loading. You might get a permission authorization request."

This is followed by a UAC prompt for which I enter my admin creds in and WhatPulse starts.

Is there anything I should try to fix this or resort to reinstalling first?
Find all posts by this user
Quote this message in a reply
10-01-2014, 06:31 PM
Post: #2
RE: Cleanup Required During Every Launch
If it keeps going every time you start the client, for some reason the client can't remove the whatpulse-after-update.exe file, maybe because of permissions. Remove that file manually and you're good.
Visit this user's website Find all posts by this user
Quote this message in a reply
10-02-2014, 03:05 PM
Post: #3
RE: Cleanup Required During Every Launch
Thanks smitmartijn,
Having a deeper look the deletion of the whatpulse-after-update.exe file is attempted by the whatpulse.exe process which is also running as non-admin. I started up whatpulse with admin rights and the file got deleted automatically.

You could, for example, implement a fix by having whatpulse-after-update.exe self-delete using the admin privs from the UAC prompt. I'm sure I'm not the only whatpulse user that doesn't run on a full admin account by default.
Find all posts by this user
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Question [SOLVED] Manual Pulse-button does not work PeaceFreak 5 1,362 03-13-2020 04:14 PM
Last Post: PeaceFreak
  [SOLVED] Can't run the Linux version [Driver not loaded Driver not loaded] radioz 2 2,517 06-20-2019 11:54 AM
Last Post: radioz
  [SOLVED] Error uploading keyboard/mouse heatmap Wopian 2 2,022 03-17-2017 12:26 PM
Last Post: Wopian
  [SOLVED] [postmortem] Pulse error: "The specified configuration cannot be used." dgw 4 3,460 03-03-2017 09:54 PM
Last Post: dgw
  Client crash on launch (v2.7.1) Sovex66 13 5,857 02-27-2017 09:31 AM
Last Post: Dosphal
  [SOLVED] Client crashes on startup v. 2.7 Win10x64 Lttngblt 11 5,667 10-08-2016 06:43 PM
Last Post: smitmartijn
  [SOLVED] OS X no longer starts, crashes on startup stuthemonkey 3 2,105 10-01-2016 06:34 PM
Last Post: smitmartijn
  [SOLVED] Best solution for delaying whatpulse until after panel loads fennectech 1 1,958 09-15-2016 03:36 AM
Last Post: smitmartijn
Sad [SOLVED] The only thing that kept me from using whatpulse itzhalo 3 2,685 09-07-2016 09:53 AM
Last Post: smitmartijn
  [SOLVED] Facts window occassional displays strange formats/information d3ullist 1 1,906 07-08-2016 09:38 PM
Last Post: smitmartijn

Forum Jump:

User(s) browsing this thread: 1 Guest(s)