WhatPulse Forums » Support » Client software v » [SOLVED] [OSX] Only measuring modifier keys Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] [OSX] Only measuring modifier keys
09-30-2014, 08:38 AM (This post was last modified: 10-18-2014 05:42 PM by smitmartijn.)
Post: #1
[SOLVED] [OSX] Only measuring modifier keys
Hi,

Already for a few months I have the problem that Whatpulse is only tracking the modifier keys (Caps / Shift / Ctrl / Alt). The only solution I read to this problem is to re-enable accessibility options for the client. I have now already done that in every possible way.

I have always been using the latest version, I'm also running OSX 10.9.5.

Tried following things:
- Re-enable with client on
- Re-enable with client off
- Disable > turn client off > enable > start client
- Re-enable > restart computer
- Disable > restart computer > enable > restart client
- Re-installing client > re-enable
- Re-installing client after erasing all previous files using AppCleaner > re-enable

When I start the client with accessibility options disabled I get the message that I should enable it. When it's enabled I don't get the message, but it still is not counting all keys.

I have installed WhatPulse on a friends computer (also OSX) and over there it directly worked after the re-enable. Any one else with the same problem, or a solution?

Kind regards,

Emiel
Find all posts by this user
Quote this message in a reply
10-03-2014, 05:42 PM
Post: #2
RE: Only measuring modifier keys
If you've tried all these things and it's still not letting you properly add WhatPulse..there's one last resort which should work. Do this in a Terminal window (with WhatPulse closed):

Code:
sudo cp /Library/Application\ Support/com.apple.TCC/Tcc.db Tcc.db.backup
sudo sqlite3 /Library/Application\ Support/com.apple.TCC/Tcc.db 'delete from access where client like "%whatpulse%"'

Then open the client again (it'll complain again), then give it permission once again and it should be okay.
Visit this user's website Find all posts by this user
Quote this message in a reply
10-09-2014, 07:51 AM
Post: #3
RE: Only measuring modifier keys
Thank you smitmartijn for your suggestion. I have tried it, but to no avail. The moment I enter the sqlite3 command WhatPulse is removed from the accessibility screen as expected. After opening WhatPulse it complains again as expected, and WhatPulse reappears on the accessibility screen. I give permissions once again, start WhatPulse, it does not complain anymore about permissions, but still is only measuring modifier keys.

So maybe the problem isn't related with permissions? I already have tried to set different keyboard input sources (U.S. / U.S. Extended / Dutch). The keyboard heatmap is showing a Windows like layout. Maybe that is the problem?


Attached File(s)
.png  whatpulse-keyboard-heatmap.png (Size: 48.87 KB / Downloads: 246)
Find all posts by this user
Quote this message in a reply
10-11-2014, 01:30 PM
Post: #4
RE: [OSX] Only measuring modifier keys
Weird, it might be something else blocking the client then. Got any type of antivirus/system monitor/watchdog running? Otherwise I'm out of ideas. If you've got it correctly in the security settings, it should work fine.

The heat map is the same everywhere, unless you change the layout to azerty or one of the other available options.
Visit this user's website Find all posts by this user
Quote this message in a reply
10-15-2014, 11:58 AM
Post: #5
Shocked RE: [OSX] Only measuring modifier keys
Yes yes yes! Webroot SecureAnywhere feature secure keyboard entry was blocking WhatPulse! Thanks!

Feeling a little bit dumb now, but at least the problem is solved Smile
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [SOLVED] Can't run the Linux version [Driver not loaded Driver not loaded] radioz 2 1,071 06-20-2019 11:54 AM
Last Post: radioz
  Keys & Clicks not recording anymore DJLunacy 0 439 05-08-2019 05:05 PM
Last Post: DJLunacy
  Modifier keys not registered (shift, alt, ctrl, enter) teilvtiw 4 2,188 04-24-2019 04:14 PM
Last Post: ajencks1
  [SOLVED] Error uploading keyboard/mouse heatmap Wopian 2 825 03-17-2017 12:26 PM
Last Post: Wopian
  [SOLVED] [postmortem] Pulse error: "The specified configuration cannot be used." dgw 4 1,618 03-03-2017 09:54 PM
Last Post: dgw
  [SOLVED] Client crashes on startup v. 2.7 Win10x64 Lttngblt 11 2,788 10-08-2016 06:43 PM
Last Post: smitmartijn
  [SOLVED] OS X no longer starts, crashes on startup stuthemonkey 3 1,004 10-01-2016 06:34 PM
Last Post: smitmartijn
  [SOLVED] Best solution for delaying whatpulse until after panel loads fennectech 1 1,080 09-15-2016 03:36 AM
Last Post: smitmartijn
Sad [SOLVED] The only thing that kept me from using whatpulse itzhalo 3 1,593 09-07-2016 09:53 AM
Last Post: smitmartijn
  [SOLVED] Facts window occassional displays strange formats/information d3ullist 1 1,044 07-08-2016 09:38 PM
Last Post: smitmartijn

Forum Jump:


User(s) browsing this thread: 1 Guest(s)