WhatPulse Forums » Support » Client software v » Network traffic numbers way off on Linux Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Network traffic numbers way off on Linux
09-06-2014, 07:56 PM
Post: #1
Network traffic numbers way off on Linux
I've tried both searching and browsing for similiar threads to no avail, so here's one. Sorry if there's a thread already.

1) Which version of WhatPulse are you running?
WhatPulse 2.4

2) What Operating System are you using?
elementary OS 0.2 (Luna) 64-bit (Ubuntu 12.04 LTS-based distro)
Code:
Linux Yukiho 3.2.0-51-generic #77-Ubuntu SMP Wed Jul 24 20:18:19 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Most of the info that describes the issue itself should be in the attachments. There's mainly two screenshots of interests which shows monitoring tools + WP before and during an iperf test. Permissions are set, and for the record running the binary with sudo doesn't change the outcome. Network configuration is done using `/etc/network/interfaces`, Network Manager is disabled.

Although in this case I've got two interfaces bonded together, I've experienced similiar if not the same problem when they weren't bonded. Outbound network traffic will be routed from `10.0.1/24` to `192.168.10/24` before being sent to the 'tubez'. The issue has also occured in a setting at the computer party The Gathering, in which the interfaces weren't bonded.

The issue is "permanent", i.e. there's not been any cases so far where it's been counting the traffic correctly. This applies to both inbound and outbound traffic.

Screenshot description
- The top-left Munin graph is interface data grabbed from the computer itself.
- The middle-left and bottom-left Munin graphs are the two ports on the switch that this computer is connected to and in a trunk with.
- The bottom-middle Munin graph is from the WAN link on my switch
- Middle-middle is Gnome System Monitor
- To the very top is iftop running on the bond0 interface

On the left-hand graphs there is a 200 M+ spike before the relevant data, you can safely disregard the spikes (iperf testing). To my recollection, even though local traffic isn't counted towards your total it should still show up under WP's network tab. The monitoring tools to take a look at to see the difference between and during iperf testing is Gnome System Monitor, iftop and WP.

NICs
Code:
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-V (rev 05)
08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 11)


Attached File(s)
.png  2014-09-06-211344_397x104_scrot.png (Size: 121.33 KB / Downloads: 337)
.png  915b3a077d326a1ad548709df5fd29c6cc6e5f19.png (Size: 283.59 KB / Downloads: 332)
.png  2014-09-06-214212_1703x1049_escrotum.png (Size: 278.65 KB / Downloads: 289)
Find all posts by this user
Quote this message in a reply
09-09-2014, 07:01 PM
Post: #2
RE: Network traffic numbers way off on Linux
There seems to be a skew of 1,58GB on 14GB, which is like 10%. That can have several reasons;

- The type of traffic you're sending. If you're sending small packets, the skew will be bigger; the client only counts the data and leaves the headers out.
- pcap can't keep up. It's not getting enough CPU time and basically dropping packets.
- Interface card offloading is making for giant packets which the client can't unpack.

Most likely, you're running into the first..I've seen that a lot with benchmark tests. The WhatPulse client is built for customer desktops with average workloads, which is where it's pretty accurate.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Network stats displayed / counted wrong MrElliwood 0 120 01-30-2021 10:10 PM
Last Post: MrElliwood
  Snap fails on Manjaro Linux madhead 6 504 01-22-2021 04:40 PM
Last Post: madhead
  3.0 for Linux Bzzz 5 478 01-22-2021 03:43 PM
Last Post: flotwig
  Error: "Network access is disabled." Jourei 5 350 01-20-2021 07:01 AM
Last Post: penguin2233
Question 3.0 not tracking network stats on macOS numbermaniac 0 191 01-02-2021 11:36 AM
Last Post: numbermaniac
  3.0 Mac Network Not Tracking mewturn 3 322 12-30-2020 05:57 AM
Last Post: mewturn
  Cannot start Whatpulse successfully on Manjaro 18.1.4 (Arch Linux) anijatsu 3 2,151 10-25-2020 01:36 PM
Last Post: smitmartijn
  Support for Linux dropped ? Adrriii 23 4,931 10-25-2020 01:35 PM
Last Post: smitmartijn
  Portable Mode Network Recording ItsRiftzy 1 741 09-04-2020 03:25 PM
Last Post: smitmartijn
  Wired Network Stats for USB-C to RJ45 abpop 3 972 08-05-2020 01:51 PM
Last Post: abpop

Forum Jump:


User(s) browsing this thread: 1 Guest(s)