WhatPulse Forums » Support » Client software v » 2.4 (Lubuntu) network stats problem Welcome back, Guest.

Thread Closed 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2.4 (Lubuntu) network stats problem
06-03-2014, 12:43 PM
Post: #1
2.4 (Lubuntu) network stats problem
I have a problem getting the network stats in WP.

Strange enough it does work when i close WP and start it again with a SUDO; then up and download are counted perfectly. If i set the 'start on boot' option while in sudo mode; it doesn't work, just like it didn't work before.

I'm currently running wp from /usr/bin, in the past it ran from /home/%user%/.local/share/applications with the same problem.

also; when i look at the network tab; there it sees and counts traffic while i'm not in sudo mode; but again this traffic is not added to the pulse totals.

So it's clear it CAN count, but currently it will only do so in SUDO mode; what can i do?

I guess it has something to with userrights, but since i'm quite new on linux/ubuntu i don't know how to fix this on my own.
Find all posts by this user
06-03-2014, 07:44 PM (This post was last modified: 06-03-2014 07:45 PM by bogy.)
Post: #2
RE: 2.4 (Lubuntu) network stats problem
i found this info:
Quote:The next is only required on clients earlier than 2.1 - later versions will automatically correct this:
After libpcap installation, you need to tell the OS to allow the WhatPulse binary to hook into the network traffic. To do so, execute this command inside the directory where the binary resides:

sudo setcap cap_net_raw,cap_net_admin=eip ./whatpulse

but appearantly it also is needed for 2.4 as this solved my issue immediately
Find all posts by this user
06-07-2014, 11:44 AM
Post: #3
RE: 2.4 (Lubuntu) network stats problem
Only on not-tested distros. Currently, only Ubuntu and Debian are a tested distribution.
Visit this user's website Find all posts by this user
06-18-2014, 03:26 AM
Post: #4
RE: 2.4 (Lubuntu) network stats problem
(06-07-2014 11:44 AM)smitmartijn Wrote:  Only on not-tested distros. Currently, only Ubuntu and Debian are a tested distribution.

Running Ubuntu 13.04 and have recently been having the same issue as OP until I found this thread. Ran the command given by bogy and now it works perfectly. I ignored it before as it says it wasn't needed for the v2.4 client.
Find all posts by this user
Thread Closed 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Bug Stats syncing bug? Roki100 0 364 08-01-2019 05:46 PM
Last Post: Roki100
  WhatPulse 64bit install on Lubuntu 19.04 SiKTheGreatOne 0 537 06-30-2019 02:49 AM
Last Post: SiKTheGreatOne
  Incorrect Network Upload/Download cahern7 11 3,830 11-21-2016 07:13 PM
Last Post: smitmartijn
  [CLOSED] Network traffic not recorded on Ubuntu 16.04 LTS GnaXi 4 1,832 09-15-2016 03:33 AM
Last Post: smitmartijn
  [CLOSED] Accidentally Deleted Local Stats TheFrozenSword 2 1,089 06-16-2016 12:09 AM
Last Post: TheFrozenSword
  [CLOSED] Mac client, network traffic reading but not pulsing dacheat 1 1,073 05-23-2016 02:11 PM
Last Post: smitmartijn
  [FIXED] Cannot open the "I" button in input/network/uptime screen YoshiIsAwsum 2 1,270 05-03-2016 08:02 PM
Last Post: YoshiIsAwsum
  Unencrypted network connections Megachip 1 884 04-25-2016 10:25 AM
Last Post: smitmartijn
  [SOLVED] Problem with Logitech Keyboard Widget Mattie112 2 1,244 03-25-2016 07:29 PM
Last Post: Mattie112
  Input Stats Bug? Drake356 0 1,024 02-11-2016 01:07 AM
Last Post: Drake356

Forum Jump:

User(s) browsing this thread: 1 Guest(s)