WhatPulse Forums » Support » Client software v » Startup time exceeds 10 minutes Welcome back, Guest.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Startup time exceeds 10 minutes
04-24-2014, 08:51 AM (This post was last modified: 04-24-2014 04:59 PM by theHacker.)
Post: #1
Thumbs Down Startup time exceeds 10 minutes
Hi there,

WhatPulse takes for startup over 10 minutes. You can watch in the Windows Task Manager whatpulse.exe slowly doing I/O (reading). After reaching a certain amount of bytes the main window opens and all is well. I suspected the client on startup reading the entire database file which has 316 MiB at the moment.

I recently upgraded from version 2.3 to 2.4 hoping this would improve performance but it didn't.

The log corroborates my theory:
23-04-2014 08:36:34.134 DEBUG Database file:  "C:/Users/theHacker/AppData/Local/WhatPulse/whatpulse.db"
23-04-2014 08:45:13.326 DEBUG Database check:  "ok"
23-04-2014 08:45:13.326 DEBUG Opened database in:  519255 ms

I think the problem is the mousepoints table which is really large with 5,397,298 entries. Without this table my database file would only be 9.33 MiB, i.e. 97% of the database is the mousepoints data.

Is there a good reason why the client reads this data at startup? It would suffice to read the data only when looking at the mouse heatmap (a progress indicator would be nice).

I personally would rather have an instant start of WhatPulse than a faster mouse heatmap. For two reasons:
  1. I am losing 10 minutes of stats every day because the client does not count while reading the database file at startup.
  2. I never look at the mouse heatmap because it's useless for me combining the coordinates from 3 displays with different resolution ratios in one chart.

Can you please look into this and improve the startup? Thanks a lot :-)

Sry, OS infos: I am running Windows 7 (x64). WhatPulse runs as administrator.

Join klamm.de and our WhatPulse-team at www.whatpulse-team.de.
Visit this user's website Find all posts by this user
Quote this message in a reply
04-24-2014, 04:56 PM
Post: #2
RE: Startup time exceeds 10 minutes
Not sure if it helps, but I've noticed related, but different behaviors of Whatpulse when starting up and when set to startup with Windows; on my Windows 8 machine it takes a while to start up (in the order of tens of seconds though, not minutes and certainly not ten minutes). It takes a lot more RAM when starting up than when running afterwards though (about 80 MB during startup on my machine, as opposed to 2-3 MB during normal operation).

I've had a different experience on my Windows 7 machine, where Whatpulse will crash in the background when attempting to startup with the machine, and require me to start it manually. This problem is significantly more annoying since I want to be able to have Whatpulse start and run with my computer without having to worry about what it's doing.

In my case these issues are certainly not unbearable but on the other hand it seems like as a stat tracking application Whatpulse should be as light as possible, so I definitely second the idea that startup time and reliability should be improved.
Find all posts by this user
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [SOLVED] Client crashes on startup v. 2.7 Win10x64 Lttngblt 11 4,087 10-08-2016 06:43 PM
Last Post: smitmartijn
  [SOLVED] OS X no longer starts, crashes on startup stuthemonkey 3 1,470 10-01-2016 06:34 PM
Last Post: smitmartijn
  [SOLVED] Client freezes and crashes on first startup Creator13 1 1,294 03-06-2016 12:43 PM
Last Post: smitmartijn
  [SOLVED] Asks for permission every time I load WhatPulse? Saprostomous 4 2,479 05-08-2015 08:21 PM
Last Post: Saprostomous
Bug [SOLVED] xubunt: main window on startup always showing bogy 1 2,393 02-25-2015 12:28 PM
Last Post: smitmartijn
  Bandwidth graph is anomalous around 5 minutes ago timothymh 0 1,271 02-14-2015 09:13 PM
Last Post: timothymh
  [SOLVED] Clean up required and failing each startup wilrob2 2 2,341 10-02-2014 05:42 PM
Last Post: wilrob2
  Minor database error when starting 2.4.1 for the first time Spleasure 1 2,097 09-29-2014 07:18 PM
Last Post: smitmartijn
  Application all time keys wrong laishiou 1 2,149 09-26-2014 04:22 PM
Last Post: smitmartijn
  [SOLVED] Geek Window not Updating in Real Time garrett.miller.3367 3 3,281 09-16-2014 11:14 AM
Last Post: smitmartijn

Forum Jump:

User(s) browsing this thread: 1 Guest(s)