WhatPulse Forums » Support » Client software v » Trouble with Whatpulse in Ubuntu. Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trouble with Whatpulse in Ubuntu.
12-21-2013, 07:24 AM (This post was last modified: 12-21-2013 07:43 AM by Giraffe.)
Post: #1
Trouble with Whatpulse in Ubuntu.
I tried to run Whatpulse and got this error.
[Image: Yl8Bl2e.png]
But when I went to try to download it, it looks like I already have it.
[Image: r3CwfCr.png]

I don't know how to use Linux that well. Can you please explain what I am doing wrong?

Er... I figured out the solution to my problem on my own. However, due to the way this page became formatted due to the large pictures I cannot edit it.

I thought if I deleted the pictures breaking the links I could then edit/delete this post as to not waste peoples' time, but I didn't log in before I uploaded them so I cannot do that.

Also my click on my track pad wont count.

Guess I am a failure all around.
Find all posts by this user
Quote this message in a reply
12-21-2013, 12:12 PM
Post: #2
RE: Trouble with Whatpulse in Ubuntu.
Everything you need is in de kb:

- http://whatpulse.org/kb/content/7/15/en/...ation.html
- http://whatpulse.org/kb/content/7/34/en/...linux.html

The installation guides notes openssl-devel, not just openssl, that's why you're getting that error.
Visit this user's website Find all posts by this user
Quote this message in a reply
12-25-2013, 05:28 AM
Post: #3
RE: Trouble with Whatpulse in Ubuntu.
(12-21-2013 12:12 PM)smitmartijn Wrote:  Everything you need is in de kb:

- http://whatpulse.org/kb/content/7/15/en/...ation.html
- http://whatpulse.org/kb/content/7/34/en/...linux.html

The installation guides notes openssl-devel, not just openssl, that's why you're getting that error.

Alright, I got it all working on my Ubuntu machine. Thank you.

However, I just put linux on my Chromebook so I could use Whatpulse on it. On Ubuntu I would just use the software centre to install those libraries. Since this version doesn't seem to have such a feature I need to learn how to do it with the Terminal, something I should probably know anyway.

I tried typing in 'sudo apt-get install libQtCore' but it says the file isn't found. I assume that there is some obvious grammar issue here, but I don't know it.
Find all posts by this user
Quote this message in a reply
12-25-2013, 12:31 PM
Post: #4
RE: Trouble with Whatpulse in Ubuntu.
Chromebook isn't currently supported (I don't have one), the client will not run on it (cpu architecture).
Visit this user's website Find all posts by this user
Quote this message in a reply
12-25-2013, 05:30 PM (This post was last modified: 12-25-2013 05:48 PM by Giraffe.)
Post: #5
RE: Trouble with Whatpulse in Ubuntu.
(12-25-2013 12:31 PM)smitmartijn Wrote:  Chromebook isn't currently supported (I don't have one), the client will not run on it (cpu architecture).

Eh, it took a bit of work but I got Whatpulse working on my Chromebook.

It counts my keys and downloads, but not my trackpad yet. I can probably get the trackpad working too, but I'm burnt out.

Took me like 8 hours to get it working. Bleh, I need to learn computers better. -_-

Edit: Oddly, the trackpad is counted in the Chromebook environment but not in the Linux one. No idea why yet. I might just call it good enough and not mess with it any further. ^_^
Find all posts by this user
Quote this message in a reply
12-25-2013, 08:21 PM
Post: #6
RE: Trouble with Whatpulse in Ubuntu.
Could you kindly explain how you got it working? I have been trying for quite a while.
Find all posts by this user
Quote this message in a reply
12-25-2013, 08:58 PM
Post: #7
RE: Trouble with Whatpulse in Ubuntu.
I don't remember it enough to say it step-by-step since I was drunk when I did it.

First I enabled developer mode, then used a program called Crouton to install Linux, then I did something in the terminal, then everything was good.
Find all posts by this user
Quote this message in a reply
01-03-2014, 01:22 PM
Post: #8
RE: Trouble with Whatpulse in Ubuntu.
Which Chromebook do you have? Don't suppose it's a standard ARM CPU type, right? Or is there an i386 emulator on there, that could explain the client being able to run?
Visit this user's website Find all posts by this user
Quote this message in a reply
01-03-2014, 02:57 PM
Post: #9
RE: Trouble with Whatpulse in Ubuntu.
Yeh that's true. He might have the pixel or something.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Cannot start WhatPulse using Ubuntu 19.10 Adrriii 1 90 11-01-2019 02:37 PM
Last Post: Adrriii
  Whatpulse crash [GoT]Jewest 3 206 10-28-2019 01:18 PM
Last Post: [GoT]Jewest
  Updating from jessie to buster breaks whatpulse [GoT]Jewest 2 202 10-28-2019 01:17 PM
Last Post: [GoT]Jewest
  Server error: Missing input! with whatpulse 2.8.4 on Win10 Franck.Dernoncourt 3 562 09-24-2019 10:56 PM
Last Post: kolah
  Whatpulse isn't running after upgrading Ubuntu 1geeky 0 231 08-06-2019 05:46 AM
Last Post: 1geeky
  WhatPulse 64bit install on Lubuntu 19.04 SiKTheGreatOne 0 379 06-30-2019 02:49 AM
Last Post: SiKTheGreatOne
  Ubuntu 16.04 and Libqt5 VanackSabbadium 0 441 06-09-2019 02:24 PM
Last Post: VanackSabbadium
  WhatPulse not opening on Manjaro Linux (Arch distro) tboxley 4 784 05-26-2019 11:30 AM
Last Post: FamilienVater
  Whatpulse won't start, Unable to install crashRpt! Bai.Bing 0 311 05-24-2019 01:02 PM
Last Post: Bai.Bing
  Whatpulse is not recognizing internet traffic Lodisen 8 1,044 05-22-2019 05:35 PM
Last Post: Trapton

Forum Jump:


User(s) browsing this thread: 1 Guest(s)