WhatPulse Forums » Support » Client software v » Archlinux: libGL.so.1 Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Archlinux: libGL.so.1
10-21-2013, 11:20 PM (This post was last modified: 10-22-2013 05:43 PM by smitmartijn.)
Post: #1
Archlinux: libGL.so.1
WP 2.2.1 on 64 bit archlinux.
Library exists in LD_LIBRARY_PATH

Where wp expected this library?
Find all posts by this user
Quote this message in a reply
10-22-2013, 05:43 PM
Post: #2
RE: Archlinux: libGL.so.1
In the library path...and it's not the client expecting it somewhere, the client only tells the system it needs 'these' libraries and the system does the rest. If the subject is your literal error, the library simply does not exist.

Check for capitalisation and whether it's the right version.

Archlinux isn't tested, but I remember someone who got it to work.
Visit this user's website Find all posts by this user
Quote this message in a reply
10-22-2013, 07:15 PM
Post: #3
RE: Archlinux: libGL.so.1
(10-22-2013 05:43 PM)smitmartijn Wrote:  Archlinux isn't tested, but I remember someone who got it to work.
At least me Wink But after updating to 2.2.1 it did not start anymore. Possible other updates interferences with this Problem...
Find all posts by this user
Quote this message in a reply
11-13-2013, 08:44 PM
Post: #4
RE: Archlinux: libGL.so.1
Code:
[andre@meg-mac wp]$ ./whatpulse
./whatpulse: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
[andre@meg-mac wp]$ ldd whatpulse | grep libGL.so.1
    libGL.so.1 => /usr/lib/catalystpxp/libGL.so.1 (0x00007f9b7c1af000)

Is there any special version required?
Find all posts by this user
Quote this message in a reply
11-13-2013, 09:13 PM
Post: #5
RE: Archlinux: libGL.so.1
It would throw another nasty error (usually something about dynamic functions not found) if it's a version thing, I think. "No such file or directory" is pretty clear..this is exactly why I stay away from Linux. ;-)
Visit this user's website Find all posts by this user
Quote this message in a reply
01-09-2014, 07:43 PM
Post: #6
RE: Archlinux: libGL.so.1
Looks like this problem only belongs to non-root user. Root can run Whatpulse without any problems :/
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)