WhatPulse Forums » Support » Client software v » Arrow keys not showing in heatmap Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Arrow keys not showing in heatmap
05-02-2013, 12:55 AM
Post: #1
Arrow keys not showing in heatmap
Hi Martijn, thank you for being so involved with the community!

I have a problem, though: although they are registering as keys and raising the keycount, the arrow keys (and the navigation and insert and delete keys) are not showing up in the heatmap.

Thanks for your time! Groetjes Smile
Find all posts by this user
Quote this message in a reply
05-03-2013, 08:03 PM
Post: #2
RE: Arrow keys not showing in heatmap
Please state your OS and other system details, I've tested the key mapping on most systems, but it could be different on yours.
Visit this user's website Find all posts by this user
Quote this message in a reply
05-04-2013, 04:43 PM (This post was last modified: 05-06-2013 12:07 AM by Milamber_conDoin.)
Post: #3
RE: Arrow keys not showing in heatmap
I run 32 bit Windows 7 with Whatpulse v2.1. Intel t9500 with an ATi Radeon HD 4650M.
Find all posts by this user
Quote this message in a reply
05-04-2013, 05:51 PM (This post was last modified: 05-04-2013 06:09 PM by Electrosa.)
Post: #4
RE: Arrow keys not showing in heatmap
For me the same happens. None of these keys are counted in the heatmap:

[Image: cyQPCtEl.jpg]

My OS is Windows 7 32 bits; WhatPulse version is 2.1.
I have looked into the database file searching when was the last date it recognised the key, and I think it occurs since 2.1b1 (in 2.0.4 it was OK).



PD: I can give you more information related on how is working on my computer: The key ids for those keys have changed comparing version 2.0.4 and previous, and 2.1:

WP <=2.0.4 - key up id is 16777235.
WP >2.1b1 - key up id is 16781913.
Find all posts by this user
Quote this message in a reply
05-05-2013, 05:09 AM (This post was last modified: 05-05-2013 05:11 AM by cavveman.)
Post: #5
RE: Arrow keys not showing in heatmap
(05-04-2013 08:30 PM)teilvtiw Wrote:  Same problem on Win7 x64 and Win8 x64 with v2.1(.1).

I am using a non-standard keyboard layout (Scandinavian with 3 extra vowels) - maybe that is causing the inconsistency?

That could be it. Since WP keyboard image doesnt have the extra letters as are required around the world.
But I do remember that the old whatpulse 1.7 did register scandinavian letters also since it did not use any heatmap as 2.X are using.

Running in win 8 x64 with 2.1.1
Find all posts by this user
Quote this message in a reply
05-06-2013, 11:22 PM (This post was last modified: 05-06-2013 11:23 PM by Bloopy.)
Post: #6
RE: Arrow keys not showing in heatmap
This bug has been there since at least 2.1b2. I get it on both Win7 and WinXP, and I use normal US layout keyboards. I was mashing the the keys to make them change colour, and at one point the 10 keys all changed to red, but they always show Pressed 0x:

[Image: heatmap1.png]

Also, since there's no numpad, why not have numpad numbers, arrows and symbols count towards their heatmap counterparts? My numpad enter already counts towards the heatmap enter.

Apart from that, 2.1.1 is working perfectly so far. Nice work guys!

[Image: 152857.jpg]
Visit this user's website Find all posts by this user
Quote this message in a reply
06-06-2013, 03:55 PM
Post: #7
RE: Arrow keys not showing in heatmap
Sorry to thread bump a month later but I recently installed WhatPulse and noticed my "Q" key is not being counted on the heatmap, along with my arrow keys, numpad, INS, DEL, HOME, etc. I'm working on a laptop with a 104-key Rosewill RK-9000BRI keyboard (standard ANSI layout) and use the numpad extensively throughout the day. Heatmap on my desktop at home has the same issue with 'Q' showing 0 presses, but keystrokes are still being counted towards my total.

[Image: BaP63Mv.png]

Laptop is running:
WhatPulse 2.1.1.
Windows 7 Home x64 (SP1)

Desktop:
WhatPulse 2.1.1.
Windows 7 Ultimate x64 (SP1)

All in all, neat program and I love getting statistics on my computer usage - just curious as to why the heatmap seems to be inconsistent.
Find all posts by this user
Quote this message in a reply
06-06-2013, 09:28 PM (This post was last modified: 06-06-2013 09:31 PM by blezer.)
Post: #8
RE: Arrow keys not showing in heatmap
same probleme here. but i have also G1 G2 G3 G4 G5 G6 buntons. can jou make that count in the next version? sorry for my bad englische Tongue

i am running on win8 professional 64x bit
keyboard: logitech gaming keyboard G105
whatpulse version: 2.1.1

thank you,
thom
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Showing incorrect pulse stats Vetselm 1 330 02-15-2020 03:54 PM
Last Post: smitmartijn
Brick Keys not registering in Red Dead Redemption 2 cerastes 2 514 12-24-2019 02:21 PM
Last Post: cerastes
  Keys & Clicks not recording anymore DJLunacy 0 776 05-08-2019 05:05 PM
Last Post: DJLunacy
  Modifier keys not registered (shift, alt, ctrl, enter) teilvtiw 4 2,761 04-24-2019 04:14 PM
Last Post: ajencks1
  Heatmap On = High CPU Usage Dark_wizzie 3 1,576 03-19-2017 07:28 AM
Last Post: Dark_wizzie
  [SOLVED] Error uploading keyboard/mouse heatmap Wopian 2 1,336 03-17-2017 12:26 PM
Last Post: Wopian
  [FIXED] Keyboard heatmap color mix up d3ullist 1 1,110 06-24-2016 06:49 PM
Last Post: smitmartijn
  doesn't recognize keys Posergoth6667 1 1,433 05-09-2016 04:56 PM
Last Post: mupi
  Total Clicks & Keys TotalBlank 4 2,082 02-02-2016 05:07 AM
Last Post: TotalBlank
Question How can I count keys before keybindings(Karabiner)? kumamotone 0 1,282 12-22-2015 09:56 AM
Last Post: kumamotone

Forum Jump:


User(s) browsing this thread: 1 Guest(s)