WhatPulse Forums » Support » Client software v » Linux - 2.0.4 doesn't work on Debian Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linux - 2.0.4 doesn't work on Debian
02-02-2013, 10:04 AM (This post was last modified: 02-02-2013 01:24 PM by smitmartijn.)
Post: #1
Linux - 2.0.4 doesn't work on Debian
64bit version:
Code:
./whatpulse: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by ./whatpulse)

32bit version:
Code:
./whatpulse: error while loading shared libraries: libQtWebKit.so.4: cannot open shared object file: No such file or directory

Code:
Linux version 3.3.0-8.dmz.1-liquorix-amd64 (Debian 3.3.0-9) () (gcc version 4.6.3 (Debian 4.6.3-7) ) #1 ZEN SMP PREEMPT Mon Jun 4 19:51:34 CDT 201

1.2 working "out of box", so still staying with 1.2. :/
Find all posts by this user
Quote this message in a reply
02-02-2013, 01:23 PM
Post: #2
RE: 2.0.4 doesn't work
Debian is currently not supported, as it uses outdated packages. There will be a Debian specific built sometime, but can't really say when.
Visit this user's website Find all posts by this user
Quote this message in a reply
02-02-2013, 04:40 PM
Post: #3
RE: Linux - 2.0.4 doesn't work on Debian
Oh... to bad. So I'm waiting for debian build Smile

Thanks for reply.
Find all posts by this user
Quote this message in a reply
03-09-2013, 09:10 AM
Post: #4
RE: Linux - 2.0.4 doesn't work on Debian
Hi, I resolved this issue by upgrading glibc library to version 2.17 (I guess you have to add Debian testing and/or experimental repo). After that WhatPulse works fine Smile
Find all posts by this user
Quote this message in a reply
03-13-2013, 01:49 PM
Post: #5
RE: Linux - 2.0.4 doesn't work on Debian
This has been known from the beta board....
  • Code:
    http://whatpulse.org/forums/showthread.php?tid=2006&pid=18212#pid18212
    &&
  • Code:
    http://whatpulse.org/forums/showthread.php?tid=1982

[Image: 2itq8g6.png]
^ This was cool xD
[Image: mcdty0-3.png]
Find all posts by this user
Quote this message in a reply
04-27-2013, 03:19 PM
Post: #6
RE: 2.0.4 doesn't work
(02-02-2013 01:23 PM)smitmartijn Wrote:  Debian is currently not supported, as it uses outdated packages. There will be a Debian specific built sometime, but can't really say when.

Just take a few minutes to compile against libc 2.13, you're not using any features from a newer version anyway.
Find all posts by this user
Quote this message in a reply
04-27-2013, 07:36 PM
Post: #7
RE: 2.0.4 doesn't work
(04-27-2013 03:19 PM)hostname Wrote:  Just take a few minutes to compile against libc 2.13, you're not using any features from a newer version anyway.

Probably not from the libc, correct. However, the client uses several Qt functions available only in 4.6+ (or 4.7+). When upgrading Qt on debian, you need to take everything with it, including libc, so thats useless. Downgrading libc on an up to date distro is also a nightmare.

To make it work, there needs to be a version that can work with the old Qt, which means recoding some stuff. Seeing as there are 2182 computers of the 136382 computers total using Linux (so 1.5%), this has not been given priority. It's still on the todo, and now that windows (with 2.1) is mostly stable, there is a chance it will happen soon.
Visit this user's website Find all posts by this user
Quote this message in a reply
04-28-2013, 12:45 PM
Post: #8
RE: 2.0.4 doesn't work
(04-27-2013 07:36 PM)smitmartijn Wrote:  Probably not from the libc, correct. However, the client uses several Qt functions available only in 4.6+ (or 4.7+). When upgrading Qt on debian, you need to take everything with it, including libc, so thats useless.
That's not true. Debian Squeeze has Qt 4.6, while the soon-to-be-released Wheezy even has Qt 4.8. Qt is also compiled against the default libc version in that version (2.11 for Squeeze, 2.13 for Wheezy), so you don't even need to update libc for the Qt version.

(Squeeze is almost two years old, so I can imagine you don't want to support that, though it shouldn't be hard. Wheezy will be released next weekend, and has a more than new enough Qt, so there's no reason to don't support it).

(04-27-2013 07:36 PM)smitmartijn Wrote:  Downgrading libc on an up to date distro is also a nightmare.
True, but you don't have to downgrade the running version, just don't reference the GLIBC_2.14 symbol.
Find all posts by this user
Quote this message in a reply
04-28-2013, 01:39 PM
Post: #9
RE: 2.0.4 doesn't work
(04-28-2013 12:45 PM)hostname Wrote:  That's not true. Debian Squeeze has Qt 4.6, while the soon-to-be-released Wheezy even has Qt 4.8. Qt is also compiled against the default libc version in that version (2.11 for Squeeze, 2.13 for Wheezy), so you don't even need to update libc for the Qt version.

Good phrasing; "the soon-to-be-released" - as it's currently still in testing phase. And you're right, I don't want to support an OS that's still in beta.

Expect a compiled version when this Wheezy version comes out, or when there's time to make the client Qt 4.6 compatible.
Visit this user's website Find all posts by this user
Quote this message in a reply
04-28-2013, 01:43 PM (This post was last modified: 04-28-2013 01:43 PM by hostname.)
Post: #10
RE: 2.0.4 doesn't work
(04-28-2013 01:39 PM)smitmartijn Wrote:  Good phrasing; "the soon-to-be-released" - as it's currently still in testing phase. And you're right, I don't want to support an OS that's still in beta.

Expect a compiled version when this Wheezy version comes out, or when there's time to make the client Qt 4.6 compatible.
Ok, I'll be happy to download it on Sunday then Smile
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [SOLVED] Can't run the Linux version [Driver not loaded Driver not loaded] radioz 2 1,074 06-20-2019 11:54 AM
Last Post: radioz
  WhatPulse not opening on Manjaro Linux (Arch distro) tboxley 4 779 05-26-2019 11:30 AM
Last Post: FamilienVater
  [Edited] Whatpulse does not work with libssl-dev 1.1.0 jhepburn 4 4,157 03-07-2017 11:11 PM
Last Post: swissboney3
  [CLOSED] Debian Stretch: OpenSSL library not found wullxz 1 846 02-27-2017 05:31 PM
Last Post: smitmartijn
  [CLOSED] Does whatpulse linux support Qt5 satshow 1 1,244 06-26-2016 06:19 PM
Last Post: smitmartijn
  WhatPulse don't work for me ImMario_ 1 996 06-19-2016 01:45 PM
Last Post: smitmartijn
  Will WhatPulse work on Intel Atom? Code-E 1 1,016 05-28-2016 08:06 PM
Last Post: smitmartijn
  doesn't recognize keys Posergoth6667 1 1,059 05-09-2016 04:56 PM
Last Post: mupi
  [CLOSED] Installing on ARM Based Linux London_Ash 3 3,875 05-01-2016 11:42 PM
Last Post: Wopian
  Help for Linux version angelo.gallesio 0 660 04-27-2016 11:26 AM
Last Post: angelo.gallesio

Forum Jump:


User(s) browsing this thread: 1 Guest(s)