WhatPulse Forums » Support » Client software v » Linux client requiring GLIBC_2.14 Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linux client requiring GLIBC_2.14
12-29-2012, 10:48 PM
Post: #1
Linux client requiring GLIBC_2.14
Is there any reason for the Linux client to require glibc 2.14? It doesn't seem to use any of its features, and it blocks usage on Debian Wheezy.
Find all posts by this user
Quote this message in a reply
12-30-2012, 02:11 AM
Post: #2
RE: Linux client requiring GLIBC_2.14
(12-29-2012 10:48 PM)hostname Wrote:  Is there any reason for the Linux client to require glibc 2.14? It doesn't seem to use any of its features, and it blocks usage on Debian Wheezy.


Indeed. It always annoy's me when binary-only releases do not make static build binaries and build off older versions of glib to support more distro's/systems. I have to run mine out of an ubuntu chroot environment.
Find all posts by this user
Quote this message in a reply
12-30-2012, 09:45 AM
Post: #3
RE: Linux client requiring GLIBC_2.14
The reason is that the client was built on Qt 4.8 (minimal 4.7) - which is also not available on Debian. Any modern distribution has up to date packages, which is why I decided to put this out there now and see if it's back portable on a later date.
Visit this user's website Find all posts by this user
Quote this message in a reply
12-30-2012, 11:59 AM
Post: #4
RE: Linux client requiring GLIBC_2.14
Totally off-topic but I wonder how WhatPulse chooses NOT to support Debian Squeeze (about 3 years old) vs. DO supporting Windows XP (about 12 years old). Speaking of modern distro's/OS's.
Find all posts by this user
Quote this message in a reply
12-30-2012, 12:14 PM
Post: #5
RE: Linux client requiring GLIBC_2.14
(12-30-2012 11:59 AM)MAX3400 Wrote:  Totally off-topic but I wonder how WhatPulse chooses NOT to support Debian Squeeze (about 3 years old) vs. DO supporting Windows XP (about 12 years old). Speaking of modern distro's/OS's.

Quick answer; Windows does backwards compatibility pretty good, so all the Windows code is the same for XP, Vista, 7, 8. The 'biggest' issue here is Qt; the client needs at least 4.7. Qt 4.7 is 2 years old, which is pretty reasonable for me to have updated your packages to it, but I guess Debian has a different release schedule.

Once I have time to rearrange some Qt code so it can be compiled with 4.6, there will be a Debian release.
Visit this user's website Find all posts by this user
Quote this message in a reply
12-30-2012, 12:25 PM
Post: #6
RE: Linux client requiring GLIBC_2.14
(12-30-2012 09:45 AM)smitmartijn Wrote:  The reason is that the client was built on Qt 4.8 (minimal 4.7) - which is also not available on Debian. Any modern distribution has up to date packages, which is why I decided to put this out there now and see if it's back portable on a later date.

That's not true. Debian Wheezy includes Qt 4.8.2. I understand that you don't want to support Squeeze (which will be obsolete in a few months anyway), but Wheezy is a modern distribution with up to date packages.
Find all posts by this user
Quote this message in a reply
12-30-2012, 12:33 PM
Post: #7
RE: Linux client requiring GLIBC_2.14
Well, apparently the main download is not this Wheezy, so I'm guessing most Debian users won't have that version.

So Wheezy has later versions of software packages, but they scrapped it for older software on the main train? Doesn't make much sense to me..
Visit this user's website Find all posts by this user
Quote this message in a reply
12-30-2012, 12:50 PM (This post was last modified: 12-30-2012 12:50 PM by hostname.)
Post: #8
RE: Linux client requiring GLIBC_2.14
No. Debian Squeeze (Debian 6.0) is the current stable (released) version. Debian Wheezy (Debian 7.0) will be the next stable version (called "testing"), and is currently in the final pre-release stage. It'll probably be released somewhere around March.

However, due to the ultimate stability Debian aims for, even the pre-release versions are very stable and often a lot more stable than other distributions. Ubuntu LTS releases are actually based upon the Debian testing version (the normal releases are based upon unstable, which is the development version). See Wikipedia for more information about the release schedule.

Almost all desktop users run the testing or unstable version, because the stable version is too old and the testing version is very stable too, while stable is mainly used on servers. Thus, most users of WhatPulse on Debian will have Qt 4.8.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Support for Linux dropped ? Adrriii 4 297 04-05-2020 09:39 PM
Last Post: pederoco
  Cannot start Whatpulse successfully on Manjaro 18.1.4 (Arch Linux) anijatsu 2 412 01-12-2020 04:06 PM
Last Post: Adrriii
  Having trouble running whatpulse on Neon Linux BlackWidow 1 400 12-03-2019 12:02 AM
Last Post: Adrriii
  [SOLVED] Can't run the Linux version [Driver not loaded Driver not loaded] radioz 2 1,485 06-20-2019 11:54 AM
Last Post: radioz
  WhatPulse not opening on Manjaro Linux (Arch distro) tboxley 4 1,341 05-26-2019 11:30 AM
Last Post: FamilienVater
  Mac client causing latency every ~10 seconds bryandh 10 3,547 03-09-2017 04:50 PM
Last Post: DJLunacy
Information [CLOSED] Mouse distance counter in Windows client. TigraPolosatiy 1 1,049 02-27-2017 05:30 PM
Last Post: smitmartijn
  Client crash on launch (v2.7.1) Sovex66 13 3,563 02-27-2017 09:31 AM
Last Post: Dosphal
Bug Client doing an insane amount of writing to disk Formina_Sage 4 1,563 11-04-2016 04:47 PM
Last Post: smitmartijn
  [SOLVED] Client crashes on startup v. 2.7 Win10x64 Lttngblt 11 3,697 10-08-2016 06:43 PM
Last Post: smitmartijn

Forum Jump:


User(s) browsing this thread: 1 Guest(s)