WhatPulse Forums » Support » Client software v » No interfaces listed in Ubuntu 12.10 Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 1 Votes - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No interfaces listed in Ubuntu 12.10
05-01-2013, 01:20 PM
Post: #31
RE: No interfaces listed in Ubuntu 12.10
Could anyone with this problem post the result of the command 'ifconfig' here?
Visit this user's website Find all posts by this user
Quote this message in a reply
05-01-2013, 03:42 PM
Post: #32
RE: No interfaces listed in Ubuntu 12.10
(05-01-2013 01:20 PM)dutchmega Wrote:  Could anyone with this problem post the result of the command 'ifconfig' here?


Code:
eth1      Link encap:Ethernet  HWaddr 18:03:73:2b:4a:86  
          inet addr:192.168.120.181  Bcast:192.168.123.255  Mask:255.255.252.0
          inet6 addr: fe80::1a03:73ff:fe2b:4a86/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9948097 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3364047 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3821150983 (3.8 GB)  TX bytes:770957869 (770.9 MB)
          Interrupt:20 Memory:f7100000-f7120000

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:304415 errors:0 dropped:0 overruns:0 frame:0
          TX packets:304415 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:48057815 (48.0 MB)  TX bytes:48057815 (48.0 MB)
Find all posts by this user
Quote this message in a reply
05-02-2013, 06:11 AM
Post: #33
RE: No interfaces listed in Ubuntu 12.10
Code:
eth0      Link encap:Ethernet  Hardware Adresse bc:ae:c5:26:f4:50  
          inet Adresse:XXX.XXX.XXX.111  Bcast:XXX.XXX.XXX.255  Maske:255.255.255.0
          inet6-Adresse: fe80::beae:c5ff:fe26:f450/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:1282347153 errors:0 dropped:0 overruns:0 frame:0
          TX packets:158640177 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX-Bytes:1813131494819 (1.8 TB)  TX-Bytes:13188444803 (13.1 GB)
          Interrupt:18

eth1      Link encap:Ethernet  Hardware Adresse bc:ae:c5:26:f6:3a  
          UP BROADCAST MULTICAST  MTU:1500  Metrik:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX-Bytes:0 (0.0 B)  TX-Bytes:0 (0.0 B)
          Interrupt:17

lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:16436  Metrik:1
          RX packets:375379 errors:0 dropped:0 overruns:0 frame:0
          TX packets:375379 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX-Bytes:101105525 (101.1 MB)  TX-Bytes:101105525 (101.1 MB)

tun0      Link encap:UNSPEC  Hardware Adresse 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet Adresse:10.10.0.18  P-z-P:10.10.0.17  Maske:255.255.255.255
          UP PUNKTZUPUNKT RUNNING NOARP MULTICAST  MTU:1500  Metrik:1
          RX packets:4385 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3311 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:100
          RX-Bytes:257135 (257.1 KB)  TX-Bytes:746501 (746.5 KB)
My IP is a public routeable one, that why I set the X's ...
Find all posts by this user
Quote this message in a reply
05-04-2013, 12:24 AM
Post: #34
RE: No interfaces listed in Ubuntu 12.10
Guys, I fixed my problem completely by uninstalling the old WinPCap, and just downloading the newest one off of their website. I don't know if this is the problem for you guys, but it fixed my problem.
Find all posts by this user
Quote this message in a reply
05-04-2013, 08:57 AM
Post: #35
RE: No interfaces listed in Ubuntu 12.10
(05-04-2013 12:24 AM)Bluekandy Wrote:  Guys, I fixed my problem completely by uninstalling the old WinPCap, and just downloading the newest one off of their website. I don't know if this is the problem for you guys, but it fixed my problem.

Probably not, as WinPcap is for Windows, not Linux. ;-)
Visit this user's website Find all posts by this user
Quote this message in a reply
05-06-2013, 09:53 AM
Post: #36
RE: No interfaces listed in Ubuntu 12.10
(05-01-2013 01:20 PM)dutchmega Wrote:  Could anyone with this problem post the result of the command 'ifconfig' here?

a) Non-working ifconfig [With vmware and openvpn stopped]
Code:
eth0      Link encap:Ethernet  HWaddr bc:ae:c5:44:07:ce  
          inet addr:10.2.1.150  Bcast:10.2.1.255  Mask:255.255.255.0
          inet6 addr: fe80::beae:c5ff:fe44:7ce/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14664818 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14723040 errors:0 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000
          RX bytes:8365636613 (8.3 GB)  TX bytes:6775318935 (6.7 GB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:50928 errors:0 dropped:0 overruns:0 frame:0
          TX packets:50928 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:37892111 (37.8 MB)  TX bytes:37892111 (37.8 MB)

b) Working ifconfig [with vmware started]. Ifconfig with openvpn is similar to that of roemer2201
Code:
eth0      Link encap:Ethernet  HWaddr bc:ae:c5:44:07:ce  
          inet addr:10.2.1.150  Bcast:10.2.1.255  Mask:255.255.255.0
          inet6 addr: fe80::beae:c5ff:fe44:7ce/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14675537 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14734048 errors:0 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000
          RX bytes:8370009552 (8.3 GB)  TX bytes:6776646013 (6.7 GB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:51007 errors:0 dropped:0 overruns:0 frame:0
          TX packets:51007 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:37908137 (37.9 MB)  TX bytes:37908137 (37.9 MB)

vmnet1    Link encap:Ethernet  HWaddr 00:50:56:c0:00:01  
          inet addr:172.16.30.1  Bcast:172.16.30.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:46 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

vmnet8    Link encap:Ethernet  HWaddr 00:50:56:c0:00:08  
          inet addr:172.16.91.1  Bcast:172.16.91.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
Find all posts by this user
Quote this message in a reply
05-06-2013, 10:05 AM
Post: #37
RE: No interfaces listed in Ubuntu 12.10
Thanks, that is helpful.

Could you also post the content of /proc/net/dev?
Visit this user's website Find all posts by this user
Quote this message in a reply
05-07-2013, 01:06 PM (This post was last modified: 05-07-2013 01:10 PM by FamilienVater.)
Post: #38
RE: No interfaces listed in Ubuntu 12.10
I've just downloaded WhatPulse 2.1.1 64bit and am still having the problems (Linuxmint 14). Additionally, the program now crashes, whenever I plug or unplug the network or enable/disable the WiFi-Card.

- Wireless is detected and the traffic is counted
- Ethernet is detected as "unknown" and traffic is not counted


Here's my Information if it's helpful:

Start of the program:
Quote:07-05-2013 15:01:05.199 INFO Starting WhatPulse...
07-05-2013 15:01:05.286 WARN "sni-qt/9865" WARN 15:01:05.286 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE
07-05-2013 15:01:05.287 DEBUG Database file: "/home/hsegnitz/.local/share/data/WhatPulse/whatpulse.db"
07-05-2013 15:01:05.771 DEBUG Database check: "ok"
07-05-2013 15:01:05.772 DEBUG Opened database in: 485 ms
07-05-2013 15:01:05.778 DEBUG Found proper permissions for network monitoring
07-05-2013 15:01:05.778 DEBUG Encrypted file: "/home/hsegnitz/.local/share/data/WhatPulse/whatpulse.wpw"
07-05-2013 15:01:06.294 DEBUG Opening GeoIP database: "/home/hsegnitz/.local/share/data/WhatPulse/GeoIP.dat"
07-05-2013 15:01:06.299 DEBUG Creating device listener for "/dev/input/event0"
07-05-2013 15:01:06.299 DEBUG Creating device listener for "/dev/input/event1"
07-05-2013 15:01:06.299 DEBUG Creating device listener for "/dev/input/event2"
07-05-2013 15:01:06.300 DEBUG Creating device listener for "/dev/input/event3"
07-05-2013 15:01:06.300 DEBUG Creating device listener for "/dev/input/event4"
07-05-2013 15:01:06.300 DEBUG Creating device listener for "/dev/input/event5"
07-05-2013 15:01:06.300 DEBUG Creating device listener for "/dev/input/event6"
07-05-2013 15:01:06.300 DEBUG Creating device listener for "/dev/input/event7"
07-05-2013 15:01:06.300 DEBUG Creating device listener for "/dev/input/event8"
07-05-2013 15:01:06.301 DEBUG Starting PfRingNetworkTrafficMonitor..
07-05-2013 15:01:06.302 DEBUG PF-Ring thread started
07-05-2013 15:01:06.325 DEBUG WhatPulse has started
07-05-2013 15:01:06.413 WARN Unable to find videocard in our database with vendor "1002" , device "7145" and subsys "10282002"
07-05-2013 15:01:06.431 WARN QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout

output of ifconfig:
Quote:eth0 Link encap:Ethernet HWaddr 00:15:c5:4f:66:e2
inet addr:192.168.0.106 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2328 errors:0 dropped:0 overruns:0 frame:0
TX packets:1481 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2359814 (2.3 MB) TX bytes:159560 (159.5 KB)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4315 errors:0 dropped:0 overruns:0 frame:0
TX packets:4315 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:589290 (589.2 KB) TX bytes:589290 (589.2 KB)

wlan0 Link encap:Ethernet HWaddr 00:18Big Grine:a5:6e:7f
inet addr:192.168.0.103 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:6999 errors:0 dropped:0 overruns:0 frame:0
TX packets:4941 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8328256 (8.3 MB) TX bytes:624296 (624.2 KB)


output of "cat /proc/net/dev":

Quote:Inter-| Receive | Transmit
face |bytes packets errs drop fifo frame compressed multicast|bytes packets errs drop fifo colls carrier compressed
eth0: 2368969 2382 0 0 0 0 0 76 163436 1511 0 0 0 0 0 0
lo: 642364 4686 0 0 0 0 0 0 642364 4686 0 0 0 0 0 0
wlan0: 8330249 7010 0 0 0 0 0 0 624296 4941 0 0 0 0 0 0



and here's the crashlog:


Quote:07-05-2013 15:08:26.158 DEBUG Stopping PfRingNetworkTrafficMonitor..
07-05-2013 15:08:26.158 DEBUG "received 7723 packets, dropped 0
"
07-05-2013 15:08:26.158 DEBUG Starting PfRingNetworkTrafficMonitor..
07-05-2013 15:08:26.183 DEBUG PF-Ring thread started
07-05-2013 15:08:26.184 WARN QThread: Destroyed while thread is still running
07-05-2013 15:08:26.187 DEBUG PF-Ring thread stopped
Application crashed with signal 11!
0 [/usr/lib/x86_64-linux-gnu/libQtCore.so.4(+0x7aacb) [0x7fbb8f563acb]]
1 [/usr/lib/x86_64-linux-gnu/libQtCore.so.4(+0x7bb02) [0x7fbb8f564b02]]
2 [/lib/x86_64-linux-gnu/libpthread.so.0(+0x7e9a) [0x7fbb8f2d3e9a]]
3 [/lib/x86_64-linux-gnu/libc.so.6(clone+0x6d) [0x7fbb8e7ebccd]]
Find all posts by this user
Quote this message in a reply
05-08-2013, 01:19 PM
Post: #39
RE: No interfaces listed in Ubuntu 12.10
Thanks that helps. Fix willl be in the next release.
Visit this user's website Find all posts by this user
Quote this message in a reply
05-15-2013, 07:04 AM
Post: #40
RE: No interfaces listed in Ubuntu 12.10
(05-06-2013 10:05 AM)dutchmega Wrote:  Thanks, that is helpful.

Could you also post the content of /proc/net/dev?

Sorry, missed this post. Please find the information below.

I. With vmware running
Code:
Inter-|   Receive                                                |  Transmit
face |bytes    packets errs drop fifo frame compressed multicast|bytes    packets errs drop fifo colls carrier compressed
vmnet8:       0       0    0    0    0     0          0         0        0   28207    0    0    0     0       0          0
  eth0: 38895002792 54556061    0    0    0     0          0    154700 21378189803 50587770    0    0    0     0       9          0
    lo: 174162783  281706    0    0    0     0          0         0 174162783  281706    0    0    0     0       0          0
vmnet1:       0       0    0    0    0     0          0         0        0   28164    0    0    0     0       0          0

II. With openvpn running
Code:
Inter-|   Receive                                                |  Transmit
face |bytes    packets errs drop fifo frame compressed multicast|bytes    packets errs drop fifo colls carrier compressed
  tun0:       0       0    0    0    0     0          0         0        0       0    0    0    0     0       0          0
  eth0: 38896200715 54559275    0    0    0     0          0    154843 21379219360 50590523    0    0    0     0       9          0
    lo: 174163055  281708    0    0    0     0          0         0 174163055  281708    0    0    0     0       0          0


III. Without any services
Code:
Inter-|   Receive                                                |  Transmit
face |bytes    packets errs drop fifo frame compressed multicast|bytes    packets errs drop fifo colls carrier compressed
  eth0: 38895694307 54557765    0    0    0     0          0    154724 21379002856 50589453    0    0    0     0       9          0
    lo: 174162783  281706    0    0    0     0          0         0 174162783  281706    0    0    0     0       0          0

Network monitor works in case 1 and 2 only and it stop as soon as i stop either of the services (essentially taking the third interface down).

Hope this helps.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Cannot start WhatPulse using Ubuntu 19.10 Adrriii 1 66 11-01-2019 02:37 PM
Last Post: Adrriii
  Whatpulse isn't running after upgrading Ubuntu 1geeky 0 214 08-06-2019 05:46 AM
Last Post: 1geeky
  Ubuntu 16.04 and Libqt5 VanackSabbadium 0 420 06-09-2019 02:24 PM
Last Post: VanackSabbadium
  [CLOSED] Network traffic not recorded on Ubuntu 16.04 LTS GnaXi 4 1,656 09-15-2016 03:33 AM
Last Post: smitmartijn
  Ubuntu on Mac SeeEmAge 0 713 04-29-2016 09:10 PM
Last Post: SeeEmAge
  Memory leak WhatPulse 2.6.3 on Ubuntu 15.04 Wouter0100 2 1,945 01-07-2016 11:52 AM
Last Post: Wouter0100
Sad [Ubuntu 14.04.3] Mouse clicks not logged Carlgo11 0 940 12-16-2015 09:45 AM
Last Post: Carlgo11
  [CLOSED] WhatPulse not starting - Ubuntu 12.04 on Chromebook Code-E 6 2,659 05-19-2015 05:58 PM
Last Post: Divisi
  [SOLVED] Uninstall from Ubuntu vell 1 1,581 02-24-2015 09:05 PM
Last Post: smitmartijn
  Inactive interfaces, PPPOE connection Cyph 3 2,027 01-01-2015 09:11 PM
Last Post: smitmartijn

Forum Jump:


User(s) browsing this thread: 1 Guest(s)