WhatPulse Forums » Support » Client software v » Ubuntu AMD64 client not capturing network traffic Welcome back, Guest.


Thread Closed 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ubuntu AMD64 client not capturing network traffic
01-08-2013, 10:57 AM
Post: #11
RE: Ubuntu AMD64 client not capturing network traffic
I have the same problem, Whatpulse is not detecting any interfaces even though I have the required dependencies installed and running fine.

OS: Lubuntu 12.04 64-bit
Wireshark runs fine
Used to run the old whatpulse v1 for Linux - working fine
Current whatpulse version: 2.0.1

The interface I am using is usb0 (tether), below is my ifconfig
Code:
eth0      Link encap:Ethernet  HWaddr 00:00:00:00:00:10  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:35 errors:0 dropped:0 overruns:0 frame:0
          TX packets:35 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:6327 (6.3 KB)  TX bytes:6327 (6.3 KB)

tun       Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet6 addr: 2001:fd8:600:10::19/128 Scope:Global
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1280  Metric:1
          RX packets:38 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:500
          RX bytes:2545 (2.5 KB)  TX bytes:2118 (2.1 KB)

usb0      Link encap:Ethernet  HWaddr da:bd:7c:f0:1c:0c  
          inet addr:192.168.42.172  Bcast:192.168.42.255  Mask:255.255.255.0
          inet6 addr: fe80::d8bd:7cff:fef0:1c0c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7102 errors:3 dropped:0 overruns:0 frame:3
          TX packets:8715 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3468152 (3.4 MB)  TX bytes:1445487 (1.4 MB)

tun - my IPv6 tunnel

I hope it helps in some way or another.
Find all posts by this user
01-31-2013, 07:04 AM
Post: #12
RE: Ubuntu AMD64 client not capturing network traffic
Did someone find out something new regarding this topic? I'm at 2.03 and still got no interfaces detected.
Find all posts by this user
02-18-2013, 02:05 PM
Post: #13
RE: Ubuntu AMD64 client not capturing network traffic
For me with 2.0.4 WP now detects my NIC as inactive.
Find all posts by this user
05-25-2013, 04:29 PM
Post: #14
RE: Ubuntu AMD64 client not capturing network traffic
I have experiencing the same behavior in version 2.0.4 under windows 7 64 bit with an intel nic
Find all posts by this user
05-25-2013, 05:37 PM
Post: #15
RE: Ubuntu AMD64 client not capturing network traffic
(05-25-2013 04:29 PM)Zyndarius Wrote:  I have experiencing the same behavior in version 2.0.4 under windows 7 64 bit with an intel nic

Excellent way to hijack a thread, good sir. You simply need to get the windows based WinPcap (.org, or included in the installer)

For Linux; this will be fixed in the next release - the format of a system file is not identical on all Linux systems and we're not focusing on the format anymore, just the content. That will get the interfaces no matter the format of the file.
Visit this user's website Find all posts by this user
Thread Closed 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Whatpulse 3.2 on Ubuntu 21.04 Lieutenant_Dan 2 235 04-26-2021 05:23 PM
Last Post: Lieutenant_Dan
  Modifiers key on Ubuntu Erwane 0 155 04-09-2021 11:48 AM
Last Post: Erwane
  client 3.0 behind sniffing corporate proxy cannot pulse drdamour 5 864 02-04-2021 04:35 AM
Last Post: Bloopy
  Network stats displayed / counted wrong MrElliwood 0 382 01-30-2021 10:10 PM
Last Post: MrElliwood
  Error: "Network access is disabled." Jourei 5 920 01-20-2021 07:01 AM
Last Post: penguin2233
  Client 3.0 Window opens on startup despite setting it not to XeaLouS 4 903 01-17-2021 12:08 PM
Last Post: smitmartijn
Question 3.0 not tracking network stats on macOS numbermaniac 0 432 01-02-2021 11:36 AM
Last Post: numbermaniac
  3.0 Mac Network Not Tracking mewturn 3 671 12-30-2020 05:57 AM
Last Post: mewturn
  Whatpulse Client and Windows 10 (20H2) d3FC0N 3 1,194 12-29-2020 12:54 PM
Last Post: d3FC0N
  Cannot start WhatPulse using Ubuntu 19.10 Adrriii 8 4,583 11-05-2020 02:23 PM
Last Post: Juje

Forum Jump:


User(s) browsing this thread: 1 Guest(s)