WhatPulse Forums » Community » Beta client » Archive v » Debian 6 commandline fails Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Debian 6 commandline fails
12-23-2012, 12:21 PM
Post: #1
Debian 6 commandline fails
Right, ever since I gotten the nice email telling me there was a new WhatPulse-client, I did upgrade my Windows machines. At the same time, I tried installing the 64-bit Linux client on a Debian-machine but this seems to go horribly wrong.

I've gotten these steps done but when everything finishes and I want to run WhatPulse-client, it comes up with an error

apt-get install bison build-essential gawk m4 texinfo libqt4-core libqt4-dev libqt4-sql libqt4-sql-sqlite openssl make automake
wget http://ftp.gnu.org/gnu/glibc/glibc-2.16.0.tar.gz
tar zvxf glibc-2.16.0.tar.gz
mkdir glib-build
cd glib-build
../glibc-2.16.0/./configure --disable-sanity-checks
make
sudo ldconfig
./whatpulse

./whatpulse: /lib/libc.so.6: version `GLIBC_2.14' not found (required by ./whatpulse)


I am running Debian in VMware using the 6.0.6 x64 NetInst.iso and, for somewhat dumb reason maybe, NOT using unstable/testing repo's.

Anyone care to help?
Find all posts by this user
Quote this message in a reply
12-23-2012, 12:36 PM (This post was last modified: 12-23-2012 12:39 PM by JJJJust.)
Post: #2
RE: Debian 6 commandline fails
Debian has a 2.16 version in the experimental repo. Even though it trashed my system (probably because im multi-arching), you should try using that before compiling from source.

And if you aren't using unstable/testing repos, as stated in the other thread, Whatpulse needs a higher QT version than is in the stable repo, so it won't work anyways...
Find all posts by this user
Quote this message in a reply
12-23-2012, 03:56 PM
Post: #3
RE: Debian 6 commandline fails
Tried the unstable repos just now; error comes back same even after a clean install, adjusting sources.list, doing an upgrade and installing the latest libqtcore4
Find all posts by this user
Quote this message in a reply
12-23-2012, 04:14 PM (This post was last modified: 12-23-2012 04:14 PM by JJJJust.)
Post: #4
RE: Debian 6 commandline fails
(12-23-2012 03:56 PM)MAX3400 Wrote:  Tried the unstable repos just now; error comes back same even after a clean install, adjusting sources.list, doing an upgrade and installing the latest libqtcore4

To get rid of the error you originally stated, you either need to compile glibc >= 2.14 from source or get libc6 2.16 from experimental.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  GLIBC and Debian JJJJust 7 10,331 12-23-2012 12:41 PM
Last Post: smitmartijn

Forum Jump:


User(s) browsing this thread: 1 Guest(s)