WhatPulse Forums » Community » Beta client » Archive v » Windows b5 client bugs Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows b5 client bugs
10-12-2012, 01:50 PM
Post: #11
Windows b5 client bugs
Huh, you're right, the pagination is off. Well, that's another bug, then, although you can always navigate to ?page=0 on the meantime as a temporary fix.
Find all posts by this user
Quote this message in a reply
10-12-2012, 03:25 PM
Post: #12
Windows b5 client bugs
Bandwidth is not counted using my built-in Atheros AR9485 wireless adapter.
Find all posts by this user
Quote this message in a reply
10-13-2012, 04:13 AM
Post: #13
Windows b5 client bugs
Selly -- awesome reports. Dang. :o

[Image: XKalSig1.png]
Visit this user's website Find all posts by this user
Quote this message in a reply
10-13-2012, 05:19 AM
Post: #14
Windows b5 client bugs
Heh, thanks ^^

I've seen so many beta builds with tons of issues, but because no-one reports them (assuming "oh, it's a beta, they'll be fixed) the developers never hear about them. And, as someone who has been dabbling in programming recently, I know how much of a bitch it is to find a problem in 20,000 lines of code when your only bug report is "it crashes".
Find all posts by this user
Quote this message in a reply
10-13-2012, 07:34 AM
Post: #15
Windows b5 client bugs
The Qaulcomm Atheros AR9485 802.11b/g/n WiFi Adapter isn't recognised, either. Thanks to AufurNitro for that.

In addition there appears to be a bug with launching on start:

[6:07:05 PM] Alex Ashenden (ExplodingPonyTwink): I had it set to launch automatically on computer start, but it didn't do that for me.

I'm not willing to risk my uptime testing this, so I'll wait on more information.

EDIT: It appears that this may be an error with a program crash that went unnoticed, not failure to launch. More info is required, though.
Find all posts by this user
Quote this message in a reply
10-13-2012, 09:00 AM
Post: #16
Windows b5 client bugs
I've been getting reports of keycount not recording in fullscreen games. Bandwidth and uptime appear to be unaffected. The only game this is confirmed for happening in is Team Fortress 2 (the client doesn't seem to record keys at all while the game is running, even while TF2 is in the background. Batman: Arkham Asylum and Burnout Paradise were tested, but WhatPulse crashed during testing. It seemed to count keys.

Counter-Strike: Global Offensive and International Cricket Captain 2012* work fine, so it's clearly just a problem with some games, not all full-screen applications.

Combat Arms, the Half-Life series, and a few others are being tested as I speak. Will update as I get results.

*ExplodingPonyToast is this game's entire fanbase.

EDIT: Dragon Age Origins is in the clear. Half Life doesn't work. Half Life 2 is already broken. Based on this (HL/HL2/TF2) it seems to be the HL engine that's conflicting. Testing in Portal and L4D to confirm. This is a pretty big bug, as they're some of the most popular games out there.

EDITEDIT: Tested Portal 2 and L4D2, neither worked. WhatPulse 2.0 does not record keys while games built on the HL2 engine are open. It seems fine with all other games. Fullscreen games (not just HL2 engine) also seem more prone to crashing the client than normal usage.

Testing is continuing just for the sake of making absolutely sure. Sonic Generations and Stepmania run fine, as are Just Cause 2 and Saints Row the Third.

EDIT³: Seems Combat Arms breaks too... Huh.

IMMENSE thanks to AufurNitro for this testing.
Find all posts by this user
Quote this message in a reply
10-13-2012, 11:40 AM
Post: #17
Windows b5 client bugs
Longest uptime and total uptime stats seem to be broken for some users. Works fine for me, though. Getting more info as I can.

[Image: kkb63.png]
[10:11:26 PM] Mason: It said "less than a minute" until this morning.
[10:12:14 PM] Mason: As soon as I installed it, current uptime was like 7 minutes but total was less than a minute.

Thanks to MysteryMason for this report.
Find all posts by this user
Quote this message in a reply
10-13-2012, 11:43 AM
Post: #18
Windows b5 client bugs
sellyme Wrote:IMMENSE thanks to AufurNitro for this testing.

Happy to help.
Find all posts by this user
Quote this message in a reply
10-13-2012, 11:46 AM
Post: #19
Windows b5 client bugs
Apparently MysteryMason managed to record some BitTorrent usage without a network adapter being recognised...

[Image: gkvL2.png]
[Image: Zt7LT.png]
This is with a TP-Link Wireless USB Adapter.

[10:17:00 PM] Jett: it did similar to mine.
[10:17:00 PM] Jett: it picked up on some downloads and uploads but nothing showed up on the network tab
Find all posts by this user
Quote this message in a reply
10-13-2012, 01:26 PM
Post: #20
Windows b5 client bugs
Application and interface bandwidth is handled by separate processes, so different results are possible. There's a pretty big filter for removing bogus interfaces (bluetooth, loopback, tunnels, etc) from the list.

Could you get me the complete name and type of the interfaces it does not recognise?
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [SOLVED] Server Lost Client Token Inquizitor 3 1,930 04-12-2015 09:30 AM
Last Post: smitmartijn
  Windows Beta 7 Crash X-Kal 3 8,227 12-04-2012 09:52 PM
Last Post: X-Kal
  DLL errors on Windows XP sibberio 5 6,404 11-26-2012 09:35 AM
Last Post: sibberio
  Windows b7 - Small Network Tab Problem Alakon9x 2 4,080 11-25-2012 08:43 AM
Last Post: smitmartijn
  Windows b6 - program freeze issue (Windows XP and XP64) FamilienVater 6 7,070 11-24-2012 03:07 PM
Last Post: smitmartijn
  Windows b6 disk consumption Syfaro 6 6,126 11-08-2012 11:08 PM
Last Post: Syfaro
  Windows b6 - Crash On hibernate Alakon9x 3 5,070 11-06-2012 07:05 PM
Last Post: Alakon9x
  Windows b6 - Heatmap Issue Alakon9x 7 6,966 11-06-2012 06:58 PM
Last Post: Alakon9x
  Windows b6 - Network FamilienVater 4 5,017 10-30-2012 05:56 PM
Last Post: smitmartijn
  Bugs and feature for 2.0b5 - Mac OS X client bman4789 3 4,596 10-11-2012 06:17 PM
Last Post: smitmartijn

Forum Jump:


User(s) browsing this thread: 1 Guest(s)