WhatPulse Forums » Support » Client software v » Crash on high memory systems? Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Crash on high memory systems?
03-08-2012, 05:26 PM (This post was last modified: 03-08-2012 05:35 PM by mrpijey.)
Post: #1
Crash on high memory systems?
Seems WhatPulse doesn't like a lot of RAM, after upgrading from 6GB to 18GB the app refuses to start with an "WhatPulse has stopped working" error.

I've uninstalled and reinstalled it
I've cleaned out all associated files and tried to run it clean
I've tried various compatibility modes, with and without admin privs

It worked flawlessly before the upgrade without any special settings, now it won't start without an immediate crash. No debug files are created. Icon pops up in taskbar but disappears after crash. Tried memory testing tools to see if RAM is faulty, no errors found, and no symptoms with any other software (so far). All my other systems run Win7 x64 also but not with more than 6GB RAM except for this one.

OS: Windows 7 Pro x64
RAM: 18GB (worked fine with 6GB)
Sys: Intel i7-950 with DEP support
DEP disabling won't work with this app.

--
Crash info:

Problem signature:
Problem Event Name: APPCRASH
Application Name: WhatPulse.exe
Application Version: 1.7.0.0
Application Timestamp: 4ec26572
Fault Module Name: WhatPulse.exe
Fault Module Version: 1.7.0.0
Fault Module Timestamp: 4ec26572
Exception Code: 40000015
Exception Offset: 00140f77
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1053
Additional Information 1: 659f
Additional Information 2: 659f4016eb5907713cc37b7b4cbe043e
Additional Information 3: 339c
Additional Information 4: 339c378087315c5567dab8e25e512e61
Find all posts by this user
Quote this message in a reply
03-12-2012, 10:52 PM
Post: #2
Crash on high memory systems?
What happens if you go back to 6GB?

GitHub
Wishlist - Have I helped you in some way? Thank me by buying something on my wishlist! (There's even cheap things I need so you don't have to break your bank thanking me :3)
[Image: 227041.jpg]
Find all posts by this user
Quote this message in a reply
03-14-2012, 03:09 PM
Post: #3
Crash on high memory systems?
It's not just you. I haven't upgraded my ram at all (I have 6 GB now) and I'm getting this problem too. With the exact same problem signature:


Problem Event Name: APPCRASH
Application Name: WhatPulse.exe
Application Version: 1.7.0.0
Application Timestamp: 4ec26572
Fault Module Name: WhatPulse.exe
Fault Module Version: 1.7.0.0
Fault Module Timestamp: 4ec26572
Exception Code: 40000015
Exception Offset: 00140f77
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: 659f
Additional Information 2: 659f4016eb5907713cc37b7b4cbe043e
Additional Information 3: 339c
Additional Information 4: 339c378087315c5567dab8e25e512e61


I think there might be something else going on here. I'm also running Windows 7 x64

Until this is fixed I'm running Whatpulse 1.5b1
Find all posts by this user
Quote this message in a reply
03-15-2012, 08:33 AM
Post: #4
Crash on high memory systems?
ToastyMallows Wrote:Application Version: 1.7.0.0
Fault Module Version: 1.7.0.0

What about 1.7.1?

GitHub
Wishlist - Have I helped you in some way? Thank me by buying something on my wishlist! (There's even cheap things I need so you don't have to break your bank thanking me :3)
[Image: 227041.jpg]
Find all posts by this user
Quote this message in a reply
03-15-2012, 07:16 PM
Post: #5
Crash on high memory systems?
I am running 1.7.1. I doublechecked and it does indeed say 1.7.0.0 when you check the exe. File version: 1.7.0.0, Product version: 1.7.

And it works fine on 6GB RAM. I verified the same issue on my workstation where I added more RAM to it (total of 12GB) and it crashes there too. The workstation was also reinstalled from scratch.

I am going to test an older version of WhatPulse... but this needs to be fixed as more and more people use more RAM and x64.

Question is, where do I find an older version?
Find all posts by this user
Quote this message in a reply
03-21-2012, 04:44 PM
Post: #6
Crash on high memory systems?
Shawn Wrote:What about 1.7.1?

1.7.1 has a version number of 1.7.0, I think someone forgot to change that (like mrpijey mentioned).

An old version can be found here: http://unidownload.com/downloading-WhatP...497_1.html

It's version 1.5b1, works fine.
Find all posts by this user
Quote this message in a reply
05-03-2012, 11:45 PM
Post: #7
Crash on high memory systems?
I'm not sure the problem is in the ammount of RAM... I have 24GB over here with a 64bit Windows 7 and it works fine.
I'm using the newest version.

4GB (only 3GB used since it's a 32bit Windows) on my other computer and no problem either.
Find all posts by this user
Quote this message in a reply
06-05-2012, 10:55 PM
Post: #8
Crash on high memory systems?
Well is there any way to diagnose the issue?
Find all posts by this user
Quote this message in a reply
07-02-2012, 09:41 PM
Post: #9
Crash on high memory systems?
Not sure if the crash issue for me was related to Memory or what not but I uninstalled and then I went to C drive. -> Users -> Username -> appdata -> roaming.
Then deleted / renamed whatpulse folder and then reinstalled.
It is working now.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  No Download counting on high speeds iOChris 13 3,800 01-22-2021 07:17 PM
Last Post: TehMoff
Bug WIndows High CPU Usage necenzurat 15 10,393 01-17-2021 12:08 PM
Last Post: smitmartijn
  High CPU Usage - On wake-up ClayC 9 4,231 06-19-2020 10:22 PM
Last Post: FamilienVater
  Whatpulse crash [GoT]Jewest 3 2,519 10-28-2019 01:18 PM
Last Post: [GoT]Jewest
  Heatmap On = High CPU Usage Dark_wizzie 3 2,957 03-19-2017 07:28 AM
Last Post: Dark_wizzie
  Client crash on launch (v2.7.1) Sovex66 13 7,840 02-27-2017 09:31 AM
Last Post: Dosphal
  [CLOSED] Client Crash macOS Sierra SeeEmAge 3 3,333 09-15-2016 03:42 AM
Last Post: smitmartijn
  [SOLVED] Win7x64 - WhatPulse 2.7 - Instant Crash Zoomer 3 2,907 03-05-2016 09:07 PM
Last Post: smitmartijn
  Memory leak WhatPulse 2.6.3 on Ubuntu 15.04 Wouter0100 2 3,197 01-07-2016 11:52 AM
Last Post: Wouter0100
  Still no High DPI support ajfoegen 1 2,183 09-29-2015 08:05 AM
Last Post: Megachip

Forum Jump:


User(s) browsing this thread: 1 Guest(s)