WhatPulse Forums » Support » Client software v » [SOLVED] Can't run the Linux version [Driver not loaded Driver not loaded] Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Can't run the Linux version [Driver not loaded Driver not loaded]
04-26-2019, 11:30 PM (This post was last modified: 06-20-2019 11:54 AM by radioz.)
Post: #1
[SOLVED] Can't run the Linux version [Driver not loaded Driver not loaded]
Hi, I am running a fresh install of Linux Mint 19.1 that I installed yesterday. I have not been able to get the Linux version of Whatpulse to run despite following the install instructions and installing boatloads of libqt libsql packages. I've tried installing multiple times, I've tried all the 64 bit versions and all the 32 bit versions, I've tried deleting all the files it generates, I've tried running in sudo, I get the same error. I've tried reinstalling all the dependencies. I'm not a Linux person so forgive me if I'm making some blatant error, I just can't figure out how to even get the application started. The Mac version just works, it's just this Linux version that has the error. This is a completely new install, I haven't screwed with it or anything, just followed all the instructions and it didn't work. The error I get is:

Code:
radioz@THINKPAD:~/Downloads/wp2$ ./whatpulse
qt5ct: using qt5ct plugin
27-04-2019 00:04:45.195  INFO "Starting WhatPulse 2.8.4-1633..."
propsReply "Rejected send message, 1 matched rules; type=\"method_call\", sender=\":1.300\" (uid=1000 pid=20129 comm=\"./whatpulse \" label=\"unconfined\") interface=\"org.freedesktop.DBus.Properties\" member=\"GetAll\" error name=\"(unset)\" requested_reply=\"0\" destination=\"org.freedesktop.NetworkManager\" (uid=0 pid=883 comm=\"/usr/sbin/NetworkManager --no-daemon \" label=\"unconfined\")"
nmReply "Rejected send message, 1 matched rules; type=\"method_call\", sender=\":1.300\" (uid=1000 pid=20129 comm=\"./whatpulse \" label=\"unconfined\") interface=\"org.freedesktop.NetworkManager\" member=\"GetDevices\" error name=\"(unset)\" requested_reply=\"0\" destination=\"org.freedesktop.NetworkManager\" (uid=0 pid=883 comm=\"/usr/sbin/NetworkManager --no-daemon \" label=\"unconfined\")"
"Object path cannot be empty"
QObject::startTimer: Timers cannot have negative intervals
qt5ct: D-Bus system tray: no
27-04-2019 00:04:45.206 DEBUG "/home/radioz/.local/share/WhatPulse"  does not exist, starting fresh!
27-04-2019 00:04:45.206 DEBUG Database file:  "/home/radioz/.local/share/WhatPulse/whatpulse.db"
QSqlDatabase: QSQLITE driver not loaded
QSqlDatabase: available drivers:
27-04-2019 00:04:45.206 FATAL Unable to open database:  "Driver not loaded Driver not loaded"

It's always the same error, I don't know how to fix it. This has been posted before, but the thread is from 2005 and the links are broken.
http://whatpulse.org/forums/showthread.php?tid=1890

Here is my ldd
Code:
ldd whatpulse
    linux-vdso.so.1 (0x00007ffeda1d0000)
    libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f4cef207000)
    libsqlite3.so.0 => /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007f4ceeefe000)
    libQt5Widgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007f4cee6b7000)
    libQt5Gui.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5 (0x00007f4cedf4e000)
    libQt5Sql.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Sql.so.5 (0x00007f4cedd05000)
    libQt5Network.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Network.so.5 (0x00007f4ced979000)
    libQt5Xml.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Xml.so.5 (0x00007f4ced73d000)
    libQt5Core.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 (0x00007f4cecff2000)
    libGL.so.1 => /usr/lib/x86_64-linux-gnu/libGL.so.1 (0x00007f4cecd66000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f4cecb47000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f4cec7be000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f4cec420000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f4cec208000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f4cebe17000)
    libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f4cebbef000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f4ceb9eb000)
    libpng16.so.16 => /usr/lib/x86_64-linux-gnu/libpng16.so.16 (0x00007f4ceb7b9000)
    libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007f4ceb51b000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f4ceb2fe000)
    libicui18n.so.60 => /usr/lib/x86_64-linux-gnu/libicui18n.so.60 (0x00007f4ceae5d000)
    libicuuc.so.60 => /usr/lib/x86_64-linux-gnu/libicuuc.so.60 (0x00007f4ceaaa6000)
    libdouble-conversion.so.1 => /usr/lib/x86_64-linux-gnu/libdouble-conversion.so.1 (0x00007f4cea895000)
    libglib-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f4cea57f000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f4cefb61000)
    libGLX.so.0 => /usr/lib/x86_64-linux-gnu/libGLX.so.0 (0x00007f4cea34e000)
    libGLdispatch.so.0 => /usr/lib/x86_64-linux-gnu/libGLdispatch.so.0 (0x00007f4cea098000)
    libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f4ce9e94000)
    libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f4ce9c8e000)
    libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f4ce99da000)
    libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007f4ce97ad000)
    libicudata.so.60 => /usr/lib/x86_64-linux-gnu/libicudata.so.60 (0x00007f4ce7c04000)
    libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f4ce7992000)
    libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007f4ce777d000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f4ce7575000)

I have no idea how to fix this, does anyone know how this error happens or how to rectify it?
Find all posts by this user
Quote this message in a reply
04-28-2019, 12:39 PM
Post: #2
RE: Can't run the Linux version [Driver not loaded Driver not loaded]
Ha, that was my thread - and by that age it had to be the old, old linux client which is quite different from the current version. And sorry for the broken links, I relaunched my website in the meantime and threw away all those miscellaneous images... :/

Maybe I can help you, I haven't used LinuxMint in a while, but on a freshly installed Xubuntu 18.04 I just needed to install the following packages (and their dependencies) and WhatPulse would run (after using the two setup scripts that come with it pcap and input permissions)

apt install libssl1.0-dev libqt5widgets5 libqt5sql5-sqlite
Find all posts by this user
Quote this message in a reply
06-20-2019, 11:54 AM
Post: #3
RE: Can't run the Linux version [Driver not loaded Driver not loaded]
(04-28-2019 12:39 PM)FamilienVater Wrote:  Ha, that was my thread - and by that age it had to be the old, old linux client which is quite different from the current version. And sorry for the broken links, I relaunched my website in the meantime and threw away all those miscellaneous images... :/

Maybe I can help you, I haven't used LinuxMint in a while, but on a freshly installed Xubuntu 18.04 I just needed to install the following packages (and their dependencies) and WhatPulse would run (after using the two setup scripts that come with it pcap and input permissions)

apt install libssl1.0-dev libqt5widgets5 libqt5sql5-sqlite

Thanks so much, this fixed my install Smile
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  WhatPulse not opening on Manjaro Linux (Arch distro) tboxley 4 502 05-26-2019 11:30 AM
Last Post: FamilienVater
  [SOLVED] Error uploading keyboard/mouse heatmap Wopian 2 575 03-17-2017 12:26 PM
Last Post: Wopian
  [SOLVED] [postmortem] Pulse error: "The specified configuration cannot be used." dgw 4 1,246 03-03-2017 09:54 PM
Last Post: dgw
  [SOLVED] Client crashes on startup v. 2.7 Win10x64 Lttngblt 11 2,310 10-08-2016 06:43 PM
Last Post: smitmartijn
  [SOLVED] OS X no longer starts, crashes on startup stuthemonkey 3 825 10-01-2016 06:34 PM
Last Post: smitmartijn
  [SOLVED] Best solution for delaying whatpulse until after panel loads fennectech 1 844 09-15-2016 03:36 AM
Last Post: smitmartijn
Sad [SOLVED] The only thing that kept me from using whatpulse itzhalo 3 1,207 09-07-2016 09:53 AM
Last Post: smitmartijn
  [CLOSED] Does WhatPulse and the WinPCap driver slow down internet? dandu3 2 1,090 08-06-2016 12:45 AM
Last Post: dandu3
  [SOLVED] Facts window occassional displays strange formats/information d3ullist 1 860 07-08-2016 09:38 PM
Last Post: smitmartijn
  [CLOSED] Does whatpulse linux support Qt5 satshow 1 1,060 06-26-2016 06:19 PM
Last Post: smitmartijn

Forum Jump:


User(s) browsing this thread: