WhatPulse Forums » Support » Client software v » Application freezing, and using 25%cpu Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Application freezing, and using 25%cpu
06-07-2016, 10:05 AM (This post was last modified: 06-07-2016 10:06 AM by d3ullist.)
Post: #9
RE: Application freezing, and using 25%cpu
(08-12-2015 10:00 AM)Robby250 Wrote:  Yeah, it's an issue with WinPcap, my whatpulse started freezing again after my post, but much more rarely. I noticed it happened whenever my router screwed up and my internet stopped working for a while.
The last line before the freeze in the app.log is this:
Code:
16-07-2015 11:46:06.691 DEBUG void __thiscall PcapNetworkTrafficMonitor::refreshInterfaces(void) Unable to find network interfaces via normal APIs, trying pcap alternative..

Disabling network statistics fixes the issue, but I'd rather keep them.

Since installing Nmap I no longer have this issue on my laptop. It seems that Nmap came with a more recent version of winPcap.

Having virtual internet adapters, such as VMware, Hamachi seems to have been the culprit for my desktop. Removing them prevented freezing. I also confirmed that when tunnelling your connection over a virtual adapter the freeze does not seem to happen either.

Hope my solution can also help you

ps the error still persists in WP 2.7
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RE: Application freezing, and using 25%cpu - d3ullist - 06-07-2016 10:05 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Not tracking a certain application d1tzl 1 149 08-26-2019 04:35 PM
Last Post: DrEx
  Not uploading Application Data mewturn 0 639 07-25-2016 06:45 AM
Last Post: mewturn
  Application uploading not yet supported in Linux client? Wieschie 16 13,933 02-10-2016 06:17 PM
Last Post: smitmartijn
  Ignored programs still show up in Application Heatmaps Drake356 1 1,368 06-20-2015 06:32 PM
Last Post: smitmartijn
  [CLOSED] Export Application Uptime from All Computers devmonster 5 2,244 05-08-2015 05:28 PM
Last Post: smitmartijn
  Per-Application Pulsing Issue. micycle 14 5,543 04-12-2015 12:43 PM
Last Post: micycle
  Overall lifetime application summary not adding up Esuk 2 1,308 04-09-2015 06:51 AM
Last Post: Esuk
  Error in Application Data Uploaded mewturn 0 1,052 03-20-2015 01:50 AM
Last Post: mewturn
  [SOLVED] Application isn't logging the "-" key since the update. cartman2000 2 2,161 10-21-2014 10:20 PM
Last Post: cartman2000
  Application all time keys wrong laishiou 1 1,874 09-26-2014 04:22 PM
Last Post: smitmartijn

Forum Jump:


User(s) browsing this thread: 1 Guest(s)