WhatPulse Forums » Support » Client software v » Cant install the linux client Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cant install the linux client
12-24-2012, 12:01 PM (This post was last modified: 12-24-2012 12:01 PM by FamilienVater.)
Post: #15
RE: Cant install the linux client
I've just gotten the networking to work.

@smijtmartin - maybe you could setup a knowledgebase article for every distro + version - as far as there is valid information. -- and since I can't post in my old thread in the beta: the network problem (with wired ethernet) persists in linuxmint14 even with the non-beta. However, I'm switching to ubuntu (with cinnamon desktop) anyhow...

So here's what I did:

* Freshly installed ubuntu 12.10 64bit (only my /home partition remained)
* installed the following packages (some of them might already be installed!):
Code:
apt-get install libqt4-core
apt-get install libqtwebkit4
apt-get install libssl-dev
apt-get install libpcap0.8
apt-get install libpcap0.8-dev  # the dev one was actually the one that made the "libpcap not available" - message go away....
* ran this command:
Code:
sudo setcap cap_net_raw,cap_net_admin=eip ./whatpulse
* downloaded and executed the permission-script from http://jmrk.whatpulse.org/ to get key and mouse/touchpad capturing running
* did the xorg-script for my laptop's touchpad on the same page.

and here I am, glad to have a working whatpulse setup on my work notebook....
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Cant install the linux client - BladeX - 12-23-2012, 08:45 PM
RE: Cant install the linux client - BladeX - 12-23-2012, 10:15 PM
RE: Cant install the linux client - BladeX - 12-23-2012, 10:28 PM
RE: Cant install the linux client - BladeX - 12-23-2012, 11:15 PM
RE: Cant install the linux client - FamilienVater - 12-24-2012 12:01 PM
RE: Cant install the linux client - nimd4 - 12-24-2012, 03:31 PM
RE: Cant install the linux client - BladeX - 12-25-2012, 05:26 PM
RE: Cant install the linux client - BladeX - 12-26-2012, 06:11 PM
RE: Cant install the linux client - nimd4 - 12-26-2012, 07:40 PM
RE: Cant install the linux client - BladeX - 12-26-2012, 09:53 AM
RE: Cant install the linux client - BladeX - 12-26-2012, 07:57 PM
RE: Cant install the linux client - nimd4 - 12-26-2012, 08:10 PM
RE: Cant install the linux client - nimd4 - 12-29-2012, 05:38 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Support for Linux dropped ? Adrriii 2 129 Yesterday 12:10 PM
Last Post: fatsa
  Cannot start Whatpulse successfully on Manjaro 18.1.4 (Arch Linux) anijatsu 2 229 01-12-2020 04:06 PM
Last Post: Adrriii
  Unable to install latest version: Certificate expired Gadgetdude 1 106 01-09-2020 10:32 AM
Last Post: smitmartijn
  Having trouble running whatpulse on Neon Linux BlackWidow 1 278 12-03-2019 12:02 AM
Last Post: Adrriii
  WhatPulse 64bit install on Lubuntu 19.04 SiKTheGreatOne 0 618 06-30-2019 02:49 AM
Last Post: SiKTheGreatOne
  [SOLVED] Can't run the Linux version [Driver not loaded Driver not loaded] radioz 2 1,329 06-20-2019 11:54 AM
Last Post: radioz
  WhatPulse not opening on Manjaro Linux (Arch distro) tboxley 4 1,111 05-26-2019 11:30 AM
Last Post: FamilienVater
  Whatpulse won't start, Unable to install crashRpt! Bai.Bing 0 441 05-24-2019 01:02 PM
Last Post: Bai.Bing
  Mac client causing latency every ~10 seconds bryandh 10 3,159 03-09-2017 04:50 PM
Last Post: DJLunacy
Information [CLOSED] Mouse distance counter in Windows client. TigraPolosatiy 1 937 02-27-2017 05:30 PM
Last Post: smitmartijn

Forum Jump:


User(s) browsing this thread: 1 Guest(s)