WhatPulse Forums
Error regarding missing DLL - Printable Version

+- WhatPulse Forums (http://whatpulse.org/forums)
+-- Forum: Support (/forumdisplay.php?fid=38)
+--- Forum: Client software (/forumdisplay.php?fid=58)
+--- Thread: Error regarding missing DLL (/showthread.php?tid=7917)



Error regarding missing DLL - TheIceMage - 01-17-2021 03:44 PM

I just updated to v3.1 and now whatpulse won't work Sad I attached a screencap of the error. I tried reinstalling but it didn't help. Please help soon, I don't like not having my stats tracked... Sad


RE: Error regarding missing DLL - TehMoff - 01-18-2021 10:02 AM

Currently having the same issue, done a /sfc scannow in cmd without success, tried reinstalling WhatPulse which didn't help.
I think it's something related to all those "Microsoft Visual C++" redistributables, so I'm about to uninstall/reinstall all of them to see what happens.

I also searched my other computer for this dll, and it doesn't even have it - but WhatPulse 3.1 works fine there, weird!

Alright, uninstalled all the Redist stuff, rebooted, reinstalled WhatPulse which in turn installed Microsoft Visual C++ Redistributable (x86) 14.0.23026 and STILL had the same very same error :|

If I uninstall the one redist that WhatPulse installed for me, and try to run WhatPulse, it says MSVCP140.dll (note: not MSCVCP140_1.dll, if its of importance) is missing. The next prompt says the code execution cannot proceed because VCRUNTIME140.dll was not found, the third prompt is the same as the second. The forth prompt goes back to missing MSVCP140.dll, then there are no more.

Finally, the MSVCP140.dll seems to be related to the 2015 version of the redists ( https://www.groovypost.com/howto/fix-visual-c-plus-plus-redistributable-windows-10/ )
I downloaded the install for both x86 and x64 from Microsoft, same issue.

Currently out of ideas, went back to 3.0.

The computer is running Windows 10 Pro x64 build 19042.746 (20H2)


RE: Error regarding missing DLL - z2sam - 01-18-2021 05:22 PM

I have the same problem after installing v 3.1


RE: Error regarding missing DLL - StrozeR - 01-19-2021 12:50 PM

Do you guys have maybe mirror to version 3.0?


RE: Error regarding missing DLL - Strike91 - 01-19-2021 01:27 PM

Same problem here


RE: Error regarding missing DLL - TheIceMage - 01-19-2021 04:27 PM

(01-19-2021 12:50 PM)StrozeR Wrote:  Do you guys have maybe mirror to version 3.0?

IDK about v3.0 but here is the last beta release, which I think is much the same as v3.0
https://whatpulse.org/forums/showthread.php?tid=7894


RE: Error regarding missing DLL - z2sam - 01-19-2021 07:48 PM

(01-19-2021 04:27 PM)TheIceMage Wrote:  
(01-19-2021 12:50 PM)StrozeR Wrote:  Do you guys have maybe mirror to version 3.0?

IDK about v3.0 but here is the last beta release, which I think is much the same as v3.0
https://whatpulse.org/forums/showthread.php?tid=7894

thanks for the mirror! Will have to use this until it's fixed


RE: Error regarding missing DLL - smitmartijn - 01-20-2021 11:22 AM

Hi, please re-download the client and try again. There was an issue with a dependency (Visual Studio Redistributable) that might've caused above DDL error.