WhatPulse Forums
WhatPulse 2.6b4 - Printable Version

+- WhatPulse Forums (http://whatpulse.org/forums)
+-- Forum: Community (/forumdisplay.php?fid=34)
+--- Forum: Beta client (/forumdisplay.php?fid=74)
+---- Forum: Archive (/forumdisplay.php?fid=80)
+---- Thread: WhatPulse 2.6b4 (/showthread.php?tid=6367)

Pages: 1 2


WhatPulse 2.6b4 - smitmartijn - 04-12-2015 11:01 AM

Hi,

Alright, so beta 3 didn't go as planned for Windows users, as you might have noticed. ;-) I was hoping to lessen the time needed to deploy a new beta by only pushing it through the updater, which I will try again for the new one.

But for now, here's beta 4! The Windows updater should be fixed, along with several other issues. Plus new input history views: last 12 and 24 hours, a per hour view!

Windows users: use the installer below to update, OS X users should be able to just use the updater.

Please go ahead and see how this works for you, I'm looking forward to get feedback, thanks!

Downloads:
- Windows: http://amcdn.files.whatpulse.org/beta/whatpulse-win-2.6b4.exe
- OS X: http://amcdn.files.whatpulse.org/beta/whatpulse-mac-2.6b4.dmg

Changes:



RE: WhatPulse 2.6b4 - micycle - 04-12-2015 12:50 PM

[Image: uRmU7s8.png]

8388608/1024^2 = 8


RE: WhatPulse 2.6b4 - Robby250 - 04-12-2015 12:58 PM

Installed the beta, after a while my Today keycount stopped increasing, even though the Unpulsed one was still working and pulsing properly. I closed the application, and then it wouldn't restart. I backed up the database and the .wpw, and then installed 2.5. When I run 2.5, it seems to blank out my database, regardless of being the current or the backup, and starts with every single option unchecked (http://puu.sh/haYEN/4f8035bfe8.png ).
Basically 2.6b4 won't run at all anymore unless I start over (delete both the .db and .wpw), and 2.5 blanks out my .db completely without giving me any message that it's corrupted or anything.

Here's the app.log (won't let me attach it for some reason): http://puu.sh/haYOR/6b2863b9dd.log

I managed to pulse the remaining keys I had unpulsed with the 2.5 version somehow, but I'd like to know if there's any way I could get my database to work without resetting it, and prevent this from happening again.

EDIT: It seems that the 2.6b4 client doesn't want to start again after closing it with any kind of database or .wpw file, it wants to start over every time, and on older versions my .db gets nuked because it's version 5 instead of 4 and the client doesn't like that.


RE: WhatPulse 2.6b4 - smitmartijn - 04-16-2015 04:27 PM

(04-12-2015 12:50 PM)micycle Wrote:  [Image: uRmU7s8.png]

8388608/1024^2 = 8

That is awesome, but a little more info; is it permanently like that, does it only do that at start, does the max change?


RE: WhatPulse 2.6b4 - smitmartijn - 04-16-2015 04:40 PM

(04-12-2015 12:58 PM)Robby250 Wrote:  Installed the beta, after a while my Today keycount stopped increasing, even though the Unpulsed one was still working and pulsing properly. .....

Downgrading between clients is not supported. I've just changed the detecting of that by notifying you and exiting. The previous way was to reset the database, which in your case failed (causing the log you saw).

About the not being able to start it: make sure there's not a process left over of that messing around and downgrading, it might still have an active lock which would be why you are not able to start it.

When you said that it stopped counting "today" keys, but was still counting unpulsed keys, which field on which tab did you mean exactly?


RE: WhatPulse 2.6b4 - Drake356 - 04-16-2015 11:04 PM

(04-16-2015 04:40 PM)smitmartijn Wrote:  When you said that it stopped counting "today" keys, but was still counting unpulsed keys, which field on which tab did you mean exactly?

The geek window for me as of me typing this displays 4,091 Keys for today. The client itself has the proper count as shown: http://puu.sh/hguCr.png
While the geek window displays: http://puu.sh/hguEM.png

Restarted the client only temporarily solves the problem as it begins happening again after about an hour or so.


RE: WhatPulse 2.6b4 - Robby250 - 04-17-2015 12:23 AM

(04-16-2015 04:40 PM)smitmartijn Wrote:  When you said that it stopped counting "today" keys, but was still counting unpulsed keys, which field on which tab did you mean exactly?
The Today field in the 'Input' tab, and for unpulsed either the 'Input' or 'Overview', it was all the same. The numbers were the same in geek window, input, and overview.


RE: WhatPulse 2.6b4 - jerone - 04-20-2015 08:20 AM

How can I find which beta version I'm running? The titlebar only shows "WhatPulse 2.5-1186 (beta)", but not which version (e.g. beta 3, beta 4).


RE: WhatPulse 2.6b4 - 00Eraser00 - 04-20-2015 08:58 AM

The QWERTZ keyboard layout still has some missing keys. See screenshot.


RE: WhatPulse 2.6b4 - smitmartijn - 04-20-2015 10:53 AM

(04-20-2015 08:20 AM)jerone Wrote:  How can I find which beta version I'm running? The titlebar only shows "WhatPulse 2.5-1186 (beta)", but not which version (e.g. beta 3, beta 4).

Here: http://whatpulse.org/forums/showthread.php?tid=6197