WhatPulse Forums
WhatPulse 2.6b3 - Printable Version

+- WhatPulse Forums (http://whatpulse.org/forums)
+-- Forum: Community (/forumdisplay.php?fid=34)
+--- Forum: Beta client (/forumdisplay.php?fid=74)
+---- Forum: Archive (/forumdisplay.php?fid=80)
+---- Thread: WhatPulse 2.6b3 (/showthread.php?tid=6322)



WhatPulse 2.6b3 - Megachip - 04-02-2015 07:37 AM

On OSX 1172 tolt me, that it was 1171 and requested an update.
On the main window 1172 is shown but looks like the update rotine thinks it is 1171.

- Quertz still not working proper on OS X
- can't close the update window if I closed the wp main window before


RE: WhatPulse 2.6b3 - TehMoff - 04-02-2015 06:04 PM

(Sorry for hijacking the thread)

Speaking of 2.6b3, I see no official release thread with download link? I couldn't download it when getting the update prompt (does it have to pop up like that btw? Could be disastrous if you're doing something important, a little balloon popup in systray would be great!), got some error instead which I can't remember and can't seem to reproduce - now nothing happens at all when I press the "install update" button Confused

Using 64-bit W7.


RE: WhatPulse 2.6b3 - PalkiaX50 - 04-03-2015 03:40 PM

I think I got the same kind of issue as TehMoff :/
The error which doesn't seem to have reappeared was something like "Could not find [... something something] updater.exe --beta" I believe.
The --beta at the end, as if it's saying it's trying to find a file ending with that, struck me as being rather odd alright.


RE: WhatPulse 2.6b3 - TehMoff - 04-03-2015 03:56 PM

Installed 2.6b2 (from 2.5) on my laptop with Win 32-bit now and then searched for new beta versions, got the error prompt again - http://i.imgur.com/YC2Fvbd.jpg
Pressed ok and now nothing happens again when trying to install the update.


RE: WhatPulse 2.6b3 - PalkiaX50 - 04-03-2015 04:43 PM

Yea that looks about right...can't quite be sure without seeing the code firsthand of course but I'm thinking it's something like this "--beta" argument is supposed to be passed to something to specify that it's a beta update or so but somehow it's accidentally being passed as part of the filename.


RE: WhatPulse 2.6b3 - jerone - 04-03-2015 08:26 PM

Same error here about beta updater.exe.
However running the updater.exe in command line with beta argument solved my problem.

New version did change all checkboxes however (see attachment).

Windows 7 64-bits.


RE: WhatPulse 2.6b3 - smitmartijn - 04-04-2015 10:17 AM

For some reason I'm all over the map when it comes to the Windows updater. It was being passed as a parameter (the --beta) during testing, but something happened which made it part of the command, so Windows is actually looking for "/updater.exe --beta" - which does not exist.

As jerone said, running it from cmd would work.


RE: WhatPulse 2.6b3 - smitmartijn - 04-04-2015 10:33 AM

(04-02-2015 07:37 AM)Megachip Wrote:  - Quertz still not working proper on OS X

What is not working properly? Need specifics to fix.


RE: WhatPulse 2.6b3 - Megachip - 04-07-2015 06:49 AM

(04-04-2015 10:33 AM)smitmartijn Wrote:  
(04-02-2015 07:37 AM)Megachip Wrote:  - Quertz still not working proper on OS X

What is not working properly? Need specifics to fix.
Same as before (b2), keys which differ from qwerty aren't detected (or detected wrong, like z and y)


RE: WhatPulse 2.6b3 - smitmartijn - 04-07-2015 07:15 PM

(04-07-2015 06:49 AM)Megachip Wrote:  Same as before (b2), keys which differ from qwerty aren't detected (or detected wrong, like z and y)

Hrm, think I just should go out and buy a real one. Apparently a virtual keyboard does not work for testing this. To be continued!