WhatPulse Forums
[SOLVED] [Mac 10.10] Incorrect key count - Printable Version

+- WhatPulse Forums (http://whatpulse.org/forums)
+-- Forum: Support (/forumdisplay.php?fid=38)
+--- Forum: Client software (/forumdisplay.php?fid=58)
+--- Thread: [SOLVED] [Mac 10.10] Incorrect key count (/showthread.php?tid=6257)



[SOLVED] [Mac 10.10] Incorrect key count - cassolotl - 03-19-2015 08:41 AM

Hello. Smile

I installed WhatPulse on my Mac (10.10.2) yesterday, I've got the permissions set correctly, etc.

Just now I clicked Pulse and checked my stats. Since last night it says I've typed 501 keys - but I pasted a blog post I wrote (before I pulsed) into LibreOffice and it said that post had over 600 characters. I've typed a lot more than just that blog post since last night.

So, this isn't a not-counting issue, this is an undercounting issue. I've searched the forums for mac key counting and nothing appeared, so here I am. Help! Confused

Edit: Adding answers to these questions: http://whatpulse.org/forums/showthread.php?tid=810

1) WhatPulse 2.5
2) Mac OS X 10.10.2 (can't find whether x64 or x86)
3) N/A (not on Windows)
4) N/A (not on Windows)
5) No error messages.
6) Chrome, Echofon. No anti-virus.
7) N/A


RE: [Mac 10.10] Incorrect key count - smitmartijn - 03-22-2015 09:26 PM

Hi,

When you look at the keyboard heatmap, which keys do you see lit up? If they are only space, shift, ctrl, option, your permissions are not set correctly.

If normal keys (a-z) keys are displayed, any chance you copy/pasted a lot? :-)


RE: [Mac 10.10] Incorrect key count - cassolotl - 03-23-2015 08:43 AM

I've uninstalled it because no one replied! But, there was no heatmap at all. It says right now "No images found." http://whatpulse.org/cassolotl#keyboard-heatmaps

Also no, I didn't copy-paste my blog posts. Tongue

Is there a How To Permissions somewhere, so I can double-check that I got it right?


RE: [Mac 10.10] Incorrect key count - smitmartijn - 03-24-2015 04:38 PM

The client checks for the permissions every time it starts and tells you about it. The latest version even opens up the system preferences pane for you. ;-)

Also, the heat-maps on the website are only published when you press the "Share" button, which is why there are no images available on your profile.


RE: [Mac 10.10] Incorrect key count - cassolotl - 03-27-2015 09:01 AM

>The client checks for the permissions every time it starts and tells you about it. The latest version even opens up the system preferences pane for you. ;-)

Not on mine, it doesn't.

>Also, the heat-maps on the website are only published when you press the "Share" button, which is why there are no images available on your profile.

I can't see a share button anywhere?


RE: [Mac 10.10] Incorrect key count - smitmartijn - 03-28-2015 09:43 AM

(03-27-2015 09:01 AM)cassolotl Wrote:  Not on mine, it doesn't.

It does. If it doesn't tell you about it, the permissions are fine and counting it functional.

(03-27-2015 09:01 AM)cassolotl Wrote:  I can't see a share button anywhere?

https://www.evernote.com/shard/s258/sh/dd014d96-0b6e-4734-8de1-57a337c05a3f/16a227f712fee43f65b7f5192ea1fabd/deep/0/WhatPulse-2.5-1166-(beta).png


RE: [Mac 10.10] Incorrect key count - cassolotl - 03-28-2015 12:23 PM

(03-28-2015 09:43 AM)smitmartijn Wrote:  
(03-27-2015 09:01 AM)cassolotl Wrote:  Not on mine, it doesn't.

It does. If it doesn't tell you about it, the permissions are fine and counting it functional.

Ohh that's good then. Smile I reinstalled WhatPulse and it seems to now be counting everything properly, so I've no idea what was wrong last time but it's fixed after a reinstall...!

(03-28-2015 09:43 AM)smitmartijn Wrote:  
(03-27-2015 09:01 AM)cassolotl Wrote:  I can't see a share button anywhere?

https://www.evernote.com/shard/s258/sh/dd014d96-0b6e-4734-8de1-57a337c05a3f/16a227f712fee43f65b7f5192ea1fabd/deep/0/WhatPulse-2.5-1166-(beta).png

Ahh right, so that's in the settings of the app. It's greyed out on mine; I thought I was on a Premium trial so I'm not sure why that is! Oh well, at least I can see it in the app's preferences pane.

smitmartijn, is that image with your stats on that's in your signature a Premium feature too? I can't seem to get it working...!


RE: [Mac 10.10] Incorrect key count - smitmartijn - 04-01-2015 06:14 PM

(03-28-2015 12:23 PM)cassolotl Wrote:  smitmartijn, is that image with your stats on that's in your signature a Premium feature too? I can't seem to get it working...!

Nope, there are some features on the dynamic images that are premium, but they can be used by everyone. You just need to set it up. Here's how: http://whatpulse.org/kb/content/3/11/en/forum-images.html

Just to test (to see whether it wasn't broken), I've selected a background and added a text element to yours. Don't wonder why it is configured like it is now, just change it to your own style. ;-)