WhatPulse Forums
[FIXED] [Windows] WhatPulse not starting - Printable Version

+- WhatPulse Forums (http://whatpulse.org/forums)
+-- Forum: Support (/forumdisplay.php?fid=38)
+--- Forum: Client software (/forumdisplay.php?fid=58)
+--- Thread: [FIXED] [Windows] WhatPulse not starting (/showthread.php?tid=5792)



[FIXED] [Windows] WhatPulse not starting - Beastlyblu - 12-10-2014 01:51 AM

Hi, I have been having some major problems with getting WhatPulse to work.

This happened with Windows 8.1 with both versions 2.4.1 and the latest 2.5.0. Basically, the problem is that WhatPulse will open and stay open with no window, key/click tracking, etc. happening. I double click the program, the mouse cursor will display something loading, then, nothing. The program cannot be closed, it will not let me end the process tree either. A restart of the computer must be done in order to close it. When I uninstall it, there are no traces (I've deleted it from both Program Files (x86) and appdata/local/whatpulse. I have also deleted WinP Cap as that was causing issues earlier. However, reinstalling it doesn't seem to work in resolving the problem either. I've uninstalled and reinstalled at least 20 times already to no avail.

I am running the setup as an Admin and the program as an Admin as well, nothing really happens. I think I've tried everything on the forums at this point; help! Anyone know how to get dump files?

Thanks for any help given in advance.


RE: [Windows] WhatPulse not starting - smitmartijn - 12-10-2014 10:07 AM

Hi,

There's a file called 'app.log' in the appdata directory, check that for any messages on where it stops loading. In any case, you'll find another application (such as an antivirus) blocking the client.


RE: [Windows] WhatPulse not starting - Beastlyblu - 12-10-2014 01:42 PM

Alright, there doesn't seem to be very much here, but I've gone ahead and pasted in the app.log for WhatPulse.

http://pastebin.com/G20yU7Hk

Hope that helps.


RE: [Windows] WhatPulse not starting - smitmartijn - 12-10-2014 02:08 PM

10-12-2014 07:43:33.416 DEBUG WhatPulse is already running! Sending message to running client to bring up MainWindow and exiting this instance.

There you go. There's another instance of the client running, perhaps a zombie instance. Find it with your task manager, kill it and start the client. This sometimes happened in older versions, you're probably coming from one of those versions.


RE: [Windows] WhatPulse not starting - Beastlyblu - 12-10-2014 02:12 PM

Well, like I mentioned, that's not possible given that I have to restart the computer in order to kill the client. When I do, this loop happens where the above doesn't allow me to open it fully.

http://imgur.com/jnD4GAG

This is the error message that I get, and WhatPulse is running 2.5.0 at this point since the most recent instance I started was after a clean install of the latest version.


RE: [Windows] WhatPulse not starting - smitmartijn - 12-10-2014 02:33 PM

Seeing a lot of those messages online: http://answers.microsoft.com/en-us/windows/forum/windows_8-files/task-manager-cant-end-processes-access-denied/65c12d51-8b01-49f2-8e2e-4bf77010e419?page=1 - https://www.google.nl/webhp?sourceid=chrome-instant&ion=1&espv=2&es_th=1&ie=UTF-8#q=unable%20to%20terminate%20process%20access%20is%20denied - General sense is that something in your Windows permission structure has corrupted and it takes a system restore to fix it.

The next step for the client after this:

09-12-2014 19:37:50.721 DEBUG Loaded application aliases

..is to load a file from disk, or download it if it's not there (GeoIP.dat), there's nothing 'interesting' for the system there. I'm guessing the client gets stuck when requesting to download GeoIP.dat and store it. There's not much we can do here, if your Windows is messed up, sorry. Undecided


RE: [Windows] WhatPulse not starting - Beastlyblu - 12-11-2014 02:20 PM

Well, interestingly enough, after putting that in, my computer got stuck in a loop, attempting to repair my computer and not being able to do so. Looks like I'm forced to go ahead and reinstall Windows 8.1 fresh, so hopefully it'll fix my WhatPulse issues.

I will keep you posted on if anything goes wrong after a fresh install.


RE: [Windows] WhatPulse not starting - smitmartijn - 12-11-2014 05:26 PM

Sucks when Windows does that. :-(

Good luck, let us know if you have any issues with the client after the reinstall.