WhatPulse Forums
Ubuntu - WP closing as soon as it starts up - Printable Version

+- WhatPulse Forums (http://whatpulse.org/forums)
+-- Forum: Support (/forumdisplay.php?fid=38)
+--- Forum: Client software (/forumdisplay.php?fid=58)
+--- Thread: Ubuntu - WP closing as soon as it starts up (/showthread.php?tid=3156)

Pages: 1 2


Ubuntu - WP closing as soon as it starts up - dl1000v - 07-02-2013 12:13 PM

WP 2.1.1, Ubuntu 13.04 64 bit. The program has been running fine for months, no issues at all. Today it won't stay running on 2 different Ubuntu computers. As soon as it starts up it closes:

Quote:b@Ultrabook:~/Documents$ ./whatpulse
02-07-2013 07:56:38.350 INFO Starting WhatPulse...
02-07-2013 07:56:38.487 DEBUG Database file: "/home/b/.local/share/data/WhatPulse/whatpulse.db"
02-07-2013 07:56:38.544 DEBUG Database check: "ok"
02-07-2013 07:56:38.544 DEBUG Opened database in: 57 ms
02-07-2013 07:56:38.549 DEBUG Found proper permissions for network monitoring
02-07-2013 07:56:38.550 DEBUG Encrypted file: "/home/b/.local/share/data/WhatPulse/whatpulse.wpw"
02-07-2013 07:56:38.712 DEBUG Opening GeoIP database: "/home/b/.local/share/data/WhatPulse/GeoIP.dat"
02-07-2013 07:56:38.720 DEBUG Creating device listener for "/dev/input/event0"
02-07-2013 07:56:38.720 DEBUG Creating device listener for "/dev/input/event1"
02-07-2013 07:56:38.721 DEBUG Creating device listener for "/dev/input/event10"
02-07-2013 07:56:38.721 DEBUG Creating device listener for "/dev/input/event2"
02-07-2013 07:56:38.721 DEBUG Creating device listener for "/dev/input/event3"
02-07-2013 07:56:38.721 DEBUG Creating device listener for "/dev/input/event4"
02-07-2013 07:56:38.722 DEBUG Creating device listener for "/dev/input/event5"
02-07-2013 07:56:38.722 DEBUG Creating device listener for "/dev/input/event6"
02-07-2013 07:56:38.722 DEBUG Creating device listener for "/dev/input/event7"
02-07-2013 07:56:38.723 DEBUG Creating device listener for "/dev/input/event8"
02-07-2013 07:56:38.723 DEBUG Creating device listener for "/dev/input/event9"
02-07-2013 07:56:38.725 DEBUG Starting PfRingNetworkTrafficMonitor..
02-07-2013 07:56:38.726 DEBUG PF-Ring thread started
02-07-2013 07:56:38.738 DEBUG WhatPulse has started
The program 'whatpulse' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
(Details: serial 20 error_code 3 request_code 20 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)



RE: Ubuntu - WP closing as soon as it starts up - maew - 07-03-2013 05:21 AM

Same here, WP 2.1.1, Ubuntu 13.04 64 bit. Ubuntu has updated libqt4 yesterday and WP cannot start since then.
I fall back to WP 2.0.1, there is no problem.


RE: Ubuntu - WP closing as soon as it starts up - Sc0rian - 07-03-2013 03:49 PM

yup same here, suddenly started doing this today


RE: Ubuntu - WP closing as soon as it starts up - montythefish - 07-07-2013 05:39 AM

Same thing is happening to me. I was about to make a new post about it, then I stumbled upon this.

I'm running the latest Linux Mint x64. Latest Whatpulse. Was working fine up until a day or two ago. I'm not sure, but I remember letting linux update some packages around the time that whatpulse started crashing immediately upon opening; therefore, I think it is possible that some of the Qt libraries (or some dependencies that whatpulse relies on) may have updated and maybe that's why it isn't working.

I really have close to no idea. It would be nice to have someone acknowledge our issues.

Here's what is in the console when I try to start it manually in case it is help. Looks like it is an issue with how whatpulse creates a window.

07-07-2013 00:34:34.255 INFO Starting WhatPulse...
07-07-2013 00:34:34.341 WARN "sni-qt/20792" WARN 00:34:34.341 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE
07-07-2013 00:34:34.341 DEBUG Database file: "/home/matt/.local/share/data/WhatPulse/whatpulse.db"
07-07-2013 00:34:34.342 DEBUG Database check: "ok"
07-07-2013 00:34:34.342 DEBUG Opened database in: 1 ms
07-07-2013 00:34:34.348 DEBUG Found proper permissions for network monitoring
07-07-2013 00:34:34.348 DEBUG Encrypted file: "/home/matt/.local/share/data/WhatPulse/whatpulse.wpw"
07-07-2013 00:34:34.403 DEBUG Opening GeoIP database: "/home/matt/.local/share/data/WhatPulse/GeoIP.dat"
07-07-2013 00:34:34.407 DEBUG Creating device listener for "/dev/input/event0"
07-07-2013 00:34:34.408 DEBUG Creating device listener for "/dev/input/event1"
07-07-2013 00:34:34.408 DEBUG Creating device listener for "/dev/input/event10"
07-07-2013 00:34:34.408 DEBUG Creating device listener for "/dev/input/event11"
07-07-2013 00:34:34.408 DEBUG Creating device listener for "/dev/input/event12"
07-07-2013 00:34:34.408 DEBUG Creating device listener for "/dev/input/event13"
07-07-2013 00:34:34.408 DEBUG Creating device listener for "/dev/input/event14"
07-07-2013 00:34:34.409 DEBUG Creating device listener for "/dev/input/event15"
07-07-2013 00:34:34.409 DEBUG Creating device listener for "/dev/input/event16"
07-07-2013 00:34:34.409 DEBUG Creating device listener for "/dev/input/event17"
07-07-2013 00:34:34.409 DEBUG Creating device listener for "/dev/input/event18"
07-07-2013 00:34:34.409 DEBUG Creating device listener for "/dev/input/event2"
07-07-2013 00:34:34.410 DEBUG Creating device listener for "/dev/input/event3"
07-07-2013 00:34:34.410 DEBUG Creating device listener for "/dev/input/event4"
07-07-2013 00:34:34.410 DEBUG Creating device listener for "/dev/input/event5"
07-07-2013 00:34:34.410 DEBUG Creating device listener for "/dev/input/event6"
07-07-2013 00:34:34.410 DEBUG Creating device listener for "/dev/input/event7"
07-07-2013 00:34:34.411 DEBUG Creating device listener for "/dev/input/event8"
07-07-2013 00:34:34.411 DEBUG Creating device listener for "/dev/input/event9"
07-07-2013 00:34:34.412 DEBUG Starting PfRingNetworkTrafficMonitor..
07-07-2013 00:34:34.412 DEBUG PF-Ring thread started
07-07-2013 00:34:34.438 DEBUG WhatPulse has started
07-07-2013 00:34:34.498 WARN QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
The program 'whatpulse' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
(Details: serial 13 error_code 3 request_code 20 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)


RE: Ubuntu - WP closing as soon as it starts up - smitmartijn - 07-07-2013 08:47 AM

To what version of Qt have you guys updated?


RE: Ubuntu - WP closing as soon as it starts up - maew - 07-07-2013 12:51 PM

From 4.8.4+dfsg-0ubuntu9 to 4.8.4+dfsg-0ubuntu9.1 on Ubuntu 13.04

# cat history.log
Start-Date: 2013-07-02 09:21:51
Commandline: aptdaemon role='role-commit-packages' sender=':1.185'
Upgrade: libqt4-declarative:amd64 (4.8.4+dfsg-0ubuntu9, 4.8.4+dfsg-0ubuntu9.1), libqt4-declarative:i386 (4.8.4+dfsg-0ubuntu9, 4.8.4+dfsg-0ubuntu9.1), libqt4-qt3support:amd64 (4.8.4+dfsg-0ubuntu9, 4.8.4+dfsg-0ubuntu9.1), libqt4-qt3support:i386 (4.8.4+dfsg-0ubuntu9, 4.8.4+dfsg-0ubuntu9.1), libkxmlrpcclient4:amd64 (4.10.3-0ubuntu0.1~ubuntu13.04, 4.10.4-0ubuntu0.1) ...


RE: Ubuntu - WP closing as soon as it starts up - montythefish - 07-07-2013 02:19 PM

Looks like most of my libqt4* packages say version "4:4.8.4+dfsg-0ubuntu9.1"
libqtassistantclient4 is "4.6.3-4ubuntu1"
libqtwebkit4 is "2.3.0-0ubuntu2"
libqtwebkit4:i386" is same


RE: Ubuntu - WP closing as soon as it starts up - montythefish - 07-08-2013 07:00 PM

Any solution yet? Or is there a way to downgrade for the time being?


RE: Ubuntu - WP closing as soon as it starts up - dl1000v - 07-08-2013 08:02 PM

(07-08-2013 07:00 PM)montythefish Wrote:  Any solution yet? Or is there a way to downgrade for the time being?

I still had a 2.1B3 version in my download folder from a previous install. Fired that up and it's been working fine since the QT update.

Also noticed if you run WP 2.1.1 as sudo, it will count all statistics in the background even though there is no icon on the panel or in Unity. I did this for a couple days until I rolled back just to continue capturing my stats in the background.

HTH


RE: Ubuntu - WP closing as soon as it starts up - montythefish - 07-08-2013 09:02 PM

Thanks for the response.

I tried adding a line to cron in hopes that I could start whatpulse on startup that way.

"$ sudo crontab -e"
then I added the line
"@reboot root whatpulse"

Didn't work. However, if I just run "sudo whatpulse" in the terminal after I've booted up, then it opens and stays open. Main downside being the extra terminal now open.

Thanks for the help.