WhatPulse Forums
linux whatpulse not always starting - Printable Version

+- WhatPulse Forums (http://whatpulse.org/forums)
+-- Forum: Support (/forumdisplay.php?fid=38)
+--- Forum: Client software (/forumdisplay.php?fid=58)
+--- Thread: linux whatpulse not always starting (/showthread.php?tid=2744)



linux whatpulse not always starting - Sc0rian - 03-07-2013 03:30 AM

I'm running Ubuntu. Most of the time I notice that whatpulse does start when I login, I normally have to manually start it. Sometimes its does load. It is in startup applications.

Anything I can do fix this?


RE: linux whatpulse not always starting - smitmartijn - 03-10-2013 11:56 AM

Does your startup command has the "onstartup" parameter in it? If you have enabled the startup sequence via the client, it will add the "onstartup" parameter on boot. This parameter will cause the client to wait for 3 seconds before actually initialising, as most of the time the linux GUI is not ready loading when linux starts the client.


RE: linux whatpulse not always starting - alfio8788 - 03-10-2013 12:28 PM

Would it be possible to add settings about the startup delay? I have some old pcs that need more than 3 seconds to load the desktop and that leads to the error message "no traybar running".

For those with the same problem you can use this as a workaround:

Code:
#!/bin/sh

WPPATH='/usr/bin/whatpulse' # Set this to your whatpulse client executable path including the name of the binary file
STARTUPDELAY='15' # Numbers of seconds to wait before launching the client

if [ -f "$WPPATH" ]; then
    sleep $STARTUPDELAY;
    WPPATH
else
    echo "ERROR: Your WhatPulse client executable path seems to be wrong, change it setting the right path and try again";
    exit 1;
fi



RE: linux whatpulse not always starting - rents - 03-29-2013 11:18 AM

(03-10-2013 12:28 PM)alfio8788 Wrote:  Would it be possible to add settings about the startup delay? I have some old pcs that need more than 3 seconds to load the desktop and that leads to the error message "no traybar running".

+1 for customizable delay or even better - detect if tray is present before starting. I have a quite decent computer, but it still fails to start. In fact, gnome *seems* to wait for whatpulse (nothing else appears before this error dialog).


RE: linux whatpulse not always starting - j8newbie - 03-31-2013 12:28 PM

No such problem on Xubuntu 12.04, or 12.10.