WhatPulse Forums
Linux - 2.0.4 doesn't work on Debian - Printable Version

+- WhatPulse Forums (http://whatpulse.org/forums)
+-- Forum: Support (/forumdisplay.php?fid=38)
+--- Forum: Client software (/forumdisplay.php?fid=58)
+--- Thread: Linux - 2.0.4 doesn't work on Debian (/showthread.php?tid=2544)

Pages: 1 2


Linux - 2.0.4 doesn't work on Debian - ejsik - 02-02-2013 10:04 AM

64bit version:
Code:
./whatpulse: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by ./whatpulse)

32bit version:
Code:
./whatpulse: error while loading shared libraries: libQtWebKit.so.4: cannot open shared object file: No such file or directory

Code:
Linux version 3.3.0-8.dmz.1-liquorix-amd64 (Debian 3.3.0-9) () (gcc version 4.6.3 (Debian 4.6.3-7) ) #1 ZEN SMP PREEMPT Mon Jun 4 19:51:34 CDT 201

1.2 working "out of box", so still staying with 1.2. :/


RE: 2.0.4 doesn't work - smitmartijn - 02-02-2013 01:23 PM

Debian is currently not supported, as it uses outdated packages. There will be a Debian specific built sometime, but can't really say when.


RE: Linux - 2.0.4 doesn't work on Debian - ejsik - 02-02-2013 04:40 PM

Oh... to bad. So I'm waiting for debian build Smile

Thanks for reply.


RE: Linux - 2.0.4 doesn't work on Debian - ppkt - 03-09-2013 09:10 AM

Hi, I resolved this issue by upgrading glibc library to version 2.17 (I guess you have to add Debian testing and/or experimental repo). After that WhatPulse works fine Smile


RE: Linux - 2.0.4 doesn't work on Debian - nimd4 - 03-13-2013 01:49 PM

This has been known from the beta board....
  • Code:
    http://whatpulse.org/forums/showthread.php?tid=2006&pid=18212#pid18212
    &&
  • Code:
    http://whatpulse.org/forums/showthread.php?tid=1982



RE: 2.0.4 doesn't work - hostname - 04-27-2013 03:19 PM

(02-02-2013 01:23 PM)smitmartijn Wrote:  Debian is currently not supported, as it uses outdated packages. There will be a Debian specific built sometime, but can't really say when.

Just take a few minutes to compile against libc 2.13, you're not using any features from a newer version anyway.


RE: 2.0.4 doesn't work - smitmartijn - 04-27-2013 07:36 PM

(04-27-2013 03:19 PM)hostname Wrote:  Just take a few minutes to compile against libc 2.13, you're not using any features from a newer version anyway.

Probably not from the libc, correct. However, the client uses several Qt functions available only in 4.6+ (or 4.7+). When upgrading Qt on debian, you need to take everything with it, including libc, so thats useless. Downgrading libc on an up to date distro is also a nightmare.

To make it work, there needs to be a version that can work with the old Qt, which means recoding some stuff. Seeing as there are 2182 computers of the 136382 computers total using Linux (so 1.5%), this has not been given priority. It's still on the todo, and now that windows (with 2.1) is mostly stable, there is a chance it will happen soon.


RE: 2.0.4 doesn't work - hostname - 04-28-2013 12:45 PM

(04-27-2013 07:36 PM)smitmartijn Wrote:  Probably not from the libc, correct. However, the client uses several Qt functions available only in 4.6+ (or 4.7+). When upgrading Qt on debian, you need to take everything with it, including libc, so thats useless.
That's not true. Debian Squeeze has Qt 4.6, while the soon-to-be-released Wheezy even has Qt 4.8. Qt is also compiled against the default libc version in that version (2.11 for Squeeze, 2.13 for Wheezy), so you don't even need to update libc for the Qt version.

(Squeeze is almost two years old, so I can imagine you don't want to support that, though it shouldn't be hard. Wheezy will be released next weekend, and has a more than new enough Qt, so there's no reason to don't support it).

(04-27-2013 07:36 PM)smitmartijn Wrote:  Downgrading libc on an up to date distro is also a nightmare.
True, but you don't have to downgrade the running version, just don't reference the GLIBC_2.14 symbol.


RE: 2.0.4 doesn't work - smitmartijn - 04-28-2013 01:39 PM

(04-28-2013 12:45 PM)hostname Wrote:  That's not true. Debian Squeeze has Qt 4.6, while the soon-to-be-released Wheezy even has Qt 4.8. Qt is also compiled against the default libc version in that version (2.11 for Squeeze, 2.13 for Wheezy), so you don't even need to update libc for the Qt version.

Good phrasing; "the soon-to-be-released" - as it's currently still in testing phase. And you're right, I don't want to support an OS that's still in beta.

Expect a compiled version when this Wheezy version comes out, or when there's time to make the client Qt 4.6 compatible.


RE: 2.0.4 doesn't work - hostname - 04-28-2013 01:43 PM

(04-28-2013 01:39 PM)smitmartijn Wrote:  Good phrasing; "the soon-to-be-released" - as it's currently still in testing phase. And you're right, I don't want to support an OS that's still in beta.

Expect a compiled version when this Wheezy version comes out, or when there's time to make the client Qt 4.6 compatible.
Ok, I'll be happy to download it on Sunday then Smile