WhatPulse Forums
Cant install the linux client - Printable Version

+- WhatPulse Forums (http://whatpulse.org/forums)
+-- Forum: Support (/forumdisplay.php?fid=38)
+--- Forum: Client software (/forumdisplay.php?fid=58)
+--- Thread: Cant install the linux client (/showthread.php?tid=2028)

Pages: 1 2 3 4


Cant install the linux client - BladeX - 12-23-2012 08:45 PM

Hello,

I get the following error:

Code:
atouba@Ideapad:~/Programme$ ./whatpulse32
QSqlDatabase: QSQLITE driver not loaded
QSqlDatabase: available drivers: QMYSQL3 QMYSQL
Failed to open the database:  QSqlError(-1, "Driver not loaded", "Driver not loaded")

I tried to get all the needed libraries via apt-get, but the most cant be found. Maybe not the right sources? But which do I need to get all the libaries?

Any Ideas?


RE: Cant install the linux client - smitmartijn - 12-23-2012 09:47 PM

Are you sure you got the libqt-sql-sqlite package installed? Looks like that is the only problem.


RE: Cant install the linux client - Aquascum - 12-23-2012 09:57 PM

I found that libqt-sql-sqlite solved that problem.

However, I use Debian testing (fully updated) and have the following issue:

/lib/libc.so.6: version `GLIBC_2.14' not found (required by ./whatpulse)


RE: Cant install the linux client - smitmartijn - 12-23-2012 10:03 PM

Debian is currently not supported because of the outdated packages it uses. It's on the roadmap to remove or recode some features to work with an older version of Qt.

There is someone that got it running after updating a lot (http://whatpulse.org/forums/showthread.php?tid=1982 ) - but I wouldn't recommend trying it if you don't want some heavy troubleshooting.


RE: Cant install the linux client - Aquascum - 12-23-2012 10:12 PM

Okay thanks. Is there a way I can get a copy of the last version of Whatpulse (1.xx) that used to be the main download?


RE: Cant install the linux client - BladeX - 12-23-2012 10:15 PM

(12-23-2012 09:47 PM)smitmartijn Wrote:  Are you sure you got the libqt-sql-sqlite package installed? Looks like that is the only problem.

Thanks!
I installed the libqt-sql-sqlite package. But now I got this error:

Code:
atouba@Ideapad:~/Programme$ ./whatpulse
Database check:  "ok"
"/home/atouba/.local/share/data//WhatPulse/whatpulse.db"
./whatpulse: symbol lookup error: ./whatpulse: undefined symbol: _ZN9QListData11detach_growEPii



RE: Cant install the linux client - smitmartijn - 12-23-2012 10:18 PM

What OS are you on?


RE: Cant install the linux client - smitmartijn - 12-23-2012 10:22 PM

(12-23-2012 10:12 PM)Aquascum Wrote:  Okay thanks. Is there a way I can get a copy of the last version of Whatpulse (1.xx) that used to be the main download?

That's still on jmrk.whatpulse.org


RE: Cant install the linux client - BladeX - 12-23-2012 10:28 PM

(12-23-2012 10:18 PM)smitmartijn Wrote:  What OS are you on?

Ubuntu 10.04 (EasyPeasy 1.6)


RE: Cant install the linux client - smitmartijn - 12-23-2012 11:00 PM

(12-23-2012 10:28 PM)BladeX Wrote:  Ubuntu 10.04 (EasyPeasy 1.6)

That's probably too old to work properly. I've not tested below version 11.

You should upgrade either way, but try to go to 11 at least, if not the latest.