WhatPulse Forums
GLIBC and Debian - Printable Version

+- WhatPulse Forums (http://whatpulse.org/forums)
+-- Forum: Community (/forumdisplay.php?fid=34)
+--- Forum: Beta client (/forumdisplay.php?fid=74)
+---- Forum: Archive (/forumdisplay.php?fid=80)
+---- Thread: GLIBC and Debian (/showthread.php?tid=1982)



GLIBC and Debian - JJJJust - 12-22-2012 08:25 PM

WhatPulse 2.0 on Debian is complaining that GLIBC 2.14 is needed. The latest version available and non-experimental for Debian is 2.13. 2.16 is still experimental and installing it threatens to remove a bunch of other packages on my system, so I'm not.

Is there a workaround or a non-versioned whatpulse install coming?


RE: GLIBC and Debian - smitmartijn - 12-22-2012 08:29 PM

Debian is currently not supported. WhatPulse needs a Qt version (4.7+) that does not work with the outdated packages Debian unfortunately uses, so I have been unable to compile it for Debian.

It's on the todo list, but I'd rather work out how to update Qt to a proper version.


RE: GLIBC and Debian - JJJJust - 12-22-2012 08:31 PM

(12-22-2012 08:29 PM)smitmartijn Wrote:  Debian is currently not supported. WhatPulse needs a Qt version (4.7+) that does not work with the outdated packages Debian unfortunately uses, so I have been unable to compile it for Debian.

It's on the todo list, but I'd rather work out how to update Qt to a proper version.

I've got libqt4-core at 4.8 from Debian testing.


RE: GLIBC and Debian - smitmartijn - 12-22-2012 08:41 PM

Hm, I think I mainly used the unstable repo - I take it those two are different repos?


RE: GLIBC and Debian - MAX3400 - 12-22-2012 09:05 PM

Would love to find an option to get this running on Debian 6 (64-bit) since it's one of my main machines.

Tried it already under VMware and create a Deb6-guest but I also seem to struggle with the stable repo's. Getting it running only with unstable repo's just seems to defy the whole "sense" of running a stable distro at all.


RE: GLIBC and Debian - JJJJust - 12-22-2012 09:05 PM

(12-22-2012 08:41 PM)smitmartijn Wrote:  Hm, I think I mainly used the unstable repo - I take it those two are different repos?

The packages generally start in experimental or possibly unstable/sid, then move to testing, then move to stable at next Debian release.

The non-transitional package, I've found, is libqtcore4, so I'll call it that instead of libqt4-core.

If you're still running less than 4.8 and pulling from unstable by default, libqtcore4 (and its related packages) is probably set to be held. If there's a hold, apt-get won't upgrade the packages it unless explicitly told to.

Unstable is at "4:4.8.2+dfsg-6" for the architectures: amd64 armel armhf i386 ia64 kfreebsd-amd64 kfreebsd-i386 powerpc s390 s390x sparc
Testing is at "4:4.8.2+dfsg-2" for: amd64 armel armhf i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mipsel powerpc s390 s390x sparc

If you want to force-install it from unstable, you can use "apt-get install libqtcore4=4:4.8.2+dfsg-6". But, doing that on my computer, threatened to remove a large number of packages. (edit: Which I'm guessing is because it's not upgrading the other subpackages at the same time. I still recommend an "apt-get -s install" to simulate what installing it will do.)

Last Edit, I Promise: I finally got it to upgrade all the dependent packages at once by using "apt-get -t unstable install libqtcore4".


RE: GLIBC and Debian - JJJJust - 12-23-2012 12:35 PM

I tried to get libc 2.16 from the experimental repo... and it totally trashed my system.

15 hours later, some manual lib copying here, some cursing there... annndddd... I can boot again... and WhatPulse is running on Debian. Smile

However, for the sanity of my fellow users, see if you can give us Debian users a version that doesn't require >= 2.14 for libc.


RE: GLIBC and Debian - smitmartijn - 12-23-2012 12:41 PM

Yeah, I'll see what it needs to run on the older versions. Won't be very soon though..