WhatPulse Forums

Full Version: This Program Requires Windows Service Pack 1 or Later
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm currently on WhatPulse 2.8.4-1633, running Windows 10 Pro Version 2004 (OS Build 19041.985). Whenever I try to update, I get the error "This Program Requires Windows Service Pack 1 or Later" and the installer closes. I've had this issue since version 3.0.

I attempted a fresh install of version 3.3 from the WhatPulse Downloads and it gave the same error. Version 2.8.4 installs just fine.
I found a solution for this issue. Compatibility mode with Windows 7 had been enabled in the WhatPulse.exe properties. For some reason, reinstalling didn't reset this option and I had to go in and change it manually. Whatpulse 3.0+ works flawlessly now.