WhatPulse Forums » Support » Client software v » Trouble with Ubuntu 18.10 Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trouble with Ubuntu 18.10
11-19-2018, 07:28 AM
Post: #1
Trouble with Ubuntu 18.10
I've installed all the dependencies ran all the setup scripts which all ran just fine but when I try to run whatpulse itself I get this:

Code:
./whatpulse
19-11-2018 01:15:13.798  INFO "Starting WhatPulse 2.8.4-1633..."
QObject::startTimer: Timers cannot have negative intervals
19-11-2018 01:15:13.823 DEBUG Database file:  "/home/anastasia/.local/share/WhatPulse/whatpulse.db"
Application crashed with signal 11!
Find all posts by this user
Quote this message in a reply
11-19-2018, 05:10 PM
Post: #2
RE: Trouble with Ubuntu 18.10
The error also happened to me on Ubuntu 18.10 after upgrading to the latest WhatPulse client.
Find all posts by this user
Quote this message in a reply
11-19-2018, 06:23 PM (This post was last modified: 11-20-2018 11:31 PM by kekePower.)
Post: #3
RE: Trouble with Ubuntu 18.10
Hi.

Have the same problem on Mageia 7 x86_64.

Code:
% ./whatpulse
19-11-2018 19:19:42.335  INFO "Starting WhatPulse 2.8.4-1633..."
QObject::startTimer: Timers cannot have negative intervals
19-11-2018 19:19:42.351 DEBUG "/home/stig/.local/share/WhatPulse"  does not exist, starting fresh!
19-11-2018 19:19:42.352 DEBUG Database file:  "/home/stig/.local/share/WhatPulse/whatpulse.db"
19-11-2018 19:19:42.353 DEBUG Database check:  "ok"
19-11-2018 19:19:42.353 DEBUG Opened database in:  2 ms
Application crashed with signal 11!
0 [/lib64/libc.so.6(memcpy+0x1f) [0x7f880e0a9cef]]
1 [./whatpulse(+0x194bd7) [0x56345267fbd7]]
2 [./whatpulse(sqlite3_vsnprintf+0x57) [0x56345267fe67]]
3 [./whatpulse(sqlite3_snprintf+0x8f) [0x56345267ff1f]]
4 [./whatpulse(+0x194f93) [0x56345267ff93]]
5 [./whatpulse(+0x195110) [0x563452680110]]
6 [/lib64/libsqlite3.so.0(+0x2b89b) [0x7f88054bd89b]]
7 [/usr/lib64/qt5/plugins/sqldrivers/libqsqlite.so(+0x8573) [0x7f88055f1573]]
[1]    5652 abort (core dumped)  ./whatpulse
Find all posts by this user
Quote this message in a reply
11-20-2018, 09:55 AM
Post: #4
RE: Trouble with Ubuntu 18.10
I have same issue on Majaro KDE with kernel 4.19.2-1

Code:
20-11-2018 10:53:45.865  INFO "Starting WhatPulse 2.8.4-1633..."
20-11-2018 10:53:45.936 DEBUG "/home/matthieu/.local/share/WhatPulse"  does not exist, starting fresh!
20-11-2018 10:53:45.936 DEBUG Database file:  "/home/matthieu/.local/share/WhatPulse/whatpulse.db"
20-11-2018 10:53:45.939 DEBUG Database check:  "ok"
20-11-2018 10:53:45.939 DEBUG Opened database in:  4 ms
Application crashed with signal 11!
0 [/usr/lib/libc.so.6(+0x15fcdc) [0x7f445b127cdc]]
1 [whatpulse(+0x1a8d7b) [0x557b2e657d7b]]
2 [whatpulse(sqlite3_vsnprintf+0x57) [0x557b2e658247]]
3 [whatpulse(sqlite3_snprintf+0x90) [0x557b2e658300]]
4 [whatpulse(+0x1a9374) [0x557b2e658374]]
5 [whatpulse(+0x1a94e8) [0x557b2e6584e8]]
6 [/usr/lib/libsqlite3.so.0(+0xc7625) [0x7f444c583625]]
7 [/usr/lib/qt/plugins/sqldrivers/libqsqlite.so(+0x7ae4) [0x7f444c62dae4]]
[1]    6286 abort      whatpulse
Find all posts by this user
Quote this message in a reply
11-21-2018, 12:21 AM
Post: #5
RE: Trouble with Ubuntu 18.10
I have the same issue on Arch Linux. Here's a backtrace:

Code:
(gdb) run
Starting program: /usr/bin/whatpulse
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
[New Thread 0x7f16bc160700 (LWP 9615)]
[New Thread 0x7f16b9914700 (LWP 9616)]
[New Thread 0x7f16b9113700 (LWP 9617)]
[New Thread 0x7f16b8912700 (LWP 9618)]
[New Thread 0x7f16abfff700 (LWP 9619)]
20-11-2018 18:16:46.984  INFO "Starting WhatPulse 2.8.4-1633..."
[New Thread 0x7f16ab5b2700 (LWP 9620)]
[New Thread 0x7f16aadb1700 (LWP 9621)]
QObject::startTimer: Timers cannot have negative intervals
20-11-2018 18:16:47.044 DEBUG Database file:  "/home/wieschie/.local/share/WhatPulse/whatpulse.db"
20-11-2018 18:16:47.060 DEBUG Database check:  "ok"
20-11-2018 18:16:47.061 DEBUG Opened database in:  17 ms

Thread 1 "whatpulse" received signal SIGSEGV, Segmentation fault.
0x000056089733cf90 in ?? ()
(gdb) bt
#0  0x000056089733cf90 in  ()
#1  0x0000560897345c7e in  ()
#2  0x000056089734c40c in  ()
#3  0x000056089734c4e8 in  ()
#4  0x00007f16aa4c2625 in  () at /usr/lib/libsqlite3.so.0
#5  0x00007f16aa565ae4 in  () at /usr/lib/qt/plugins/sqldrivers/libqsqlite.so
#6  0x00007f16aa568afa in  () at /usr/lib/qt/plugins/sqldrivers/libqsqlite.so
#7  0x00007f16aa568e69 in  () at /usr/lib/qt/plugins/sqldrivers/libqsqlite.so
#8  0x00007f16c1e64b1d in QSqlQuery::exec(QString const&) () at /usr/lib/libQt5Sql.so.5
#9  0x00007f16c1e6b069 in QSqlDatabase::exec(QString const&) const () at /usr/lib/libQt5Sql.so.5
#10 0x00005608972a5496 in Application::setupDatabase() ()
#11 0x00005608972b137d in Application::start(bool, bool) ()
#12 0x0000560897269fb4 in main ()
Find all posts by this user
Quote this message in a reply
11-24-2018, 01:57 PM (This post was last modified: 11-24-2018 01:57 PM by Drake356.)
Post: #6
RE: Trouble with Ubuntu 18.10
At least acknowledge us Martyn ;w;
Find all posts by this user
Quote this message in a reply
11-26-2018, 08:53 AM
Post: #7
RE: Trouble with Ubuntu 18.10
Same problem on Archlinux
Find all posts by this user
Quote this message in a reply
11-30-2018, 12:44 AM
Post: #8
RE: Trouble with Ubuntu 18.10
Same issue here on fresh Ubuntu 18.10 install
Find all posts by this user
Quote this message in a reply
12-06-2018, 08:47 AM
Post: #9
RE: Trouble with Ubuntu 18.10
Any news ?
Find all posts by this user
Quote this message in a reply
12-06-2018, 08:51 AM
Post: #10
RE: Trouble with Ubuntu 18.10
Nope not really Sad.
It seems like the devs have abandoned Linux support.
Because I also contacted them through the contact form.
Well let's hope that they are so busy working on a fix that they don't have time to reply.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Sad Linux Client Installation(Ubuntu 18.04) ThatBlazyScouter 4 732 11-09-2018 11:27 AM
Last Post: phrenq
  Updated build for Ubuntu 18.04 will be needed dgw 11 2,880 10-22-2018 09:37 AM
Last Post: dgw
Smile Application usage on Ubuntu juniorain 3 1,014 05-26-2018 03:47 PM
Last Post: juniorain
  Ubuntu 17.10 Whatpulse No System Tray aaronmao 1 1,641 04-27-2018 05:23 AM
Last Post: dgw
  2.8.1 issues on Ubuntu sim642 2 1,933 04-11-2018 10:56 AM
Last Post: dgw
  [CLOSED] Network traffic not recorded on Ubuntu 16.04 LTS GnaXi 6 5,451 12-30-2017 09:31 AM
Last Post: cheeseandcereal
Question [CLOSED] Whatpulse 2.8.x for Linux/Ubuntu bogy 1 2,599 07-08-2017 02:54 PM
Last Post: sz_
  Whatpulse crashes system on ubuntu using intel graphics Wilson18com 0 1,876 05-28-2017 01:11 AM
Last Post: Wilson18com
  Ubuntu on Mac SeeEmAge 0 1,751 04-29-2016 09:10 PM
Last Post: SeeEmAge
  Memory leak WhatPulse 2.6.3 on Ubuntu 15.04 Wouter0100 2 3,297 01-07-2016 11:52 AM
Last Post: Wouter0100

Forum Jump:


User(s) browsing this thread: 1 Guest(s)