WhatPulse Forums » Support » Client software v » [CLOSED] Whatpulse does not work with libssl-dev 1.1.0 Welcome back, Guest.


Thread Closed 
 
Thread Rating:
  • 6 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[CLOSED] Whatpulse does not work with libssl-dev 1.1.0
08-04-2017, 10:26 AM
Post: #41
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
Arch seems to be using OpenSSL 1.0, so use the Debian version. Ubuntu is at 1.1. That's why I linked to the help article.
Visit this user's website Find all posts by this user
08-04-2017, 12:32 PM (This post was last modified: 08-04-2017 12:33 PM by oxman.)
Post: #42
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
My previous post was with Debian version and the last with Unbuntu version.
No one work.

And Arch use 1.1.0 :
https://www.archlinux.org/packages/core/...ssl/files/
Find all posts by this user
08-04-2017, 03:00 PM
Post: #43
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
Debian Stretch 9.0 is using libssl 1.1.0 which is the current stable version.

I ran into this issue once I upgrade from version 8 to 9, since it's the new stable release.

Tried both Ubuntu and Debian 64 bit versions and still both give AES errors.
Find all posts by this user
08-06-2017, 03:10 PM
Post: #44
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
Seems like the binaries were updated? Still the same error of "AES functions not available" though. I'm on Arch, so openssl 1.1.0

whatpulse-linux-debian-64bit-2.8.1.tar.gz

$ md5sum /usr/bin/whatpulse
27efeb16ab2777c903624dbfba7e9c81

$ ldd /usr/bin/whatpulse
linux-vdso.so.1 (0x00007ffe5a074000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x00007fa7ea761000)
libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0x00007fa7ea44e000)
libQtScript.so.4 => /usr/lib/libQtScript.so.4 (0x00007fa7e9f67000)
libQtSql.so.4 => /usr/lib/libQtSql.so.4 (0x00007fa7e9d24000)
libQtXml.so.4 => /usr/lib/libQtXml.so.4 (0x00007fa7e9adb000)
libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0x00007fa7e8d9f000)
libQtNetwork.so.4 => /usr/lib/libQtNetwork.so.4 (0x00007fa7e8a4d000)
libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0x00007fa7e8545000)
libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007fa7e8327000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007fa7e7f9f000)
libm.so.6 => /usr/lib/libm.so.6 (0x00007fa7e7c8d000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007fa7e7a76000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007fa7e76ce000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007fa7e74a5000)
libdl.so.2 => /usr/lib/libdl.so.2 (0x00007fa7e72a1000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007fa7e6f8e000)
libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007fa7e6d58000)
libz.so.1 => /usr/lib/libz.so.1 (0x00007fa7e6b41000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007fa7e6878000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00007fa7e6625000)
libSM.so.6 => /usr/lib/libSM.so.6 (0x00007fa7e641d000)
libICE.so.6 => /usr/lib/libICE.so.6 (0x00007fa7e6200000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00007fa7e5ff5000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00007fa7e5db1000)
libXext.so.6 => /usr/lib/libXext.so.6 (0x00007fa7e5b9d000)
libssl.so.1.1 => /usr/lib/libssl.so.1.1 (0x00007fa7e5933000)
libcrypto.so.1.1 => /usr/lib/libcrypto.so.1.1 (0x00007fa7e54b3000)
librt.so.1 => /usr/lib/librt.so.1 (0x00007fa7e52ab000)
/lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x000055c096870000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x00007fa7e50a7000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007fa7e4e9f000)
libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007fa7e4c2c000)
libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007fa7e4a1c000)
libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0x00007fa7e4784000)
libffi.so.6 => /usr/lib/libffi.so.6 (0x00007fa7e457b000)
libuuid.so.1 => /usr/lib/libuuid.so.1 (0x00007fa7e4376000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007fa7e4141000)
libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0x00007fa7e3f15000)



whatpulse-linux-ubuntu-64bit-2.8.1.tar.gz

$ md5sum /usr/bin/whatpulse
28fae6c32fd42dcaba1be7970c1c564d

$ ldd /usr/bin/whatpulse
linux-vdso.so.1 (0x00007fff82db0000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x00007f826b774000)
libQtSql.so.4 => /usr/lib/libQtSql.so.4 (0x00007f826b531000)
libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0x00007f826a7f5000)
libQtNetwork.so.4 => /usr/lib/libQtNetwork.so.4 (0x00007f826a4a5000)
libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0x00007f8269f9d000)
libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f8269d7f000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f82699f5000)
libm.so.6 => /usr/lib/libm.so.6 (0x00007f82696e3000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f82694cc000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007f8269126000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007f8268efd000)
libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f8268cf9000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007f82689e4000)
libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007f82687ae000)
libz.so.1 => /usr/lib/libz.so.1 (0x00007f8268597000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007f82682d0000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00007f826807d000)
libSM.so.6 => /usr/lib/libSM.so.6 (0x00007f8267e75000)
libICE.so.6 => /usr/lib/libICE.so.6 (0x00007f8267c56000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00007f8267a4b000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00007f8267807000)
libXext.so.6 => /usr/lib/libXext.so.6 (0x00007f82675f5000)
libssl.so.1.1 => /usr/lib/libssl.so.1.1 (0x00007f826738b000)
libcrypto.so.1.1 => /usr/lib/libcrypto.so.1.1 (0x00007f8266f0b000)
librt.so.1 => /usr/lib/librt.so.1 (0x00007f8266d01000)
/lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x0000563b7e456000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x00007f8266afd000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007f82668f7000)
libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007f8266684000)
libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007f8266474000)
libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0x00007f82661da000)
libffi.so.6 => /usr/lib/libffi.so.6 (0x00007f8265fd1000)
libuuid.so.1 => /usr/lib/libuuid.so.1 (0x00007f8265dcc000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007f8265b99000)
libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0x00007f826596d000)
Find all posts by this user
08-07-2017, 08:05 AM
Post: #45
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
Im also using arch, and its unfortunately still not working.

Here some output from my libs folder
ll /usr/lib/ | grep "libssl"

-rwxr-xr-x 1 root root 361544 Jun 9 19:35 libssl3.so
-rwxr-xr-x 1 root root 465264 May 29 09:04 libssl-compat.so.1.0.0
lrwxrwxrwx 1 root root 13 May 25 18:48 libssl.so -> libssl.so.1.1
-r-xr-xr-x 1 root root 502024 May 25 18:54 libssl.so.1.0.0
-rwxr-xr-x 1 root root 437920 May 25 18:49 libssl.so.1.1
Find all posts by this user
08-08-2017, 01:19 PM
Post: #46
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
Quote:We miss you!
Hi,

I see that you have not pulsed in a few weeks, can we help you get started again?

Sad
Find all posts by this user
08-10-2017, 10:12 AM
Post: #47
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
I can still only use whatpulse by holding the libssl-dev package *downgraded* to a 1.0.x version.
Find all posts by this user
08-17-2017, 08:00 AM
Post: #48
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
That's a shame, 6 months without solution.
Find all posts by this user
08-17-2017, 12:12 PM
Post: #49
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
There is a solution for the OS distros we provide. Others need workaround that we cannot provide. Closing this thread now, as we can't do anything more.
Visit this user's website Find all posts by this user
Thread Closed 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  WhatPulse not starting - SOLVED CodeEnos 0 15 Yesterday 09:32 AM
Last Post: CodeEnos
  [SOLVED] WhatPulse does not allow me to pulse and does not pulse after 50k keys LSC99bolt 2 197 09-30-2017 08:13 PM
Last Post: LSC99bolt
  WhatPulse detects xplayer's input i.e. clicks/keys but not uptime. ggelhsva 0 132 09-21-2017 12:35 PM
Last Post: ggelhsva
Bug Heatmap doesn't work in 2.8.1 veselric 11 1,261 09-13-2017 06:59 AM
Last Post: [GoT]Jewest
Question [CLOSED] Whatpulse 2.8.x for Linux/Ubuntu bogy 1 640 07-08-2017 02:54 PM
Last Post: sz_
  [FIXED] Whatpulse 2.8 is not counting any network traffic Ractaros96 4 1,060 07-04-2017 02:04 AM
Last Post: Ractaros96
  Keys and clicks don't work satshow 1 689 04-25-2017 09:12 PM
Last Post: MrLinuxFish
  [CLOSED] Network traffic not recorded on Ubuntu 16.04 LTS GnaXi 5 1,908 04-12-2017 03:59 AM
Last Post: fatsa
  [CLOSED] Debian Stretch: OpenSSL library not found wullxz 1 972 02-27-2017 05:31 PM
Last Post: smitmartijn
Information [CLOSED] Mouse distance counter in Windows client. TigraPolosatiy 1 885 02-27-2017 05:30 PM
Last Post: smitmartijn

Forum Jump:


User(s) browsing this thread: 1 Guest(s)