WhatPulse Forums » Support » Client software v » [Edited] Whatpulse does not work with libssl-dev 1.1.0 Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 4 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Edited] Whatpulse does not work with libssl-dev 1.1.0
Yesterday, 02:22 PM
Post: #31
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
(07-20-2017 06:20 PM)swa Wrote:  It appears that LD_PRELOAD and LD_LIBRARY_PATH aren't working as a regular user because Whatpulse is running as a Set-UID program to get extra privileges.

Since the executable can gain root privileges during execution, certain inputs are ignored that are controlled at the user level. See the link below, but the gist of it is that if the user can specify a library to use, they can specify one with malicious code, which in turn could be executed as root. So as a result, Set-UID programs have special rules, one of which is that ld.so does not take inputs from environment variables.

http://www.cis.syr.edu/~wedu/Teaching/In...et_UID.pdf

Thanks for the explanation, makes perfectly sense. I guess we have to wait then for a whatpulse update linked to openssl-1.1...
Find all posts by this user
Quote this message in a reply
Yesterday, 03:51 PM
Post: #32
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
(Yesterday 02:22 PM)mik Wrote:  Thanks for the explanation, makes perfectly sense. I guess we have to wait then for a whatpulse update linked to openssl-1.1...

Or put caution to the wind and run Whatpulse as root... (I don't recommend this)

If the current user id is 0 (root), then there is no privilege escalation, and the environment variables have been set by root user. So it accepts them.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Bug Heatmap doesn't work in 2.8.1 veselric 3 153 07-19-2017 05:58 PM
Last Post: veselric
  [FIXED] Whatpulse 2.8 is not counting any network traffic Ractaros96 4 307 07-04-2017 02:04 AM
Last Post: Ractaros96
  Keys and clicks don't work satshow 1 356 04-25-2017 09:12 PM
Last Post: MrLinuxFish
  [CLOSED] Does WhatPulse and the WinPCap driver slow down internet? dandu3 2 993 08-06-2016 12:45 AM
Last Post: dandu3
  [CLOSED] Does whatpulse linux support Qt5 satshow 1 1,017 06-26-2016 06:19 PM
Last Post: smitmartijn
Bug [FIXED] Premium on site does not match premium on client fractalsauce 3 865 06-26-2016 06:10 PM
Last Post: smitmartijn
  Whatpulse not recording 1 specific key (d key) sirhephaestus 2 1,167 06-19-2016 02:06 PM
Last Post: smitmartijn
  WhatPulse don't work for me ImMario_ 1 799 06-19-2016 01:45 PM
Last Post: smitmartijn
  Will WhatPulse work on Intel Atom? Divisi 1 878 05-28-2016 08:06 PM
Last Post: smitmartijn
  WhatPulse not seeing that I'm connected to the internet Divisi 0 772 05-01-2016 06:34 PM
Last Post: Divisi

Forum Jump:


User(s) browsing this thread: 1 Guest(s)