WhatPulse Forums » Support » Client software v » [FIXED] WhatPulse 2.6: Mac OSX 10.9.5 Segmentation fault: 11 Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[FIXED] WhatPulse 2.6: Mac OSX 10.9.5 Segmentation fault: 11
05-14-2015, 08:49 AM (This post was last modified: 05-16-2015 10:47 AM by smitmartijn.)
Post: #1
[FIXED] WhatPulse 2.6: Mac OSX 10.9.5 Segmentation fault: 11
Running Mac OSX 10.9.5 64-bit.
After upgrading to 2.6 WhatPulse fails to start. When I run

/Applications/WhatPulse.app/Contents/MacOS/whatpulse

manually I get this output:

4-05-2015 11:38:11.155 INFO "Starting WhatPulse 2.6..."
14-05-2015 11:38:11.163 DEBUG Database file: "/Users/dkniaz/Library/Application Support/WhatPulse/whatpulse.db"
14-05-2015 11:38:11.165 DEBUG Database check: "ok"
14-05-2015 11:38:11.166 DEBUG Opened database in: 3 ms
14-05-2015 11:38:11.170 DEBUG Encrypted file: "/Users/dkniaz/Library/Application Support/WhatPulse/whatpulse.wpw"
Segmentation fault: 11

If I run

rm ~/Library/Application\ Support/whatpulse/whatpulse.wpw
rm ~/Library/Application\ Support/whatpulse/whatpulse.wpw.backup

then it starts, but asks me for credentials and computer name. On a restart everything reoccurs.

What's the issue here?
Find all posts by this user
Quote this message in a reply
05-15-2015, 10:19 PM
Post: #2
RE: WhatPulse 2.6: Mac OSX 10.9.5 Segmentation fault: 11
Hi,

Could you run the client with --verbose as parameter? So: "/Applications/WhatPulse.app/Contents/MacOS/whatpulse --verbose" (minus quotes)

If there's a "get_facebook_login" in the final sentence it's an issue that's universal to OSX/Windows/Linux and should be fixed very soon (waiting on confirmation from other people).
Visit this user's website Find all posts by this user
Quote this message in a reply
05-16-2015, 02:29 AM
Post: #3
RE: WhatPulse 2.6: Mac OSX 10.9.5 Segmentation fault: 11
Yep that's the problem:

15-05-2015 21:28:41.788 TRACE Settings::get( "login_via_facebook" )
Segmentation fault: 11
Find all posts by this user
Quote this message in a reply
05-16-2015, 10:42 AM
Post: #4
RE: WhatPulse 2.6: Mac OSX 10.9.5 Segmentation fault: 11
Version 2.6.1 has just been posted to fix this. Use the updater or download from http://whatpulse.org/downloads/
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [FIXED-SOON] Huge UI WP 2.8 Capt.Crash 5 1,090 11-21-2017 11:55 PM
Last Post: sena
Question Portable mode install mac client on windows T0X1CCAT 2 356 11-07-2017 04:43 AM
Last Post: T0X1CCAT
Bug [FIXED-SOON] Heatmap doesn't work in 2.8.1 veselric 12 2,461 10-31-2017 08:30 PM
Last Post: smitmartijn
  [FIXED] [linux|windows] Floating point exception FamilienVater 7 4,576 10-23-2017 05:53 AM
Last Post: Robby250
  Mac reinstall iOChris 0 361 08-18-2017 07:41 PM
Last Post: iOChris
Rainbow [FIXED] Strange bug that started a week ago? Naaaaaw 2 859 07-09-2017 02:35 PM
Last Post: Naaaaaw
Bug [FIXED] BUG: Client restarts every 17 minutes due to not detecting network adapter JigglyKing37 15 3,397 07-08-2017 07:33 PM
Last Post: smitmartijn
  [FIXED] Mac client causing latency every ~10 seconds bryandh 20 4,793 07-05-2017 08:27 PM
Last Post: dkuebric
  [FIXED] multiple wp icons commentator 5 1,241 07-05-2017 08:53 AM
Last Post: bill.junes
  [FIXED] Whatpulse 2.8 is not counting any network traffic Ractaros96 4 1,462 07-04-2017 02:04 AM
Last Post: Ractaros96

Forum Jump:


User(s) browsing this thread: 1 Guest(s)