WhatPulse Forums » Community » Beta client » Archive v » 2.1b1 crash Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2.1b1 crash
03-17-2013, 03:15 AM
Post: #1
2.1b1 crash
installed the new beta at release, about an hour later it crashed, I restarted it and now it just crashed again, the crash behaviour is:

computer locks up, about 10 seconds later my mouse catches up with the movement made during the lock up, a windows crash dialog box opens up with the following contents:

Quote:Files that help describe the problem:
C:\Users\samuel\AppData\Local\Temp\WER78F2.tmp.WERInternalMetadata.xml
C:\Users\samuel\AppData\Local\Temp\WER91A1.tmp.appcompat.txt
C:\Users\samuel\AppData\Local\Temp\WER91C1.tmp.mdmp

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=1...cid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

However the files listed do not exist, so...

This is on Windows 7.
Find all posts by this user
Quote this message in a reply
03-17-2013, 09:43 AM
Post: #2
RE: 2.1b1 crash
I think that's just Windows trying to be smart, the missing files. Please check if the installation went through properly - maybe even remove the entire previous installation before installing the new one. This is behaviour as described in 2.0.4.

Also check if you have a file called 'app.log' in your install dir - I'm especially interested in the last few file lines, or you can email the entire thing to me.
Visit this user's website Find all posts by this user
Quote this message in a reply
03-17-2013, 09:47 PM
Post: #3
RE: 2.1b1 crash
I experienced the exact same symptom on first use except I'm not sure if mine crashed after an hour or sooner. I also did not uninstall the previous version before installing the beta version.
Find all posts by this user
Quote this message in a reply
03-18-2013, 09:08 PM
Post: #4
RE: 2.1b1 crash
(03-17-2013 09:43 AM)smitmartijn Wrote:  I think that's just Windows trying to be smart, the missing files. Please check if the installation went through properly - maybe even remove the entire previous installation before installing the new one. This is behaviour as described in 2.0.4.

Also check if you have a file called 'app.log' in your install dir - I'm especially interested in the last few file lines, or you can email the entire thing to me.

I couldn't find that file so I uninstalled everything and then re-installed the beta, then it crashed again and I could find the listing files:

WER1E7C.tmp.appcompat -- http://pastebin.com/B4b6a9r0
WERE810.tmp.WERInternalMetadata -- http://pastebin.com/DN9d6mBK

Then after that crash I once again uninstalled everything and reverted to the live version of Whatpulse (download 36 on the downloads page) and now I have similar behaviour:

Every ~10 - 15 minutes my PC will freeze up for ~10 seconds; Whatpulse won't crash though. I've isolated this to Whatpulse, shutting down Whatpulse stops the problem.

Any way I can get a log for the non-beta version that can isolate this problem?
Find all posts by this user
Quote this message in a reply
03-19-2013, 10:49 AM
Post: #5
RE: 2.1b1 crash
The beta version is also crashing on my laptop running Windows 8...
I've tried opening the log file, but it seems it is re-written when I relaunch whatpulse...

Code:
19-03-2013 11:46:30.972  INFO Starting WhatPulse...
19-03-2013 11:46:31.362 DEBUG Database file:  "C:/Users/%username%/AppData/Local/WhatPulse/whatpulse.db"
19-03-2013 11:46:31.363 DEBUG Opened database in:  2 ms
19-03-2013 11:46:31.366 DEBUG Running WhatPulse as Administrator! :-)
19-03-2013 11:46:31.366 DEBUG Encrypted file:  "C:/Users/%username%/AppData/Local/WhatPulse/whatpulse.wpw"
19-03-2013 11:46:31.515 DEBUG enableInputHook:  true
19-03-2013 11:46:31.515 DEBUG LowLevelHookHandler starting
19-03-2013 11:46:31.515 DEBUG Enabling lowlevel input hooks
19-03-2013 11:46:31.516 DEBUG Starting PcapNetworkTrafficMonitor..
19-03-2013 11:46:31.600 DEBUG Found new interface:  24 "{955ADBC1-F4AE-450D-9EE0-7275371E1340}" "00:05:9A:3C:7A:00" "Cisco AnyConnect Secure Mobility Client Virtual Miniport for Windows x64"
19-03-2013 11:46:31.601 DEBUG PcapNetworkTrafficMonitor: Starting interface  24
19-03-2013 11:46:31.658 DEBUG Found new interface:  12 "{154D37D8-D54F-43FB-99B1-36EFDB0FD106}" "00:24:D7:95:EB:A8" "Intel Centrino Ultimate-N 6300 AGN"
19-03-2013 11:46:31.658 DEBUG PcapNetworkTrafficMonitor: Starting interface  12
19-03-2013 11:46:31.658 DEBUG pcap thread started on interface  "\Device\NPF_{955ADBC1-F4AE-450D-9EE0-7275371E1340}"
19-03-2013 11:46:31.727 DEBUG Found new interface:  13 "{E4A9868E-1F16-46AF-AD7D-946E587A9943}" "F0:DE:F1:60:65:1B" "Intel 82579LM Gigabit"
19-03-2013 11:46:31.727 DEBUG PcapNetworkTrafficMonitor: Starting interface  13
19-03-2013 11:46:31.727 DEBUG pcap thread started on interface  "\Device\NPF_{154D37D8-D54F-43FB-99B1-36EFDB0FD106}"
19-03-2013 11:46:31.794 DEBUG pcap thread started on interface  "\Device\NPF_{E4A9868E-1F16-46AF-AD7D-946E587A9943}"
19-03-2013 11:46:31.821 DEBUG WhatPulse has started

It has now counted only a quarter of my initial keys. I have uninstalled the previous version and re-installed from scratch, but this doesn't help.
I'll try to get the information from the log file when the application crashes.

Quote:If a law is unjust, a man is not only right to disobey it, he is obligated to do so. ~ Thomas Jefferson.
Find all posts by this user
Quote this message in a reply
03-21-2013, 09:46 PM
Post: #6
RE: 2.1b1 crash
I'm getting random crashes on Win7 about 1-2 times a day. I'll see if I can find app.log. I checked Event Viewer, and it's exception code 0xc0000005 again:
Code:
Faulting application name: whatpulse.exe, version: 2.1.0.0, time stamp: 0x51449875
Faulting module name: QtCore4.dll, version: 4.8.1.0, time stamp: 0x4f61952b
Exception code: 0xc0000005
Fault offset: 0x00034159
Faulting process id: 0x9a8
Faulting application start time: 0x01ce259eeb3f6fde
Faulting application path: C:\Program Files (x86)\WhatPulse2\whatpulse.exe
Faulting module path: C:\Program Files (x86)\WhatPulse2\QtCore4.dll
Report Id: 3ff84f80-91a2-11e2-81cd-3085a98d9b12

I've tried a complete uninstall, running as administrator, and giving user accounts full control permission for the WP install directory.

The good news about 2.1b1:
- After a crash, I can now start the program again without deleting the db
- No problems yet on WinXP

[Image: bigbanner2.gif]
Visit this user's website Find all posts by this user
Quote this message in a reply
03-22-2013, 09:54 AM
Post: #7
RE: 2.1b1 crash
Code:
Faulting application name: whatpulse.exe, version: 2.1.0.0, time stamp: 0x51449875
Faulting module name: QtCore4.dll, version: 4.8.1.0, time stamp: 0x4f61952b
Exception code: 0xc0000005
Fault offset: 0x00034159
Faulting process ID: 0xa4c
Faulting application start time: 0x01ce26d3eedee5ab
Faulting application path: C:\Program Files (x86)\WhatPulse2\whatpulse.exe
Faulting module path: C:\Program Files (x86)\WhatPulse2\QtCore4.dll
Report ID: dac92f73-92cf-11e2-be78-002215754867
Faulting package full name:
Faulting package-relative application ID:



Code:
Fault bucket -822547408, type 1
Event Name: APPCRASH
Response: Inte tillgänglig
Cab Id: 0

Problem signature:
P1: whatpulse.exe
P2: 2.1.0.0
P3: 51449875
P4: QtCore4.dll
P5: 4.8.1.0
P6: 4f61952b
P7: c0000005
P8: 00034159
P9:
P10:

Attached files:
C:\Users\cavveman\AppData\Local\Temp\WER280C.tmp.WERInternalMetadata.xml

These files may be available here:
C:\Users\cavveman\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_wha​tpulse.exe_b5d13d225b86b3752b8f64c9f4aee29189c6ad1_01b034e8

Analysis symbol:
Rechecking for solution: 0
Report ID: dac92f73-92cf-11e2-be78-002215754867
Report Status: 0
Hashed bucket: 5a9d36f9805a014a4d70d6388754f72d

And have same error as Bloopy
I dont have any log in my installationfolder, and no tmp file in Local\Temp
Find all posts by this user
Quote this message in a reply
03-23-2013, 03:34 AM
Post: #8
RE: 2.1b1 crash
Ok, I found that it only writes app.log if it's running as administrator. It crashed at 15:18:01, so the last log entry was 6 seconds before that:

Code:
23-03-2013 15:12:54.846 DEBUG Starting backup of database to:  "C:/Users/Bloopy/AppData/Local/WhatPulse/whatpulse.db.backup"
23-03-2013 15:12:55.166 DEBUG Created database backup in  320 ms
23-03-2013 15:17:54.851 DEBUG Starting backup of database to:  "C:/Users/Bloopy/AppData/Local/WhatPulse/whatpulse.db.backup"
23-03-2013 15:17:55.156 DEBUG Created database backup in  305 ms

No sign of any errors in the log, but I get a couple of warnings whenever I open the main window:

Code:
23-03-2013 02:03:19.058  WARN QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
23-03-2013 02:03:19.108  WARN QPropertyAnimation: you're trying to animate a non-existing property opacity of your QObject

[Image: bigbanner2.gif]
Visit this user's website Find all posts by this user
Quote this message in a reply
03-23-2013, 03:47 AM
Post: #9
RE: 2.1b1 crash
You don't need to check any further, they have to do with the network monitor, which I most likely have fixed for the next release. If you disable network, it'll remain stable.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  2.3b1 - OS X Networking crash JOE95443 6 8,425 11-16-2013 02:24 PM
Last Post: smitmartijn
  2.1b2 crash on start Maverick 2 5,395 04-06-2013 07:49 PM
Last Post: smitmartijn
  2.1b1 stops recording keys and clicks Maverick 4 6,721 04-06-2013 05:37 PM
Last Post: smitmartijn
  2.1b1 Minor issues AmpliDude 1 3,402 04-06-2013 05:28 PM
Last Post: smitmartijn
  2.1b1 main window doesn't open tim95 1 3,496 03-24-2013 10:02 PM
Last Post: smitmartijn
Information WhatPulse 2.1b1 smitmartijn 14 20,614 03-23-2013 06:08 PM
Last Post: smitmartijn
  2.1b1 Won't stay registered on Ubuntu dl1000v 2 4,738 03-22-2013 12:31 AM
Last Post: dl1000v
  2.1b1 not counting keys and sometimes clicks defurious 2 4,867 03-20-2013 08:52 AM
Last Post: defurious
  Windows Beta 7 Crash X-Kal 3 9,431 12-04-2012 09:52 PM
Last Post: X-Kal
  Windows b6 - Crash On hibernate Alakon9x 3 5,827 11-06-2012 07:05 PM
Last Post: Alakon9x

Forum Jump:


User(s) browsing this thread: 1 Guest(s)